1. GSDer's Avatar
    I was originally excited to see that the Samsung Galaxy S III included not only 802.11n support, but dual-band (2.4GHz & 5GHz) support. Unfortunately, I've had little success in getting the 5GHz connection to work - the phone sees the router but just won't connect at all/reliably.

    Before you ask:
    1. Yes, there are other devices that connect to the 5GHz channel just fine
    2. Yes, I've rebooted the phone; pulled the battery; etc.

    Anyone else using dual-band capability? Any other suggestions?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2
    08-27-2012 05:33 PM
  2. onslaught460's Avatar
    I'm able to connect to 5gz N and A networks without a problem on my phone.
    GSDer likes this.
    08-27-2012 06:07 PM
  3. GSDer's Avatar
    I'm able to connect to 5gz N and A networks without a problem on my phone.
    If you don't mind my asking:
    1. What brand router are you using?
    2. Do you have it configured to support 2.4GHz legacy connections (b/g)?
    3. Any other configuration settings that you can think of that might make a difference?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2
    08-27-2012 11:55 PM
  4. ansextra's Avatar
    I'm using a Netgear dual band and have no trouble connecting to 5GHz wifi.
    08-28-2012 10:24 AM
  5. robrecht's Avatar
    I have a Lynksys dual band router and Belkin dual band extender. No problems. No special settings, just everything as is out of the box.

    Thanks, Robrecht
    08-28-2012 02:25 PM
LINK TO POST COPIED TO CLIPBOARD