06-02-2013 12:38 PM
26 12
tools
  1. dfb8085's Avatar
    When are they ever going to fix the wifi reception problem? I was at yet another restaurant tonight with wifi. 1 bar signal rendered the phone unusable. My wife next o me with her blackberry full strength rocking along. I had to turn off my wifi to get the phone to switch to 4glte to be able to use it. Now if thats not a problem I don't know what is. I think unless I'm at home with a good wifi signal I am just going to leave it off. to much of a pain. help samsung or att or whoever. I'm beginning to wish I had kept my blackberry if it were not for the hugh screen and the fast processor.
    09-12-2012 09:22 PM
  2. Dizzo1992's Avatar
    I agree the wifi range on this stinks I'm always one or two baring it not far away from the router. While like my laptop has full bars my s3 has one. Hopefully jelly bean or something fixes this.

    Sent from my SCH-I535 using Android Central Forums
    09-12-2012 11:44 PM
  3. nbdiver's Avatar
    I am in the same boat. I can be two rooms away from my router and have one maybe two bars. And almost every morning I have to turn wifi off and back on because it shows my router is no longer in range! Probably my biggest complaint about the S3. What a terrible oversight! I am currently sitting 3 feet away from my router and still don't have full signal strength!
    09-13-2012 12:42 AM
  4. blade22222's Avatar
    This is not a issue with all, mine works pretty good. Might be a problem with your phone's.

    Sent from my SCH-I535 using Android Central Forums
    09-13-2012 10:07 AM
  5. ansextra's Avatar
    My wifi is the same as when I had my Droid X.

    Sent from my SCH-I535 using Android Central Forums
    09-13-2012 11:28 AM
  6. jontalk's Avatar
    Mine works great too.. I think it's your phone that may need to be restarted or replaced
    09-13-2012 01:45 PM
  7. nbdiver's Avatar
    Do you ever notice your wifi router not automatically connecting when you come home, or losing connection over night while charging? Mine does this and I typically have to turn wifi off and back on for it to pick up my wifi router again. I will put a ticket in with Verizon to see what they say. Mine is horrible so it must be a hardware issue. I have heard and read that the wifi antennae is not very good in this particular phone from Samsung though.
    Mine works great too.. I think it's your phone that may need to be restarted or replaced
    09-15-2012 12:27 AM
  8. riderrick65's Avatar
    My SG3 is about a week old and I'm still trying to learn all the things this phone is capable of. First off is trying to extend battery life (am getting there slowly)
    following all the good advise here on the AC forums. Second, my WiFi will only connect to an unsecured network (signal is weak) and with our router (that is
    used for our laptops) I can't connect at all and the damned thing is only 4 to 5 foot away in the same room! Any suggestions?
    09-19-2012 10:00 AM
  9. Archienj7's Avatar
    *#0011# from the phone dialer to get into the service menu is a good start, turn wifi power saving off, then if it still isn't somewhat improved, then you replace it. It's a known issue and some got out with bad wifi. Star, pound, zero, zero, one, one, pound. It's a good thing to memorize till you get it sorted out.
    riderrick65 likes this.
    09-19-2012 10:16 AM
  10. vanvar07's Avatar
    I'll join you guys! I have the same problem. Galaxy siii International, sometimes not able to connect at all leaving me with poor signal or authentication error even when it is at full bars. The most pathetic thing is that i live on university campus where we have a network of routers, so what my galaxy does, connects not to the closest router which gives me full bars, but to the furthest one leaving me with 1 or 2 bars at most.
    To be more specific, a single router has about 5 to 8 network names i.e. students, guests, faculty etc and all the routers have same names. so when i search for network and get full bars, after connection to it, my connected network shows 1 to 2 bars, while other university names still are on the full bars. In my assumption what it basically does is connect to the router which is further away. but i see no logic in it. SAMSUNG< please FIX IT!
    09-19-2012 10:17 AM
  11. riderrick65's Avatar
    *#0011# from the phone dialer to get into the service menu is a good start, turn wifi power saving off, then if it still isn't somewhat improved, then you replace it. It's a known issue and some got out with bad wifi. Star, pound, zero, zero, one, one, pound. It's a good thing to memorize till you get it sorted out.
    Thnx. will give it a try.
    09-19-2012 10:50 AM
  12. JWLthief's Avatar
    For some reason I started having wifi connection issues at my house a couple weeks ago. I never noticed it before. I know its not the router b/c my laptops connect just fine and my work cell phone (Motorola Atrix) connects fine as well. The S3 however has a weak signal wherever I go in the house. What gives? I tried the *#0011# trick and it didnt help. Do I call Verizon or Samsung about this? Is this a known issue with them?
    09-19-2012 11:57 AM
  13. riderrick65's Avatar
    For some reason I started having wifi connection issues at my house a couple weeks ago. I never noticed it before. I know its not the router b/c my laptops connect just fine and my work cell phone (Motorola Atrix) connects fine as well. The S3 however has a weak signal wherever I go in the house. What gives? I tried the *#0011# trick and it didnt help. Do I call Verizon or Samsung about this? Is this a known issue with them?
    I tried the *#0011# trick also, but it didn't seem to help either. It will connect to a weaker non secured WiFi connection, but it won't connect to my router which
    is in the same room (about 5ft. away) and both of our laptops are connected to it also with no problems. I guess I'll try AT&T first, then if I don't get any resolve
    than I'll contact Samsung.
    09-19-2012 12:27 PM
  14. riderrick65's Avatar
    Ok things are working now! I contacted AT&T and the serv. tech had me do a few things then I came back to the wifi page, I had to log in again and low &
    behold I had the wrong password typed in before (hence the connection problem with my home router.
    09-19-2012 01:15 PM
  15. Eric_L_1's Avatar
    Hey Everyone,

    Sounds like there is a fix for some of you (previously stated in this thread)

    I spoke with a Verizon Technical Support Specialist

    Without saying so directly (I had to read between the lines) He said, they prefer for us to use 4gLTE and pay for the usage.

    .....

    In other words these aren't just known issues - these are deployed tactics!

    -As Always- Thanks for all of the useful information - To everyone participating in this Thread!
    Archienj7 likes this.
    09-19-2012 01:30 PM
  16. Almeuit's Avatar
    I am in the same boat by the bars show low, however, it does not kill my wifi. You said with that 1 bar you couldn't do anything.. If I go across my house from the router ill drop to 1 bar but I can still do everything I could on my wifi connection just like if I was next to the router with full bars. So not sure why your wifi didn't work with only 1.

    I'm on the sprint s3.

    Sent from my SPH-L710 using Android Central Forums
    09-19-2012 02:36 PM
  17. hangnaround's Avatar
    No. Physical antenna issues with cellular and wifi. Hate s3 for it. But more and more manufactures just assume we are all living in emetro cities with towers everywhere.
    09-20-2012 12:45 AM
  18. JWLthief's Avatar
    Hey Everyone,

    Sounds like there is a fix for some of you (previously stated in this thread)

    I spoke with a Verizon Technical Support Specialist

    Without saying so directly (I had to read between the lines) He said, they prefer for us to use 4gLTE and pay for the usage.

    .....

    In other words these aren't just known issues - these are deployed tactics!

    -As Always- Thanks for all of the useful information - To everyone participating in this Thread!
    Wow...so somehow Verizon is doing this on purpose via software? How are people not up in arms about this?
    09-20-2012 01:32 AM
  19. ericner#AC's Avatar
    Never had this problem with my Thunderbolt. I have a router and an access point in a small house, and my S3 constantly loses wifi signal. Did the whole thing on the wifi service menu but no help.

    Some people have said that this is a hardware issue and I should exchange the phone. But when I see so many people posting on this thread and this one as well... http://forums.androidcentral.com/sam...onnecting.html
    I'm pretty sure this isn't just my hardware.
    09-20-2012 07:07 AM
  20. seoulbrova's Avatar
    Sprint S3...I initially had problems and tried the 'secret menu' suggestion here and it resolved my issues.

    It'd be interesting to see if this is a Verizon issue or hardware issue.
    09-20-2012 11:30 AM
  21. Dizzo1992's Avatar
    Yeah I'm curious if it's a Verizon issue cuz that would be messed up. It's the only thing I dislike about the galaxy s3 its very frustrating.

    The amazing galaxy s3
    09-20-2012 12:28 PM
  22. Archienj7's Avatar
    It is a hardware and possibly software issue. Some got out early on with bad wifi components, they knew it after so many reports and they quickly offered to fix it if they couldn't resolve the issue remotely when my first phone went bad. Mine started acting up slowly till three weeks in it all went out. Wifi, mobile, only the actual phone part would work. No data at all. I got it replaced on the 29th day of my 30 day window luckily. Thing is is along with JB (whenever we get it) there's also supposed to be a wifi fix included supposedly. I can't remember where I read it or cite the source but I know it isn't a "he tell me" thing. I did read it was supposed to be coming. My replacement has been fine though and I haven't really needed to use the service menu trick much at all. Four times tops.
    09-20-2012 11:10 PM
  23. Dizzo1992's Avatar
    Maybe I'll ask my store just put my s3 side by side with my old DROID incredible 2 the incredible 2 had steady 3 bars with wifi and my s3 was at 1 and dropping to no bars. I'm thinking it's my phone.

    The amazing galaxy s3
    09-21-2012 02:03 PM
  24. Archienj7's Avatar
    Maybe I'll ask my store just put my s3 side by side with my old DROID incredible 2 the incredible 2 had steady 3 bars with wifi and my s3 was at 1 and dropping to no bars. I'm thinking it's my phone.

    The amazing galaxy s3
    I would have it checked out personally.
    09-22-2012 11:08 PM
  25. Exploited's Avatar
    If this can not get fixed, this is unfortunately a deal-killer for me. Having passed on the iPhone 4S and with the 5 being boring, I decided Android is way more fun and I can do lots more. So yesterday I turned in my venerable iPhone4 for a sweet Galaxy S3 and absolutely love it. Not sure I am even going to root it, but yeah, probably will. HOWEVER, this wi-fi thing is killing me.

    I have a larger house and put in and configured three wireless access points (WAP's) using DD-WRT flash of the trusty Linksys WRT-54 series.

    The family iPhones and a Galaxy S2 have never had an issue roaming around the property and switching seamlessly to the nearest WAP. I have a single network, WPA2, g-only.

    But this GS3 is a bugger. Weak signal unless I am right in front of the router. No matter if I move to in front of a WAP or restart wi-fi, it never hooks to them.

    This is bad as I do a lot with the wi-fi around my house.

    I do not want an HTC One X, it's GS3 or iPhone 5. I have looked into this online searching and it seems that this is still ongoing after many months.

    I seem to have two issues, the common wi-fi range thing, and this WAP switching which I can find nothing on.

    I have tried the *#001# and updated from AT&T and nothing has worked.
    09-29-2012 01:33 PM
26 12

Similar Threads

  1. WiFi connection problems
    By yogibimbi in forum Other Sony Android Phones
    Replies: 1
    Last Post: 10-04-2010, 03:16 PM
  2. Apple responds to reception problem:
    By Jerzyiroc in forum HTC EVO 4G
    Replies: 11
    Last Post: 06-25-2010, 11:22 PM
  3. Wifi streaming problems?
    By shaunm89 in forum Google / HTC Nexus One
    Replies: 3
    Last Post: 06-13-2010, 02:33 PM
  4. WIFI connection problems
    By Raija in forum HTC Desire
    Replies: 6
    Last Post: 05-20-2010, 06:24 AM
  5. Really bummed out - Droid Reception Problem/Bug?
    By tempspace#AC in forum Motorola Droid
    Replies: 9
    Last Post: 11-09-2009, 12:50 PM
LINK TO POST COPIED TO CLIPBOARD