03-28-2015 08:58 AM
42 12
tools
  1. lesorkim's Avatar
    Had this posted over at Google Help, but does not seem to be a pool of knowledgible people, like here!

    Gmail 4.1.2, Andriod 4.0.4, Samsung Galaxy Siii phone, Verison Wireless.
    At my work cubicle I have nearly zero cellular reception. HOWEVER when I am at work, most times, I am connected to the company wi-fi.

    When I send an email from work email account to my Gmail account I generally never get it until I move through a part of the building with cell reception or go outside. However, at my desk, if I launch gmail AND click the refresh button at the bottom left of the app it will find the sent email.

    I am guessing that this forces a "sync" (? right word?) with my gmail account via wi-fi/internet? If this is correct, can I change a setting somewhere that syncs my emails via cell, and then wi-fi if not available? (and if so, can we adjust the frequency that it forces a sync via wi-fi, something like once every few minutes.
    10-03-2012 02:49 PM
  2. Skunkape60's Avatar
    I don't know about your phone but with my phone you don't have to do anything. It will automatically use Wi-Fi if available and connected. No settings changes required. My guess is it was a coincidence that the mall came when you left Wi-Fi to the cellular data. My gs3 and Gmail gets my mail ask the time on Wi-Fi and I've never made any settings changes.
    10-03-2012 02:59 PM
  3. lesorkim's Avatar
    I hear what you are saying, but I can reproduce the issue numerous times. Trust me, once every two weeks when the wife says, "I emailed twice and sent text messages twice to (fill in the blank), and you're saying you didn't get the message??!!!"
    10-03-2012 03:13 PM
  4. unlmtdRW's Avatar
    I have the same version of Gmail, phone, and carrier so thought I might throw in a few items at the risk of seeming like I'm stating the obvious, but... here goes, bear with me...
    I have to assume you have some of the basic settings enabled, like the following:
    1) Settings > Wireless and Network > Wi-Fi > Advanced -- "Keep Wi-Fi on during sleep" = Always?, and
    2) Settings > Personal > Accounts and sync -- your Gmail account in "Data and synchronization" does have "Sync Gmail" checked, right?, and
    3) In the Gmail app > Settings > your account -- the "Download attachments" setting is checked (to auto-download att. to recent messages via Wi-Fi)?
    ... like I said, maybe pretty obvious things for some people, but I remember having to specifically check one or two of those myself when I was originally tweaking the phone for myself.
    GSDer likes this.
    10-03-2012 11:19 PM
  5. Tkbredx's Avatar
    Not sure but you could always find an app
    10-04-2012 01:32 AM
  6. walcolm's Avatar
    I have the same version of Gmail, phone, and carrier so thought I might throw in a few items at the risk of seeming like I'm stating the obvious, but... here goes, bear with me...
    I have to assume you have some of the basic settings enabled, like the following:
    1) Settings > Wireless and Network > Wi-Fi > Advanced -- "Keep Wi-Fi on during sleep" = Always?, and
    2) Settings > Personal > Accounts and sync -- your Gmail account in "Data and synchronization" does have "Sync Gmail" checked, right?, and
    3) In the Gmail app > Settings > your account -- the "Download attachments" setting is checked (to auto-download att. to recent messages via Wi-Fi)?
    ... like I said, maybe pretty obvious things for some people, but I remember having to specifically check one or two of those myself when I was originally tweaking the phone for myself.
    I'm pretty sure going through the checks above should resolve the OP's Gmail issues.

    My gmail works so long as I have internet access be it cellular or WiFi

    Sent from my GT-I9300 using Android Central Forums
    10-04-2012 03:37 AM
  7. lesorkim's Avatar
    I have the same version of Gmail, phone, and carrier so thought I might throw in a few items at the risk of seeming like I'm stating the obvious, but... here goes, bear with me...
    I have to assume you have some of the basic settings enabled, like the following:
    1) Settings > Wireless and Network > Wi-Fi > Advanced -- "Keep Wi-Fi on during sleep" = Always?, and
    2) Settings > Personal > Accounts and sync -- your Gmail account in "Data and synchronization" does have "Sync Gmail" checked, right?, and
    3) In the Gmail app > Settings > your account -- the "Download attachments" setting is checked (to auto-download att. to recent messages via Wi-Fi)?
    ... like I said, maybe pretty obvious things for some people, but I remember having to specifically check one or two of those myself when I was originally tweaking the phone for myself.

    "at the risk of stating the obvious", well, I usually find that the obvious is usually the problem, or rather, my not noticing the obvious is the problem So thanks for taking the basic approach.
    1. Wi-Fi on during sleep IS set to Always. (It also happens when unit is awake for 10 minutes straight.)
    2. Sync Gmail Checked? When I open "Accounts and Sync" the slider switch at the top is set to "ON" and there are the sync logos (two green arrows) next to the two accounts below. I find "Google" (my name)@gmail.com, and "Skype" with my account name. When I select Google the next screen I find a list of things checked like Sync Calendar, Sync Chrome, Sync Contacts, and Sync Gmail. Unchecked are Play Book, Play Music, Sync Internet.
    3. In the Gmail App checked is D/L attachments. It also shows "Gmail sync is ON" .
    Also, uninstalling Tasker and rebooting right now. I'm pretty sure this has been going on before it was installed, but don't want to find out that one of my experiments in there went haywire.
    10-04-2012 09:00 AM
  8. unlmtdRW's Avatar
    Hmmm, okay... how hard can this be? The S3 is just a computer, so it's logical, right? There's an answer, it's just that we need to find it.
    Troubleshooting 101 --- Have you previously been able to receive gmail messages via your company wi-fi and it stopped working, or is this an "it's always been this way" thing? Next question, does your company block access to gmail from the company network, i.e. firewall blocks? (so if you were to try accessing gmail from your workstation using desktop browser would it work?)
    Edit: Re-reading your original posting, I think you've answered the above by saying you can manually force a sync over company wi-fi and it does get the emails. Alternate question in same vein... Have you confirmed whether gmail auto syncs for you over other wi-fi connections?
    lesorkim likes this.
    10-04-2012 10:11 AM
  9. lesorkim's Avatar
    " Have you previously been able to receive gmail messages via your company wi-fi and it stopped working, or..."
    I'm not really sure now that I think of it. My previous cell phones did not have wi-fi ability.


    Have you confirmed whether gmail auto syncs for you over other wi-fi connections?
    No, and I was just thinking, where could I find a place out in the sticks with wi-fi and but no cell coverage. (I left my portable faraday cage at my brothers house.) Can I force the phone to use wi-fi ONLY?

    Just to follow up; I did uninstall Tasker and sent an email with the same results - no email recieved until sync forced.

    I need to try this on another wi-fi, like home or Starbucks. The wi-fi access points here at work may have their own issue. I have checked with three other cell phone users. One with a SGS3, and iPhone 4, and some other android phone. All three of them (and I) can't see the access point. (I put in the SSID and Key like it's hidden. The others don't work in I.T. so they can't access at all) However, if I go to a zotac desktop computer with wireless, it sees that there are four wireless channels here at work, and one across the street at another company. The WiFi is NOT configured to be hidden. In any case, I think you are right, the next step in troubleshooting is to see if this behaves the same on a different WiFi.

    So that brings me back to; can I turn off the cell radio so it can only communicate via wi-fi. If that's the case, I'll run by McDonalds today.
    10-04-2012 11:18 AM
  10. unlmtdRW's Avatar
    So that brings me back to; can I turn off the cell radio so it can only communicate via wi-fi. If that's the case, I'll run by McDonalds today.
    Yep, the quickest way I find to turn off the LTE/data connection is to pull down the Notifications area and on the toggle bar at the top, tap "Mobile data" so it greys out. That should turn off your data connection to Verizon. Just make sure your wi-fi is enabled and you're connected to a network. Then maybe send yourself an email and see if it gets pushed to you.
    I regularly connect to wi-fi networks that both broadcast SSID and not, secure and not, and my auto sync always seems to be working fine -- at least I haven't become aware of not receiving any emails someone has expected me to get -- kinda coming full-circle back to your comment from before about "not noticing the obvious" (we're all guilty of that from time to time). *heh*
    10-04-2012 04:50 PM
  11. lesorkim's Avatar
    Ok, turned off "Mobile Data" in the settings area. Sent an email from home computer to phone. Recieved it instantly. So, I think that proves that my phone is working properly? Right?
    10-06-2012 09:32 AM
  12. unlmtdRW's Avatar
    Based on what you're saying, you were connected to home wi-fi and it worked. So, yes, it would seem to demonstrate that your phone works properly to allow gmail to auto sync over wi-fi. The "problem" then seems to rest with the company wi-fi connection? Maybe that connection does perform some firewall blocking?
    Do you often run with both "mobile data" and wi-fi enabled/on at the same time? (I am always running either one or the other, rarely or never both radios on at same time, so just asking out of curiousity.)
    10-07-2012 12:48 PM
  13. lesorkim's Avatar
    "Do you often run both mobile data and wi/fi?"

    Perhaps this needs its own thread? Yes I have just left both on. When it finds my home wi/fi or work wi/fi it automatically connects, otherwise it uses mobile data. Other than battery use, is there a downside to leaving both available? My understanding is that if wi/fi is available it will use the wi/fi rather than mobile data, right?
    10-08-2012 08:46 AM
  14. unlmtdRW's Avatar
    Other than battery use, is there a downside to leaving both available? My understanding is that if wi/fi is available it will use the wi/fi rather than mobile data, right?
    I'm not aware of any downside other than battery drain (anyone else feel free to comment otherwise). I believe you're right that "by default" the S3 will use wi-fi when available rather than mobile data, no worries. I regularly get at least 36-40 hours life before I have to charge, and thought that was pretty good for a smartphone, so thought I'd ask. Other than that I guess it depends on how concerned a person is with bumping into their plan data limits. If mobile data is manually shut off then there's no chance of blowing through and racking up extra charges... or it could just be a 'control thing'.
    10-08-2012 10:08 AM
  15. moda.root's Avatar
    Yes u can that's what just sinin to your google account you'll receive email from your gmail account automatically

    Sent from my LS670 using Android Central Forums
    10-08-2012 10:11 AM
  16. lesorkim's Avatar
    UnlimtdRW: We have three phones sharing 8GB of data/mo and are not getting even close. I think we will move it down to 6G/mo and still have lots of breathing room. But your idea about turning off mobile data to prevent accidentally running over is a good idea. We had one month where the home wi-fi was down one night and they boy burned through 2GB of data on YouTube that night. Also regarding hours of use, most days I don't have an issue with battery life (just charge overnight each night). Some days it drains early, but that's when I am reading news for long periods or playing games.
    10-08-2012 10:50 AM
  17. lesorkim's Avatar
    MODA.ROOT: I dont' understand what your post is referring to
    10-08-2012 10:52 AM
  18. worwig's Avatar
    Edit:
    Deleted bogus info about needing text messages to trigger push Gmail.
    10-08-2012 11:10 AM
  19. lesorkim's Avatar
    WORWIG: I think we have determined that this issue is local to our work wi-fi system, as the phone works as expected on another wi-fi system.

    But, your hypothosis is; if I can't recieve a phone call, THEN I will not have my emails pushed to me over a wi-fi connection. However, IF I am on a wi-fi connection I can force a sync from my end over Wi-Fi?

    For instance, I can think of a particular situation where this comes up. Where we go camping in Central Missouri, there is no cell tower connection available for 10 miles. Therefore, I can not place or recieve a cellphone call or text message. HOWEVER the campground has free wi-fi available. Under your hypothosis, I should not be able to send/recieve email at all since I don't have cellphone available. I can tell you that I was able to send an email from there, but I don't recall the circumstances for recieveing email, as in, did I have to force a sync or not.
    10-08-2012 11:37 AM
  20. OWybPPgO's Avatar
    I get this at work too. When on my work wifi, gmail, gtalk, and the play store aren't dependable, so I just keep my S3 on LTE.

    Last year we were doing a bunch of Android development and my dept mgr tried to resolve the issue with the IT since it was interfering with our work but no such luck.
    10-08-2012 12:33 PM
  21. lesorkim's Avatar
    I get this at work too . . .so I just keep my S3 on LTE.
    Well... two things,
    1. from my original post "I have nearly zero cell reception at work", and
    2. Why run up data costs when free wi-fi is available?

    Since we have determined that this is unique to our wireless connection point here, we are going to look into that a little more.
    10-08-2012 01:44 PM
  22. OWybPPgO's Avatar
    Well... two things,
    1. from my original post "I have nearly zero cell reception at work", and
    2. Why run up data costs when free wi-fi is available?

    Since we have determined that this is unique to our wireless connection point here, we are going to look into that a little more.
    I wasn't suggesting you follow my example, just giving you my data point to agree that it definitely can be the work network interfering with some google services.

    As to point 2 - I have unlimited. I would use wifi if it behaved as well for me, but it doesn't.
    funkylogik likes this.
    10-08-2012 01:49 PM
  23. unlmtdRW's Avatar
    @worwig & @lesorkim,
    This issue has gotten me curious, so I've been poking around the "interwebs" seeing if there's any helpful tidbits out there (mainly to satisfy my own curiousity, but also to contribute anything useful here if I can). I'm intrigued by worwig's description of the way he believes Google's activesync works -- relying on cell network reception for notifications to nudge phone to receive emails as opposed to relying on the data connection -- and I'll admit to being a bit of a geek when it comes to finding out "why" something works or doesn't.
    I came across a Gmail synching troubleshooting guide from Google Support (here) and by their description,
    "The Gmail app needs an active data connection (mobile network or Wi-Fi) to sustain auto-sync.
    • Make sure your device is not in Airplane mode.
    • Make sure your device has a working signal.
    • Verify that your device can get online (try going to a website in Browser)."
    ... it does not explicitly mention cell reception, however the check for "Airplane mode" and "working signal" certainly might imply this.
    I guess this is not really helpful, more food-for-thought genre. If anyone else knows something more concrete, I'm interested.
    lesorkim likes this.
    10-09-2012 02:50 PM
  24. lesorkim's Avatar
    UnlmtdRW: I really appreciate your tenacity on this issue. My posting at Google's own forum for their product has gone unanswered entirely. I am going to be out later today and will purposefully try a couple other wifi locations to see if it (as expected) works perfectly. I know the network admin here asked his CISCO buddy to see what they knew about this - but no new info yet.
    10-09-2012 03:24 PM
  25. mobdad's Avatar
    Had this posted over at Google Help, but does not seem to be a pool of knowledgible people, like here!

    Gmail 4.1.2, Andriod 4.0.4, Samsung Galaxy Siii phone, Verison Wireless.
    At my work cubicle I have nearly zero cellular reception. HOWEVER when I am at work, most times, I am connected to the company wi-fi.

    When I send an email from work email account to my Gmail account I generally never get it until I move through a part of the building with cell reception or go outside. However, at my desk, if I launch gmail AND click the refresh button at the bottom left of the app it will find the sent email.

    I am guessing that this forces a "sync" (? right word?) with my gmail account via wi-fi/internet? If this is correct, can I change a setting somewhere that syncs my emails via cell, and then wi-fi if not available? (and if so, can we adjust the frequency that it forces a sync via wi-fi, something like once every few minutes.
    The phone will typically choose a WiFi connection over a cellular data connection when they're both available. Your problem may have occurred because you either are not synching your account automatically or the frequency is a long time (You can sync automatically as frequently as every 5 minutes OR you can set it for as infrequent as once a day).
    10-09-2012 03:36 PM
42 12

Similar Threads

  1. Gmail push email on Wi-Fi
    By sisblub in forum Verizon Galaxy Nexus
    Replies: 3
    Last Post: 03-10-2012, 03:29 PM
  2. Google sign-in? I can not log back in.. what to do?
    By Chilly818 in forum Android Apps
    Replies: 0
    Last Post: 10-03-2011, 11:50 AM
  3. Replies: 0
    Last Post: 02-10-2011, 06:30 PM
  4. Stopping FB info to my email on Droid X
    By a1mommy1372 in forum Motorola Droid X
    Replies: 1
    Last Post: 08-09-2010, 06:42 PM
  5. How to mount Droid via Wi-Fi/3G and Windows 7?
    By matrix2004 in forum Motorola Droid
    Replies: 0
    Last Post: 03-14-2010, 12:08 AM
LINK TO POST COPIED TO CLIPBOARD