1. Mattman3234's Avatar
    Hello everyone! Longtime BB user and made the jump to an S3 (still keeping my eye on that BB10 :-). I have a weird issue that I'm hoping someone can help me with. I have the S-Planner synced to my exchange acct and everything had been working well for 2 months. I went on a trip where the timezone was off by an hour. When I returned some of my recurring appts are now all stuck behind by an hour. They appear fine in my outlook calendar on my laptop, on my ipad and my playbook. The only device with the wrong time for these meetings is the phone (I even downloaded a second calendar app in Google calendar and it had the wrong times in there as well). I uninstalled my exchange acct and cleared all the cached data so it would have to re-sync from scratch (did this twice) and it still downloaded the appts at the wrong time. I've checked the timezone on the calendar and on the phone (both are auto synced to the carrier) and checked the timezone in the individual events and it shows as EST -5 which is correct for me. I'm stumped...some of these recurring appts are mine I created and some are other meetings I was invited to. Any thoughts? I would hate everytime I travel to a new timezone that all my appts get screwed up.


    11-14-2012 09:59 PM
  2. DM51's Avatar
    There's a setting somewhere in S-Planner where you can lock it to your home time zone or let it auto-adjust to wherever to travel to. I had trouble with this as well, so I now lock mine to home.

    Consider getting the Android Google Calendar app for your S3 it is a LOT better than S-Planner. You'll need to sync your exchange calendar to a Google calendar on your PC, but that's not difficult to do, and it will then sync properly with the phone.
    11-19-2012 02:59 AM
  3. EvilMonkey's Avatar
    That setting is just in Menu-> Settings.

    FWIW, I do NOT have that selected, and just got back from a trip where I flew from EST (GMT-5) to PT (GMT-8), drove to MT (GMT-7), drove back to PT, then flew back to EST. All my appointments were fine and adjusted accordingly depending on which timezone I was in.

    I would first check your computer/laptop and make sure the time is ok there and it doesn't think you're still in the other timezone. If so, it might be syncing back to Exchange and screwing up the calendar on your phone.
    11-19-2012 12:14 PM
  4. mfarquharson2's Avatar
    I am having a similar problem, except that I did not travel. I believe the trigger was thethe Day light saving time change in October.

    Here's what is happening:

    - Outlook PC - everything is correct, all appointments/meetings are scheduled at the correct time
    - Iphone - everything is synched correctly with Outlook exchange account.
    - Samsung S3 - some appointments are synched correctly and some are not.
    - recurring meetings that were booked prior to the daylight change are showing one hour before (i.e. a 10am meeting is now at 9am) This applies for meetings that I have booked as well as meetings which I am an attendee. This is not consistent either. Some of the meetings are showing up correctly.
    - recurring meetings that have been cancelled for this week are still showing in my calendar. This applies for meetings that I have cancelled as well as meetings which I am an attendee and others have cancelled. This is not consistent either. Some of the meetings are removed and some not.
    - new meetings (single instance and recurring) which have been booked after the time change seem to be working fine.

    Again everything is fine in Outlook, and my iphone, the problem is with the my Android Phone (S3). Also my google calendar appointments are syncing fine. Its just the outlook calendar.

    Note - I have tried this with both the Google Calendar and the SPlanner with the same results. I have also deleted my exchange account, deleted all data in the Google Calendar, and uninstalled and reinstalled. I have also checked the timezone setting in the app and in the main settings and they are set to "Use network-provided time zone"

    I would really appreciate if someone has any thoughts on this, as right now I can't use my android to reliably view my outlook (i.e. work) calendar. Thanks!
    11-23-2012 10:40 AM
  5. strutswell's Avatar
    I noticed the same thing when my weekly meeting is now showing up as 1 hour earlier! Who wants to show up 1 hour early? Not this guy...

    Anyone figure out a fix for this? I'm thinking the only way around it is to create a new meeting request every 6 months for this DST change.

    Same as previous post I see everything is fine in Outlook/Exchange, but when I view it on the S-Planner calendar it is 1 hour behind. As if it is compensating for DST time when really it shouldnt bother. Outlook specifically does not change anything for DST.
    01-04-2013 09:25 AM
  6. EvilMonkey's Avatar
    I really don't have a good solution, but the things I would check are to make sure everything is set up correctly as far as time zones go on each device. For instance if you live in Eastern (UTC-5), make sure that's what you have selected, and you didn't accidentally select one of the other UTC-5 ones (such as Bigota or Indiana).

    If it's Exchange, I would check with your network admin to make sure the Exchange server settings didn't accidentally get set to the wrong time zone or something.

    The symptoms you point to really just tell me a time zone is off somewhere (the device and the Exchange server thinks they're in separate time zones, or one didn't get reset to the correct time when the change occured or rebooted). My guess is it's the Exchange server since I'm sure you'd notice if your phone was displaying the wrong time.
    01-04-2013 11:25 AM
  7. WillowBat's Avatar
    This is happening to me too - it is definitely the S3 that is wrongly adjusting the times, because outlook and other mobile devices are still correct. The "keep time zone" checkbox does not overcome this - which points to a daylight savings time issue.

    It's quite a nasty bug too: for example, birthdays (or other annual events) can get kicked back a whole day if they are moved from 00:00 to 23:00.
    01-08-2013 04:42 AM
  8. mfarquharson2's Avatar
    I agree its definitely the android, if it was the exchange server that was off wouldn't the calendar on my other device then be off as well? My iphone calendar is working fine.
    01-08-2013 11:39 AM
  9. flixxx's Avatar
    Hi gang,

    I agree that this is a problem with the S3.

    I just migrated to the exchange server from a propriatary service called "Good for mobile" (Think of it as a RIM knock off for iphones and Androids). Good always displayed the correct time for all events (In fact it still does since i'm on both platforms). On theo ther hand the Samsung S planner, as well as the google calendar that are synched via exchange are showing a 1 hour difference on "some" recurring events.

    It definitely seems like a DST issue
    01-10-2013 10:33 AM
  10. spicyolive's Avatar
    I too am having the same issue with meeting times. I have noticed recurring meetings that have been in my calendar a while or before I got the phone are an hour early. I also noticed that some meetings organized from a person in another timezone (they are in CST and i am in EST) are ending up an hour early.

    I switched over from a Blackberry as well and never experienced problems like this before. Makes me think about switching back...
    01-14-2013 09:09 AM
  11. KNeger's Avatar
    I have just switched from HTC Desire to One X and experience this with most of my contact birthdays with the OneX (not on Desire before) in the standard Google Calendar App. I sync my calendar from an Exchange environment.
    Birthdays of people before, approx, 1984 now show as appointment starting at 23:00hrs and ending the next day at 23:00 hrs. This is messing up my overview of a day.
    Now I just entered a new contactperson with Birthday 17th of March 1984 and shows correctly as All-day-event on top of day-view starting at 00:00hrs at 17th and ending at 00:00 18th. When I change the birthday to 16th of March 1984 (or earlier) it switches back to starting 16th at 23:00hrs and ending at 17th 23:00hts again...
    This could implicate couple of thing...
    - I live in timezone UTC+1 (CET), so there could be an Time Zone issue, but they are all correct and the same as far as I can see
    - something is changed in DST, but as far as I know not the case in Europe
    - Microsoft is mentioning a DST change tool, that would be for USA DST change, but the date does not correspond with 1984
    - Microsot has rolled-out a work-around in all of their products, but in the back-ground the data is still corrupt.
    - Android has a serious bug to fix?

    Anyone any idea? It really makes me crazy

    P.S. my iPad, Outlook 2010 and OWA all show birthdays correctly
    01-16-2013 07:50 AM
  12. dajay0's Avatar
    Interestingly I had a similar problem - my S3 was not syncing Exchange calendar at all (using S-Planner). In spite of everything being correct. The S-Planner has a Settings -> Sync option. This does a force sync on the S-Planner. When I clicked that, it popped up a message "The end user license agreement with Samsung has changed. Please accept the new one to continue using the services" or something like that. When I accepted the new agreement, everything came back to normal.

    So the moral of the story - my S3 was waiting for me to accept the new terms without telling me that it was waiting Go figure.
    02-05-2013 07:54 PM
  13. haoleboy's Avatar
    i agree VERY frustrating .. i had an HTC myTouch android and never encountered this .. so it does point to S3 so far .. has anyone heard of any solution or work arounds??

    03-20-2013 11:40 AM
  14. Nader Newman's Avatar
    I've been having the same issue as everyone and it is indeed a daylight savings time problem. This issue is that S Planner is too stupid to change from Standard Time to Daylight Savings Time. In order to correct the problem launch the stupid S Planner application go to "Settings" then "Select time zone". You will then see an option for Standard Time as well as Daylight Time for the time zone you are in. In my case I switched from Eastern Standard Time to Eastern Daylight Time.
    03-21-2013 08:35 PM
  15. Roy V's Avatar
    Same problem as the rest of you.

    Outlook OK
    Other devices OK
    Samsung Galaxy S2 one hour off

    .....and by the way:
    If I have a meeting at 3 o'clock, the meeting still starts at 3 o'clock after/before DST.
    If my friends birthday is on the 19th, that does not mean his birthday is 23PM on the 18th.

    I find I very strange: they can do voice recognition, understand handwriting, they now where you are and can point you to the nearest anything.
    But they can't figure out how to deal with the DST. Kids in first grade can do it!
    04-12-2013 12:45 AM
  16. Gordp's Avatar
    This is still not fixed. Samsung don't take it seriously.

    I have escalated this to Samsung Engineering and after 3 months all they do is blame everyone else. My Exchange server, Outlook, etc. etc. must be set up wrong. They sent some moron over to take pictures of my phone and all the settings. Let's face it everyone has this problem, and the product is defective.

    My staff and I use this phone for business. Can you imagine being an hour late for Customer meeting, Unacceptable.

    I think everyone needs to return their phone. Apple doesn't have this problem.
    09-05-2013 07:12 AM
  17. KNeger's Avatar
    Well, Gordp, it is not only a Samsung issue; got the same issue on my HTC One X; see post:
    My conclusion is that it must be in Android...
    09-05-2013 07:32 AM
  18. GSDer's Avatar
    Have you guys (that are using Calendar: http://market.android.com/details?id...droid.calendar) thought of filing an issue with Google? https://support.google.com/calendar/?p=mobilesync

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 2
    09-05-2013 08:06 AM
  19. Gordp's Avatar
    KNeger DIfferent problem. I am talking about a problem that only occurs when DST switches and some recurring meetings get moved by one hour. My 3:00 meeting shows at 4:00. Other non recurring meetings are fine. My sons HTC doesnt do that.
    09-05-2013 02:22 PM
  20. DM51's Avatar
    Guys, the best solution is just to disable S-Planner completely and use Google Calendar or Week Calendar instead.
    To disable S-Planner, see this link: http://www.talkandroid.com/guides/beginner/how-to-disable-unwanted-system-apps-and-bloatware-from-your-android-phone-android-4-0-and-up/
    09-06-2013 01:46 AM
  21. Martin Jaron's Avatar
    Hi, did you find any way how to resolve this issue? I have same problem when Day light saving time change for meetings, when meeting request sent by someone from different timezone to outlook. Outlook showing meeting correctly to respect Day light saving time change but Samsung S planner ignore this and still showing meeting in time before Day light saving time change.
    Thanks for any help
    03-11-2015 09:23 AM
  22. dreamur's Avatar
    Hi guys. I have the same problem with my Samsung Note 4 and it started after US time zone reverted to standard last March 8th. And I am located half a world away so now my calendars are screwed by a day!
    03-24-2015 11:13 AM
  23. Delargo123's Avatar
    I am having the exact same problem with my new Note 4. All my calendar invites from the USA are showing one day earlier in my S Planner but are showing correctly in my Outlook calendar. Very frustrating as they are my meetings for work. Where to next?
    04-17-2015 07:42 AM
  24. A-B's Avatar
    Hi Guys

    I just found a fix for this. I went into Outlook and found even thought he appointment was showing at 9:00am - 9:30am in Outlook when I clicked on the recurrence button it was showing 8:00am to 8:30am, so I adjusted the recurrence time and the appointment still stayed at 9:00am in outlook and when my android sync was complete the appointment was moved to the correct time.

    So please make sure in outlook you check the recurrence times of those meetings that are out on your phone as I bet the recurrence time in outlook is wrong.

    04-20-2015 05:20 PM

Similar Threads

  1. Exchange Email Sync Issues
    By reed4richards in forum HTC EVO Shift 4G
    Replies: 0
    Last Post: 09-07-2011, 09:15 AM
  2. Sync Issue - Only Exchange Emails not syncing
    By beznich in forum HTC myTouch 4G
    Replies: 0
    Last Post: 01-31-2011, 05:59 PM
  3. Will Rooting Fix the Email Sync Issues?
    By map724 in forum Motorola Droid 2
    Replies: 1
    Last Post: 12-08-2010, 06:18 PM
  4. Trillian sync messages between desktop and device?
    By whitenack in forum Android Apps
    Replies: 0
    Last Post: 09-22-2010, 09:25 AM
  5. Email sync issues?
    By Wrong way down one way in forum Motorola Droid
    Replies: 0
    Last Post: 02-09-2010, 01:24 PM