1. loginatnine's Avatar
    I don't use any lock screen and I always use the home button to wake my phone up.

    Since official JB, the home button not only wakes the phone up but it closes the app I'm in. Example : I'm browsing something on chrome, the screen turns off bc of timeout, I wake the phone using the home button and I see chrome back but immediatly it closes down like if I had pressed the home button again (but I didn't). The same behavior does not happen when a lock screen is enabled.

    I tried searching for an answer and tried the solution of editing the .kl files in system/usr/keylayout by adding WAKE_DROPPED or replacing WAKE with WAKE_DROPPED for every occurence of the home key (key 172) without luck. I tried fixing the permissions in CWM and I made sure the permissions are rw-r-r.

    Running stock rooted with CWM.

    Any other ideas? Thx!
    12-04-2012 09:16 AM
  2. leprechaunshawn's Avatar
    There was a thread on this and I think the solution was to turn off the option in S-Voice to have double tapping the home button launch S-Voice.
    ejhansen71 and loginatnine like this.
    12-04-2012 09:25 AM
  3. loginatnine's Avatar
    There was a thread on this and I think the solution was to turn off the option in S-Voice to have double tapping the home button launch S-Voice.
    I had S-Voice completely disabled... I reactivated it and disable the mentioned option and unfortunately, the same behavior happen. I am using home2 shortcut though, it might be that I'll check it out.

    Thanks for your help!

    EDIT : With home2 shortcut disabled, it still doesn't work... Any other ideas?

    EDIT2 : Actually, the "solution" is to enable S-voice and enable the option of launching with double-click. It does work that way. However, it introduces the lag everyone hates and I never used S-voice...
    12-04-2012 09:36 AM

Similar Threads

  1. Odd Home button behavior
    By Simon_y7 in forum Verizon HTC Rezound
    Replies: 16
    Last Post: 06-18-2013, 01:02 PM
  2. Dead screen & No Lock screen
    By elysea in forum T-Mobile Galaxy S II
    Replies: 2
    Last Post: 04-30-2012, 04:15 PM
  3. Home button/Lock screen stopped working
    By bswann in forum T-Mobile Optimus T
    Replies: 1
    Last Post: 08-03-2011, 06:42 PM
  4. Home button to lock the phone?
    By ws1088 in forum LG Optimus S
    Replies: 12
    Last Post: 12-04-2010, 09:13 PM
  5. no lock app, the evo, and side buttons
    By xorbe in forum HTC EVO 4G
    Replies: 1
    Last Post: 06-10-2010, 06:00 PM
LINK TO POST COPIED TO CLIPBOARD