1. ncwitz's Avatar
    All of a sudden this afternoon my S3 is not seeing the installed SD card. I had a message in the notification window about the card being unmounted. Under the Settings -- Storage option, the "Mount SD Card" doesn't do anything.

    It doesn't look like the card is fried. I can see the card and all the data when I put the card in an external card reader on my PC. Am I left with checking with Sprint on a hardware problem? Thanks for the help!

    PNY MicroSD HC, 32gb, Class 10
    12-10-2012 06:42 PM
  2. winmod21's Avatar
    The first thing I would do is slide it out a bit, and then push it back in. Do it a couple of times, or more, and then check and see if your Settings > Storage > SD card still says 'Mount SD card', or if it says 'Unmount SD card'. . . . (kinda reminds me of a girl I once dated. But that's another story).
    When my GS3 was brand new, and after I had just put a brand new Micro SDHC into it, it also said 'Mount SD card'. I had to pull the card and push it back in THREE TIMES . . (with it never really clicking into place, like on the tutorial videos), before it was finally recognized and the phone would say 'Unmount SD card'.

    I've no idea why yours would just start doing it right out of the blue, though. Hope your card hasn't gone bad.

    Surprisingly, I've also read where many a GS3 seems to have, in fact, gone and done cards in. Almost makes me want to pull mine out before mine goes bad. Or at least back-up on a daily basis.
    12-10-2012 08:02 PM
  3. bassmig's Avatar
    Can you view the contents through any other device (PC, laptop, other device)? The S3 unfortunately has a bad track record for SD cards. I had on RMA'd by the manufacturer.
    12-10-2012 08:28 PM
  4. winmod21's Avatar
    Yeah, he said: "I can see the card and all the data when I put the card in an external card reader on my PC."
    12-10-2012 08:30 PM
  5. ncwitz's Avatar
    Yep... I can see the card, and contents, fine with an external reader on my PC. In fact, I'm in the process of copying all the contents to the PC for backup. I also tried the card in my daughter's S3 and had the same error which seems to indicate it is a card problem.

    What I don't understand is why the card seems to be a problem in the S3 (2 different phones) but is fine in the PC.
    12-10-2012 08:41 PM
  6. aolbites's Avatar
    I had the same issue, I ejected it and formatted the card externally and put it back in the phone, it worked for about a day and then had issues after the phone was restarted. I then reformatted the card as it was recognized by the phone and it worked for a day also and now it's having issues again.
    12-14-2012 06:24 PM
  7. prosparky's Avatar
    My GS3 just had a SanDisk Ultra 32gb card go bad. It wouldn't mount in the phone, PC, camera, or tablet. I even tried accessing it through Linux, it was dead after 5 weeks of use. I just got a replacement today, after SanDisk gave me an RMA. I hope the phone isn't frying cards...

    Sent from my ThinkPadTablet using Tapatalk 2
    12-14-2012 09:29 PM

Similar Threads

  1. Micro SD card not recognized
    By KoukiFC3S in forum AT&T ATRIX
    Replies: 22
    Last Post: 05-30-2016, 01:35 AM
  2. Wifi Error and SD Card Not Recognized
    By Makisupa in forum Verizon Droid Incredible
    Replies: 3
    Last Post: 06-27-2013, 03:10 PM
  3. SD card not recognized
    By ninerlitning in forum AT&T Inspire 4G
    Replies: 1
    Last Post: 04-13-2011, 10:53 PM
  4. SD Card Not Recognizing
    By djinsydius in forum Verizon HTC Thunderbolt
    Replies: 8
    Last Post: 04-11-2011, 04:12 PM
  5. Micro SD card not recognized
    By jostarr in forum Barnes & Noble Nook Color
    Replies: 4
    Last Post: 02-13-2011, 08:30 PM