06-11-2017 02:38 AM
74 123
tools
  1. meyerweb#CB's Avatar
    Go into Settings / Application manager, find the list of "All" apps (on my GS3 you do this by scrolling all the way to the right--don't know if the S4 is different). Scroll down until you find the phone app. Tap to open, and then scroll down and tap "Clear defaults."

    BTW, there is an S4 forum, where someone can probably tell you exactly how to do this, if navigating is different than on the S3.
    04-30-2013 11:24 AM
  2. shane b1's Avatar
    I, also have been getting the " complete action using" choice EVERY time I do a YouTube link or attach a photo in a text. I have told it to " use every time" .. it still asks after hundreds of times of clicking the " always" button. I tried clearing the cache and clearing the defaults in all my applications, yet it still makes what should be 1 step into 4 steps.. This has only been happening since I updated to the new os.. - Galaxy S3
    06-03-2013 03:23 PM
  3. tommiyau's Avatar
    Actually it appears to be the default behaviour of the OS now. To prove this point i wrote a very simple app that had nothing but a button on it that would launch the music player. I then ran this in the emulator. Every time you selected the button the emulator would fire off a "Complete Action Using" box. The choice of "Always" or "Just Once" has no effect on the subsequent pushing of the button. The prompt is always shown.

    It appears to be a misreading of how the new makeMainSelectorActivity is working and how many seem to think that this will establish defaults. It certainly does not appear to be the case in a very simple test. I suspect that its related t how the programs are coded. For instance, if I code the button push with a ACTION_MAIN and a category of APP_MUSIC then the "Complete Action Using" has no effect on the subsequent running. However if you program using an VIEW and provide a mime data type then on the first running you get the "Complete Action Using" prompt but subsequent to that the mime type is associated with an app and you never get the prompt again.

    Fundamentally it comes down to what has been coded in the application rather than clearing caches etc by the looks. Seems there is alot of information stating the ACTION_MAIN and CATEGORY use in makeMainSelectoryActivity will create defaults but in a simple 5 liner program it certainly does not.

    So in essence, you can set applications for file types as default but you can not set default applications as such. ie. if you have multiple music players and you use makeMainSelectorActivity(intent ACTION_MAIN, intent.CATEGORY_APP_MUSIC) you will always get a prompt for the application selection. You can not avoid that by the looks.

    I know this does not help but all you could do is do a bug report on the app I guess.
    06-30-2013 10:03 PM
  4. Organize SB's Avatar
    Anyone here figured this out yet? Its driving me crazy.
    09-21-2013 04:07 PM
  5. meyerweb#CB's Avatar
    Yes. The xposed framework: [FRAMEWORK ONLY!] Xposed - ROM modding without modifying APKs (2.2)(03.09.2013) - xda-developers,

    and the alternate app picker module for xposed: [APP]Altarnate App Picker Xposed - xda-developers

    will let you make this work like it did in ICS. No rooting required.
    09-21-2013 04:15 PM
  6. Leo68's Avatar
    but it does. it does keep asking. every. time.
    09-27-2013 06:35 AM
  7. meyerweb#CB's Avatar
    Leo, do you have a question?
    09-27-2013 06:59 AM
  8. Rolf Crudupt II's Avatar
    When that window comes up... just click the program you want to use... and then choose "Always..." and it shouldn't ask you again.
    But thats the thing it keeps asking even after I tap always..I recently rooted it then I hadta factory reset it..I ended up getting a soft-brick only after trying the same method I used to root from the jump but I manged to get out of that but ever since its been ****in up...Even afteer Odin and resetting my flash counter..
    10-02-2013 03:44 PM
  9. GSDer's Avatar
    Rolf,
    There are a few apps that I've run across where it always prompts with that selection box, no matter that I've made a selection before and chosen "Always". You're just going to have to deal with it, or try other apps.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    10-02-2013 08:19 PM
  10. meyerweb#CB's Avatar
    Rolf,
    There are a few apps that I've run across where it always prompts with that selection box, no matter that I've made a selection before and chosen "Always". You're just going to have to deal with it, or try other apps.
    Or check out the links in post #30.
    10-02-2013 09:11 PM
  11. GSDer's Avatar
    Or check out the links in post #30.
    Unfortunately one of the first things in that article is:
    'Does this require root access?
    Yes, because it replaces a file in /system/bin. Once the framework is installed, it should work without root access.'

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    10-03-2013 02:43 AM
  12. meyerweb#CB's Avatar
    Hmm, I thought xposed didn't require root. Let me check into that.
    10-03-2013 05:08 PM
  13. zagwask's Avatar
    I actually do have that problem....

    In fact, sometimes when I do a search from the home screen and click on one of the links, it will prompt me to decide which browser to open with. I'll select a particular browser and select "Always." I can do another search 10 minutes later and it'll ask me the exact same question. This happens repeatedly with different actions and different apps being selected as "always," but then having it seemingly forget my selection 5 minutes later. It's so annoying I'm considering ditching android altogether and going to apple.
    10-16-2013 11:14 AM
  14. Okapi Updyke's Avatar
    I too have this problem. I am not a tech person but I can tell you it never happen on my old HTC Incredible. Must be the software glitch associated with Jellybean? I looked into what post #26 suggested and in my case my default button was already cleared and I can't select it. Now what? I have had my S4 for only 4 days. Ugh. Already messed it up....
    10-31-2013 05:39 PM
  15. GSDer's Avatar
    I too have this problem.
    Which 'this' problem are you referring to? Are you getting that prompt for all apps that you try to make default, or is it happening just for one or two apps?

    If the latter, you may just have to live with it - I've run into the same behavior with a couple of specific apps - looks like they were just coded poorly.

    If it's happening with all apps that you try to make the default you can try this: Settings -> Application manager -> Menu button -> Reset app preferences (this will clear all of the selections that you've made).

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    10-31-2013 09:18 PM
  16. Alexandros Rory's Avatar
    It is indeed a change in operating system. That happened to me after sending my phone to Samsung for repair and they upgraded the software. I called them back with regards to this change (ie not having the option of "Complete action with" when I wan to make a call) and they said that is a feature of the new software. May be is an Apple patent that they are forced to remove... Who knows?
    12-01-2013 12:03 PM
  17. Corlis Taylor's Avatar
    When that window comes up... just click the program you want to use... and then choose "Always..." and it shouldn't ask you again.
    Choosing the "Always.. option hasn't been very effective for me even though my settings are default for the Apps in question.
    I constantly receive the "Complete action using" window while using stock 4.3 browser with chrome.

    Posted via Android Central App
    12-17-2013 08:30 PM
  18. meggie777's Avatar
    My S4 is doing the same thing..have had it 4 months..would get the "complete action using" and make my defaults as needed. Starting today, I can't do anything without that screen showing up..multiple times with one action most of the time.. I have cleared cache and defaults..someone give me a new idea before I pitch this phone that I used to love. .
    12-18-2013 08:51 AM
  19. GSDer's Avatar
    meggie777,
    Welcome to the forums!

    Go to Settings -> Application manager, press the Menu button and select 'Reset app preferences' - this will reset all default selections and it may correct your problem. YMMV.

    Note: it's still pretty common to run into one or two stubborn apps that don't care what default selection you have made.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    12-18-2013 10:25 AM
  20. Mexypko's Avatar
    Reseting app preferences doesn't work. The problem seems to be much deeper. I recently changed from Apple but I am starting to regret that. This thing keeps poping up, so please someone smart HELP ME!
    12-31-2013 02:59 AM
  21. GSDer's Avatar
    someone smart HELP ME!
    All the smart people hang out over on XDA - perhaps you can get some help with your as-yet-to-be-described issue there. Or if you're still within the 14 day exchange period you can go back to an iPhone.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk Pro
    12-31-2013 11:51 AM
  22. infinitempg's Avatar
    I have the same issue with my Nexus 7. for example I have an email with a link in it when I click on the link I get the message just once /always asking what I want to open the link with. select chrome and select always and it opens the link in Chrome and often it will ask me more than once before the link opens. I close chrome go back to the email click on the exact same link and it asks the same questions again the same way even though I selected always. so does the new version of Android OS not understand the word "Always"???????
    01-07-2014 09:00 PM
  23. infinitempg's Avatar
    went to the App Store and installed Default App Manager Lite, set chrome as default and went back to the email. clicked on the link and got the same prompt for just once/ always. and the link I'm going to I get that prompt 3 times before it opens the web page. ::sigh::
    01-07-2014 09:17 PM
  24. Tanner Scheidt's Avatar
    I have the same issue as everyone above and it's driving me insane. Please someone figure this out!
    01-10-2014 09:02 PM
  25. infinitempg's Avatar
    On my Nexus 7 I have some URL links in Gmail messages and to get them to open in Chrome I have to "PICK" Chrome "FOUR" (yes, that's 4!!!) times to get Chrome to open the link. If this is "as designed" then I would suggest we Android users politely invite the programmer of this gem out in a field and go totally Office Space on them....
    01-12-2014 07:01 PM
74 123

Similar Threads

  1. Replies: 12
    Last Post: 09-11-2014, 11:15 AM
  2. Replies: 0
    Last Post: 03-04-2012, 06:22 PM
  3. How do I reset Complete Action Using Menu?
    By johnstad in forum HTC EVO 3D
    Replies: 3
    Last Post: 10-17-2011, 07:57 PM
  4. Replies: 2
    Last Post: 03-26-2011, 06:27 PM
  5. Replies: 28
    Last Post: 07-23-2010, 09:36 AM
LINK TO POST COPIED TO CLIPBOARD