01-24-2016 01:04 PM
288 ... 89101112
tools
  1. Patrick Reuben's Avatar
    The samsung galaxy s3 is advertised to support a micro sd card up to 64gb. Whoever said otherwise is incorrect.
    07-16-2013 03:52 PM
  2. chrono117's Avatar
    It just happened to me, too. I have a Galaxy S3 and was using a Kingston 16 GB microSD. I couldn't get anything off it, even in a laptop card reader. I had to reformat the card. I'm not too upset because everything was backed up to the cloud. It's just annoying. I've had the phone for about a year and this is the first time I've had this problem. I'll try that Developer Tools -> Protect SD Card trick.
    07-26-2013 09:55 AM
  3. gollum18's Avatar
    Try booting into Linux from a live CD or USB. The distro doesn't matter, as android support is universal. Linux has a program called gparted which you should be able to use to see what's going on.

    The sdcard may recognize automatically in Linux as well. Really if you don't use your card on your PC, your best bet would be to format it to ext4. Android natively supports it and sdcards run best with it as their fstype.

    As I mentioned though, it won't recognize in windows based PCs, without 3rd party software.

    Sent from my SPH-L710 using Tapatalk 2
    07-26-2013 04:34 PM
  4. Neil Foster1's Avatar
    You can add the Galaxy S4 to the list. Mine just killed a 32 GB SD card (Monster Digital, Safari Series)... Samsung, I believe we have a problem!
    JeniferF likes this.
    07-30-2013 02:30 PM
  5. Megan Ackmond's Avatar
    Is there anybody here having problems with SD cards that WERE NOT MADE BY SANDISK?
    I just lost a 16GB card from Kingston in my GS3. Prior to that, I was only using Sandisk and lost 4 of those to two different GS3. I bought them all from Amazon in retail packaging. I've read articles pointing blame to the card manufacturers, but now have confirmed it's not just limited to Sandisk. The cards last for several months before the suddenly "die" according to the phone.
    08-01-2013 11:34 AM
  6. ad_winkie's Avatar
    I had this problem with a class 10 32gb micro sd on my S3. I found a recommendation on the XDA developers forum. They suggested a piece of free software called Testdisk and Photo Rec ( TestDisk Download - CGSecurity). I downloaded it and followed the instructions. I used photo rec to recover all my photos, videos and PDFs. I then used test disk to recover the partition. It then became visible to my computer. and much to my amazement and delight,when I put the micro sd back into to the phone, it recognised it and it is working again. I will be backing it up much more frequently now than I was but this software was really helpful. I used and old XP isolated XP machine just in case but none Of my security software flagged any problems.
    08-01-2013 12:54 PM
  7. mheyvaert's Avatar
    Thanks for the tip. We will try Testdisk tonight. My son's Samsung 8gb SD card just went bad on teh Galaxy S3. He was viewing photos he just took and then a couple of hours later, the phone did not recognize the card and wants to format it.
    08-05-2013 07:41 PM
  8. neilmillstone's Avatar
    I've had a lot of experience of this problem, so I'll keep it short. I've now had four Galaxy Note 2 phones. Three of them definitely had this issue, frying SD cards regular as clockwork after about six months. The fourth actually died from a bad screen controller but I'm sure it would have fried SD cards too given long enough. SD cards have been both Kingston and SanDisk.
    08-06-2013 03:39 PM
  9. Hektoren's Avatar
    In just two - 2- days, I've gotten the dreaded SD-card damaged error status on BOTH my Samsung Galaxy Tab 10.1 AND my 4 months old Galaxy S3! Do I want to reformat?

    Tried reformatting the SD-card in my Tab, but it's still recognized as "damaged".

    Now, what to do? This is evidently occurring too frequently for Samsung products to be random incidents.
    08-07-2013 04:01 AM
  10. derk's Avatar
    This problem stinks for anyone who actively uses micro sd cards. I got so frustrated that I eventually went back to using an iPhone. I went through 2 S3 phone replacements and tried 3 different sd card (Sans disk, Kingston, pny) manufacturers.
    08-08-2013 08:41 AM
  11. derk's Avatar
    This is not the same issue but I find it interesting that Samsung messed up sd card permissions for the S4 in the 4.3 update.

    http://www.ubergizmo.com/2013/08/gal...ting-for-apps/
    08-12-2013 06:54 AM
  12. Alister Clifton's Avatar
    I have not read all the posts so I apologise if this has already been said.

    I read this site, Samsung Galaxy S3 fault is caused by SanDisk memory cards | CNET UK

    I then contacted SanDisk support, SanDisk Contact Information, and pointed them to this site, they confirmed the issue and that it is has been resolved, they sent me details on how to get a replacement for my (now dead) sd card which has been showing lots of the same issues others have reported on this site.

    I will update once I have my new card.
    08-14-2013 11:09 AM
  13. Mibutastic's Avatar
    So is this issue still happening for S3s? I'm looking at finally get a 32gb micro sdhc card for my S3 and so far, the sandisks are the cheapest out of the 3 that I looked at which are sandisk, samsung and sony. Of course, I'm worried about sandisk since they are the ones in the spotlight for the last few months about sd cards failing with the S3. Should I just fork a little more money on the samsung or sony cards instead?
    08-17-2013 07:31 AM
  14. RayMabry's Avatar
    So is this issue still happening for S3s? I'm looking at finally get a 32gb micro sdhc card for my S3 and so far, the sandisks are the cheapest out of the 3 that I looked at which are sandisk, samsung and sony. Of course, I'm worried about sandisk since they are the ones in the spotlight for the last few months about sd cards failing with the S3. Should I just fork a little more money on the samsung or sony cards instead?
    I have no idea if it's still happening. All I can say is knowing that this issue was prevalent, I purchased a 32 GB Samsung SD card and couldn't be happier with it. And if an issue arose during the whole process, I only had one company to point mt finger at. Some things are just worth spending a little more on and for something I hope to have for at least a few years, I just couldn't worry about the price.

    Sent from my SAMSUNG-SGH-I747 using Tapatalk 4
    08-19-2013 06:55 AM
  15. Tina Garbacki's Avatar
    Absolutely still happening. My hubby and I both just purchased brand new s3's and have had them no longer than a week. He had a PNY 8gb card and I had a Samsung 8gb card. Both were fried. I plugged the samsung into an adapter and it was readable by the computer and used Zero Assumption Recovery program and recovered my files. Unfortunately, my hubby's card just says blank card or unsupported file format and is unrecongnizable.
    08-24-2013 10:56 AM
  16. Beardfist's Avatar
    Googled my way to this topic, after my i9300 ate its second SDHC card. First one was a Class 10 8GB Sandisk and the second was Class 10 32GB Samsung (lololol). Tried to connect the second one to my PC with four different micro SD card readers, and it's like it's not even there. Used Poweramp to play music from both of them, and I've been running WanamLite if that matters.
    08-28-2013 10:10 AM
  17. SeamusH's Avatar
    I can also confirm both that it is still happening and that it isn't limited to cards of a particular brand. In fact having heard that it was a Sandisk-related problem, I assumed I'd have no problems with an alternative card.

    I had been using a 64GB Kingston card for a few months and had just started to notice some audio tracks clicking and jumping. I assumed that this was a problem either with file or the app (Rocket player) but I now believe that it was the first signs of the card having problems. A few days later it would only mount intermittently in the phone (S3 i9305) and then it died completely. It's also unreadable in PCs - which just don't see it as a drive (so no reformatting etc can be done either).

    For now, I'm going to get a replacement card (Samsung for what that's worth) but I won't be saving photos to it and will only use it for files/media that I can afford to lose. Longer term, I'll be looking for an alternative to Samsung.
    08-28-2013 07:30 PM
  18. alan sh's Avatar
    Yes, it's the major thing that is making me look for a new phone. I've fried 2 32gb cards and now rely on the internal memory alone.

    I wish there was a cure.

    Alan
    08-29-2013 01:06 PM
  19. Ron Coleman85's Avatar
    For what it's worth, one more data point -- same experience, same frustration.
    09-01-2013 11:30 PM
  20. decontrol's Avatar
    This whole Samsung issue is complete CRAP and they (Samsung) need to recognize and start fixing and replacing the problem(s) with this device asap. I know they wont, its all deny deny deny...this all really sucks, I love my galaxy s3 and I feel really let down by Samsung. I buried my 32gb class 10 SanDisk just this past week....the madness has got to stop!
    09-02-2013 09:22 AM
  21. alphaken's Avatar
    And another data point. Second card on my S3 to go.
    09-06-2013 12:48 PM
  22. hwlanfeariv's Avatar
    ...same issue as others, had pics on SD card, was working fine for 3 months, one day, done "SD card removed" and it is wiped clean, wont work in other phones or on laptop.
    09-10-2013 03:24 PM
  23. koapsmith's Avatar
    Same thing here. I have had my SanDisk 32 GB in my SGIII for over a year with no issues. All of a sudden, the error pops up today.
    09-10-2013 10:39 PM
  24. deesto's Avatar
    Sherard S: Did you try using the same memory card in any other phone?
    Visitor: You just lost me, man.
    Visitor: That's the most ridiculous response I've ever seen.
    Visitor: Thanks for your help
    If that's the most ridiculous response you've ever seen, then I suspect you haven't seen many responses. The strangest aspect of your reaction, and willingness to bail after the support agent asked this question, is that the question is completely legitimate: checking whether the card is readable by other devices is a logical step toward eliminating the device and/or card as the problem.

    The bit about discrediting forum posts before that was just legal-ease to make sure you understand that they can't control the information posted by other people about their products, also not that unusual nor offensive.
    09-11-2013 09:43 AM
  25. jmsnyc's Avatar
    I do not think it is limited to SanDisk as I have the problem with a PNY 32GB card. (Though I suspect that cards under different brands may be manufactured at one source) I have fixed the card multiple times via testdisk, ckdsk, and copying the files to a temp location and formatting the card. I have not lost critical data yet it is still frustrating/
    09-11-2013 06:11 PM
288 ... 89101112

Similar Threads

  1. SD card fried in new Galaxy S3
    By Dubg in forum Samsung Galaxy S3
    Replies: 118
    Last Post: 07-15-2013, 06:22 PM
  2. 32 gb sd card in galaxy S3
    By LG1963 in forum New to the Forums? Introduce Yourself Here!
    Replies: 0
    Last Post: 10-04-2012, 02:14 PM
  3. Question, What Needed To Make 32G SD Card Work In Phone
    By fst2011 in forum HTC myTouch 4G
    Replies: 8
    Last Post: 02-20-2011, 02:44 PM
  4. X seems to be mounting the SD card while in "Charge" mode.
    By digitalslacker in forum Motorola Droid X
    Replies: 6
    Last Post: 10-30-2010, 04:47 PM
  5. Replies: 6
    Last Post: 08-21-2010, 04:18 AM
LINK TO POST COPIED TO CLIPBOARD