1. ess_stegra's Avatar
    I have a Galaxy S3 4G with 16GB Memory that I bought 3 weeks ago. At home I have a Comcast cable modem attached to a Netgear Wireless-N 300 Router. I have used the router successfully for over a year. I have two notebook computers running Windows 7 connecting to the internet wirelessly as well as as an old Motorola Droid smart phone. The router is using WPA-PSK [TKIP] + WPA2-PSK [AES] for security. When I enable WiFi on my Galaxy S3 it connects to the router and is assigned a valid IP address by the router and shows up on the routers list of attached devices. If I reboot the cable modem and the router, the smart phone will connect to the internet for anywhere from a few minutes to 2 hours. The phone then loses all connectivity to the internet. The exception is I can still access the router itself from the phone by entering http://192.168.1.1 I have tried the following:
    1. Rebooted cable modem and router (see above).
    2. Disabling WiFi on the phone, changing the channel on the router, re-enabling WiFi on the phone.
    3. Forcing the phone to obtain a new IP address by reserving the address being used by the phone.
    4. Assigning a fixed IP address to the phone.
    5. Restarting the phone.
    With the exception of rebooting the cable modem, none of these fixes the problem. Any suggestions for how to fix this or should I try replacing the phone?
    01-25-2013 05:24 PM
  2. Trees's Avatar
    Interesting problem. One thing that jumps out that may be relevant is the exception where you can access the router via the S3. This makes sense if your S3 is accessing the N 300 via WiFi and not from outside your home network and back in via a VPN tunnel, etc.

    What might help to further understand is the separation between the Telecom provider you have vs. your home WiFi network. If you implement Step 1, but keep WiFi disabled on your S3 does the problem persist? I'm also not sure how DHCP Reservations work with the N300 firmware, so am a bit confused by the details in Step 3. My experience has been that if a MAC address to IP address reservation has been made, then DHCP will try to honor that. Perhaps you have a DHCP scope or range of IP's allowed to bind to the S3's MAC?

    Another area to try that very likely you've already checked out is for any known or suspected issues with the N 300. Perhaps there is a newer firmware out that may address similar issues that you are seeing? From the issue descriptions and steps you listed (well done in my opinion), there may be problems with the N 300 supporting multiple devices in the 2.4 and 5GhZ ranges (am assuming that the N 300 is dual-band). But the real clue for me is starting to look like it may be the cable modem. If your cable modem goes down, then in theory the only way your S3 can access the internet is through your Telecom providers network. When the cable modem goes down, your phone has to rely upon different network routes, DNS servers, proxy servers, etc. When your cable modem is back online, then in theory your S3 switches back to using WiFi and gets its network gateway, routing, DNS, proxy, etc information from Comcast and your router. What happens when you turn off all of the other computers and WiFi enabled devices? Does the issue repeat itself? I had a high end Linksys router that was consistently dropping connections once all of the family was online in the evenings. Is your issue happening at random times or around the same time each day? Its easy to forget how many WiFi enabled devices many of us have at home at any one time. Laptops, desktops, tablets, WiFi printers...smartphones; they can all place a strain on home networks. Again this is just my experience - I'm not a WiFi router or network person.

    I would hold off on replacing your phone as it could be some combination of the Comcast cable modem and N 300 that is the source(s) of your problem. Of course your Telecom provider may also have issues that are contributing to the problems. Hope this helps.
    01-25-2013 10:10 PM
  3. Rohit_Chawla's Avatar
    Hi,

    I have T-Mobile Samsung Galaxy S (Vibrant) phone.
    From the last few weeks, I am getting internet problem on my phone while using home wifi, I have to disable and enable wifi again and again to get it working. I have also tried cleaning cache in the browser. Internet problem is on browser, Whatsapp, Market etc.
    All other device connected to my home wifi works just fine.
    Can some one help me in solving this issue?

    Thanks
    Rohit
    02-10-2013 12:16 PM

Similar Threads

  1. Droid X WiFi connect issue? Try this...
    By Dural in forum Motorola Droid X
    Replies: 12
    Last Post: 01-09-2014, 08:33 AM
  2. WiFi connection issues?
    By ellje in forum Verizon Droid Charge
    Replies: 4
    Last Post: 06-06-2011, 09:23 PM
  3. Xoom having wifi connection issues
    By afolgueira in forum Motorola Xoom
    Replies: 5
    Last Post: 04-26-2011, 07:43 AM
  4. wifi connection issue?
    By bloodycape77 in forum HTC Droid Eris
    Replies: 6
    Last Post: 03-13-2011, 08:06 PM
  5. cyanogenmod and wifi connection issues
    By dms76 in forum Incredible Rooting, ROMs, and Hacks
    Replies: 3
    Last Post: 12-30-2010, 05:26 PM
LINK TO POST COPIED TO CLIPBOARD