1. Kevin_Sole's Avatar
    Been searching for answer for this one for a week now, tried various solutions, but coming up with nothing that works.

    Up until maybe two weeks ago, everything was working fine. My PC was connected via ethernet to the router; the PS3 via wifi; roomate 1's computer connected by wifi; roomate 2's computer connected by wifi; and finally my Samsung Galaxy S3 connected by wifi.

    Suddenly, roommate 2 was having difficulty connecting. I rebooted the router, I checked the settings. She was having a DHCP problem or something, and now that it's fixed, she can connect just fine. Then my phone started having problems. Now, if I connect my phone to the wifi, internet access is disabled for ALL devices connected the router, regardless of how they are connected, including the phone itself. It's not as though it's hogging ALL THE INTERNET or something. Nothing works, until I disable my phone's wifi. Then every device works.

    I recently changed my PC to wireless, to see if that would change anything: no changes whatsoever, other than being connected wireless, obviously. It works fine. All devices work fine. Until, again, I enable the Wifi on my phone, and then internet access is revoked. Pulling up webpages, regardless of device, says something about a DNS error.

    I have pulled the battery on my phone; rebooted the router; switched to wireless on the PC; enabled devices one at a time in different order.

    The only thing I haven't tried, honestly, is restoring defaults to the router. Always seems like a last-ditch, though I doubt it would change or harm anything.

    Anybody have any ideas? If it was just disabling the internet on the phone, it would make sense -- or more sense -- but once that phone wifi is on, nobody can connect to anything on any device. I'm really damned confused.

    Thank you.
    01-27-2013 05:57 PM
  2. meyerweb#CB's Avatar
    You try noting the exact error message, and Googling that error. I find knowing having detailed and accurate information to be much more useful than "some error message."

    Otherwise, you might try deleting the Wifi settings for the router from your phone, and recreating them.
    01-27-2013 08:29 PM
  3. neil154's Avatar
    First make sure all devices automtically assign IP address and DNS automatically. If all that is set up fine then I would have all devices turned off and try turning on phone to internet. If that works then try each device with only the phone and then just work you way thru all devices and that way you might be able to figure out which device is causing the problem. Once you figure out which device is causing the problem with the phone you can examine the settings on that device and compare to other device. Not sure this will work but it is worth a try.
    01-28-2013 08:34 PM
  4. mssca's Avatar
    Try release and renew DNS in the router?
    01-28-2013 09:31 PM
  5. GMJeff's Avatar
    By starting that you are connecting to wifi, are you just turning the soft switch on and letting the phone connect automatically?

    Try turning all of the computers on and verifying that they have internet access. Then go into the wifi settings of your phone and delete your profile for your network. After a few seconds, turn on the wifi for the phone and let it find your network again. Enter the network password and it should be good to go.

    I had a similar issue a few years ago where I was asigning static IP addresses to my networked devices and had to troubleshoot an identical problem. Turned out that I had assigned a computer the IP address of the DNS server and it conflicted, and knocked my internet access out, until I found the problem and changed the address on the computer.

    Sent from my GT-N8013 using Android Central Forums
    01-29-2013 12:27 AM

Similar Threads

  1. how to tether usb wifi on phone to vista?
    By Optimusssprime in forum LG Optimus S Rooting, ROMs, and Hacks
    Replies: 3
    Last Post: 10-01-2012, 09:46 PM
  2. Attention all Kernel and Theme Developers for all devices
    By jdlfg1005 in forum Epic 4G Touch Rooting, ROMs, and Hacks
    Replies: 0
    Last Post: 11-17-2011, 09:54 PM
  3. Netflix App for all devices
    By lexriley in forum Tablet Apps
    Replies: 2
    Last Post: 09-13-2011, 10:40 AM
  4. Wifi on phone that hasn't been activated
    By herooftimeloz in forum Verizon HTC Thunderbolt
    Replies: 3
    Last Post: 03-20-2011, 10:35 PM
  5. android 2.2 for all devices
    By pixi1 in forum Software Development and Hacking
    Replies: 1
    Last Post: 08-22-2010, 09:25 PM