1. paqmanbiker's Avatar
    I'm not sure if this problem is specific to the SG3 or not, but this seemed like the best place to post this question. So here's the problem. The other day I copied some avi files to my SD card to watch later. Then yesteday I sat down to watch one, and MX player was saying it couldn't play the files. Same error with any other video player app I tried. So I rebooted the phone. After rebooting the phone, I found that all the video files I uploaded were gone from the card. As well as all the photos I had taken that day. All other files on the SD card are intact. All my old photos, and video files are still there. The only files that get deleted are video or photo files that I put on the card as of yesterday or later.

    I've tested it out. I take a photo, then reboot, and the photo is gone. I switched the photo storage to the phone storage, and on reboot the photo stays safe. So it's only deleting things from my SD card. Almost like something happened at some time yesterday, like a switch got flipped or something that won't write anything else to the card. The old stuff is safe, just new stuff. But it's not like a write switch being turned off, because I can write to the card, but the stuff gets deleted after booting.

    Currently I'm backing up the card to my laptop so I can format it and try again. I'll post the findings of that test shortly. I also haven't tested if the same problem occurs with non media files. I'll try putting a text file or something on it as well and see how that goes. In the meantime, anyone seen this before or have any ideas? Is the SD card bad? Or is some stupid "feature" doing this to me? The card is a SanDisk 32GB class 10.
    01-30-2013 06:10 PM
  2. paqmanbiker's Avatar
    A little update. It's not just media files. Any file I create on the SD card gets deleted upon reboot. Also, I tried formatting the card, and it won't format. So obviously the card is jacked up. Unless if anyone has any great ideas here, I'm gonna get Amazon to replace the card.

    Edit: interesting, After deleting every file on the card, then trying to format it, windows says it can't format it, then when I go back to the card, all of the stuff I just delete is still there. Also, if I delete all the files, then eject the card, then re-insert the card, all the stuff comes back. So it's like it won't let you make (or keep) any changes you make, creations or deletions.
    01-30-2013 07:29 PM
  3. blade22222's Avatar
    Your probely right, sounds like a bad card.

    Sent from my SCH-I535 using Android Central Forums
    01-30-2013 07:52 PM
  4. GSDer's Avatar
    You've tried reformatting it in the phone? If so, does that fail and give you an error?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2
    01-30-2013 10:32 PM
  5. paqmanbiker's Avatar
    Yep, I guess if I would finish all my troubleshooting before posting here, I could have conserved a few bytes on the precious interwebs.
    01-30-2013 11:53 PM
  6. bugfinder's Avatar
    See below
    02-12-2016 10:47 AM
  7. bugfinder's Avatar
    [SOLVED.] After a long battle, I figured it out.

    1. Power off the phone
    2. Remove the SD card and put it in a card reader and connect it to a PC
    3. Run "Cmd" that will open a command window
    4. Type chkdsk /f drive: For example chkdsk /f E: (Most likely you will see a corruption found)
    5. Add files from your computer. (Drag and drop)
    6. Repeat chkdsk /f drive:
    7. Safely eject card and plug it to your phone. Enjoy.

    Regards, JD
    02-12-2016 10:53 AM

Similar Threads

  1. Viewing SD card files on phone?
    By pt1911 in forum Verizon HTC Thunderbolt
    Replies: 11
    Last Post: 08-25-2016, 11:38 PM
  2. 2 Years worth of data on my SD card not being read on Thunderbolt. WTF?
    By Bassman125 in forum Verizon HTC Thunderbolt
    Replies: 5
    Last Post: 02-09-2013, 10:44 AM
  3. SD card not being read on new Optimus S
    By imapotato in forum LG Optimus S
    Replies: 3
    Last Post: 08-10-2011, 08:34 AM
  4. Fascinate SD card will not mount on a MAC with DL09/EB01
    By dgriff945 in forum Verizon Fascinate
    Replies: 66
    Last Post: 04-23-2011, 08:14 AM
  5. SD Card File Transfer
    By Chromie in forum HTC EVO 4G
    Replies: 2
    Last Post: 02-09-2011, 07:18 PM