1. Billy Young's Avatar
    Hi , Yesterday my phone said there was a firmware update, which i did , once my phone restarted and came back on everytime I go into the green phone symbol the screen go's black and then come's up . Unfortunately , contact's has stopped.
    Now if i go into my orange symbol for contacts this opens fine and I can call from there by swiping right , but I can't get a keypad up to make calls through the phone symbol .

    I hope you can follow that , the phone is standard nothing rooted etc . I have done a factory reset but this hasn't done anything other than cost me time.

    Any help would be great
    04-28-2013 04:45 AM
  2. meyerweb#CB's Avatar
    Have you rebooted? If not, start there. If that doesn't work, try this as the next step: Go to Settings / Application manager, scroll all the way to the right to the "All" tab, then scroll down to Phone, and tap there.

    If Clear cache is enabled, tap that, then Force stop. Then go back and restart the phone app. If that doesn't fix it, do the same thing, but this time tap "Clear data", then Force stop. If it's still not working, let us know.

    What carrier are you on, and do you know what the update was?
    04-28-2013 11:08 AM
  3. Billy Young's Avatar
    Hi I tried what you said but that has not worked either. I don't know what the update was.

    I'm in the uk and on o2.
    05-01-2013 04:34 PM
  4. meyerweb#CB's Avatar
    I'm pretty much guessing here, but some other things to try:

    Do the same thing, but this time on the contacts app rather than the phone app. I see there's an app listed call PhoneUtil. Try force stopping that.
    If that doesn't work, in the Application manager, tap the Menu button, and choose Reset app preferences. This will reset preferences for a bunch of apps, so you may find yourself have to reset some things.

    If all else fails, the only other thing I can suggest is to do a Factory Reset. But you might want to check with O2 to see if they have anything else to try, first.
    05-01-2013 05:17 PM

Similar Threads

  1. wifi hotspot app not working after s3 update
    By dfb8085 in forum Samsung Galaxy S3
    Replies: 27
    Last Post: 02-13-2014, 06:58 PM
  2. Verizon Samsung Galaxy s3 Update!
    By oma1340 in forum Verizon Galaxy S III
    Replies: 10
    Last Post: 09-20-2012, 07:08 PM
  3. ANOTHER international s3 update
    By funkylogik in forum Samsung Galaxy S3
    Replies: 2
    Last Post: 08-09-2012, 01:34 PM
  4. ATT S3 update
    By CarlGalgano in forum AT&T Galaxy S III
    Replies: 61
    Last Post: 08-03-2012, 09:01 AM
  5. Sooooo where is the North American S3 update?
    By brava27 in forum Samsung Galaxy S3
    Replies: 9
    Last Post: 07-10-2012, 01:36 PM
LINK TO POST COPIED TO CLIPBOARD