1. CorrineyBear's Avatar
    Apparently I must be the only person in the world having this problem, because I have searched everywhere and cannot find an answer to my problem. I have posted on here before with no help. I'm hoping I can get some answers here. I'm using an at&t factory unlocked galaxy s3 on straight talk and ever since I upgraded my phone to 4.1 I cannot get mobile data. I know I haven't gone over my limit since I rarely use it. But without it I can't send or receive mms. I cannot find any apn settings that work for me. I have tried the default one from straight talk to ones "the ultimate apn" with no luck. This is so frustrating. If anyone can help me, PLEASE do not hesitate to. I need this fixed.

    Sent from my SAMSUNG-SGH-I747 using Android Central Forums
    05-15-2013 01:08 AM
  2. GTWalling's Avatar
    Can you list what APN's you are using now. You may also check Here.
    05-15-2013 09:13 AM
  3. CorrineyBear's Avatar
    This is what's in there right now. It doesn't work though. I can't find anything that works.

    Sent from my SAMSUNG-SGH-I747 using Android Central Forums
    Attached Thumbnails Can't find any apns that work for my S3-uploadfromtaptalk1368816558903.jpg   Can't find any apns that work for my S3-uploadfromtaptalk1368816570087.jpg  
    05-17-2013 01:50 PM
  4. ScottsoNJ's Avatar
    Try these
    This is what I use on my Galaxy s3 Straight Talk At&t sim
    Name
    Straight Talk ATT
    APN
    att.mvno
    Proxy
    not set
    Port
    not set
    username
    not set
    Password
    not set
    Server
    not set
    MMSC
    http://mmsc.cingular.com
    MMS proxy
    66.209.11.33
    MMS Port
    80
    MCC
    310
    MNC
    410
    Authentication type
    PAP or CHAP
    APN type
    default,supl,mms,hipri
    APN prtocol
    IPv4
    APN roaming protocol
    IPv4
    APN enable/disable this should be lighter and already checked.you shouldn't be able to alter it
    Bearer
    unspecified
    using these settings I am getting 5.5 dn and 1.25 up
    05-17-2013 06:11 PM
  5. CorrineyBear's Avatar
    I tried it and it didn't work. Whenever I put in a new apn I turn off my wifi. Turn my phone for a few minutes and the turn it back on. When I try to use my browser it tells me my wifi and mobile data is turned off. My data isn't turned off. I check every time. I've even tried putting it in airplane mode for a little while and it still doesn't work.

    Sent from my SAMSUNG-SGH-I747 using Android Central Forums
    05-17-2013 11:11 PM
  6. Charlieanne's Avatar
    Hi CorrineyBear, have you resolved this yet?

    I am having the same problem! I cannot connect to my data at all. I have tried adding new apns but nothing works. I just did a "reset apns to default", which did not work and now I cannot not add new apns either! Like I press menu, select new apn, fill in all the fields and press save, but the new apn is no where to be found! And the default apn is wrong, but I cannot edit it!

    I'm in England and I'm using a factory unlocked S3 on orange/ee so I think this issue is with either android or samsung, and like you I can find no one else with this problem!
    05-20-2013 08:38 AM
  7. Stealthieone's Avatar
    You two might want to verify if your imei number is still there.

    Sent from my SGH via tapatalk-2
    05-21-2013 05:10 AM
  8. Charlieanne's Avatar
    My imei is still there.

    From what I've read I think my phones default APN is wrong. The MNC field is 33, but all recent APNs for Orange/EE I've found have the MNC as 30. But I cannot edit the default APN or delete it, I cannot add a new APN with a different MNC to the default - It just won't save it. I don't know if the MNC field being wrong is the cause but the rest of the APN fields are correct (same as other APNs I've found).

    I'm running android 4.1.2 so I cannot download an APN manager app to change the default APN either. I think I might have to bite the bullet and do a factory reset which I didn't want to do as my phone also takes an absolute age to back up! If that doesn't work I have been advised to root it, but as I have no idea what I'm doing I do not want to do that either.
    05-21-2013 08:01 AM
  9. CorrineyBear's Avatar
    I don't know what an imei number is. And no, I haven't resolved this. I can't find a solution anywhere. I also ha e been told that I should try rooting but I'm too afraid I will brick it. I can't afford a new phone.

    Sent from my SAMSUNG-SGH-I747 using Android Central Forums
    05-25-2013 02:25 PM
  10. CorrineyBear's Avatar
    I found my imei number. It's still there. And I also checked my mobile network state and it constantly says connecting...but never does.

    Sent from my SAMSUNG-SGH-I747 using Android Central Forums
    05-25-2013 02:31 PM

Similar Threads

  1. Replies: 1
    Last Post: 09-03-2012, 03:50 PM
  2. Any App that works for Mono Bluetooth on the GS3?
    By Unfranchise33 in forum Verizon Galaxy S III Rooting, ROM's, and Hack's
    Replies: 0
    Last Post: 08-01-2012, 10:45 AM
  3. I can't find any available ROM for P505
    By shaorand in forum AT&T LG Phoenix/Thrive
    Replies: 2
    Last Post: 04-04-2012, 08:24 PM
  4. Replies: 0
    Last Post: 06-18-2010, 12:06 AM
  5. DROID Wallpaper Maker??? I can't Find Any!
    By JLG1985 in forum Motorola Droid
    Replies: 4
    Last Post: 01-15-2010, 08:36 PM
LINK TO POST COPIED TO CLIPBOARD