1. Funkpod's Avatar
    Hello, I got super excited to try out the new Chrome Experiment, Chrome Racer!

    Go to g.co/racer and you can race on a track that take over several devices. I ALMOST got it to work, but it keeps on saying "Aw Snap, it apperas that ..." my Galaxy s3 is not fast enough?

    If it was my Droid Incredible, I'd understand, but my Galaxy s3?

    Anyone else having this problem?

    Doesn't work on my Nexus 7 either. That's weird.

    Anybody get it to work?
    05-16-2013 08:53 AM
  2. wampdog29's Avatar
    Same thing here with my Sprint Galaxy S3. Seems like it IS working with my Nexus 7. Not sure though, because I don't have a second device to sync up with. I'm not getting the "Aw Snap" error though...
    05-17-2013 12:55 AM
  3. wampdog29's Avatar
    Just tried with my wife's S3 and it worked fine.... really odd. I hope this doesn't mean my Galaxy S3 is having issues...
    05-17-2013 01:16 AM
  4. Funkpod's Avatar
    It sort of worked for a second with my galaxy s3. I cleared all data and tried again. Worked for a little bit, started a race, But then stopped.

    I tried using the Chrome Beta. Seemed to work better. But that's when it crashed.

    Nexus 7 used chrome beta as well. Spotty.

    If the galaxy s3's specs are too low, which would make sense, but if they're too low, then Google's aiming to high, imo.

    Sent from my SCH-I535 using Tapatalk 2
    05-17-2013 05:21 AM
  5. Nikola Arnaudov's Avatar
    Got the same message. The fix with my S3 was easy:
    1. Disable power saving mode
    2. Reload page
    05-29-2013 09:24 AM
  6. Roll_Cam_Tide's Avatar
    Not working on my t-mobile gs3 even with power saver off. Worked a few days ago so they must have changed something.
    05-29-2013 02:16 PM
  7. jaamarti's Avatar
    I agree that if the S3 will not run this browser game then Chrome is doing something wrong. I have not had power saving mode turned on my S3, it worked to the point of starting a race. Set the phone down to install Chrome on my wife's computer, came back and got the aw snap crap. Racer looks really great, but epic fail on the reqs.
    05-29-2013 08:30 PM
  8. Funkpod's Avatar
    agreed as well. if this phone can't run it, something's weird.
    05-29-2013 08:54 PM
  9. jpaulini's Avatar
    If you have enabled energy savings, turn them off. It seems that this slows down your phone...

    I'd the same error and it went off when I disabled it.
    06-10-2013 08:44 AM
  10. Jonathan Chick's Avatar
    Yeah.... Same on my s3
    06-14-2013 04:36 PM
  11. Fetter's Avatar
    It's definitely hit and miss with that game on the S3.
    06-14-2013 04:43 PM
  12. Funkpod's Avatar
    Apparently it works now on my phone. Weird.

    Sent from my SCH-I535 using Tapatalk 2
    06-14-2013 08:49 PM
LINK TO POST COPIED TO CLIPBOARD