07-02-2016 09:59 PM
382 ... 678910 ...
tools
  1. Rain CDO-PH's Avatar
    I share your problem. Mine is original S3, bought at known Australian electronic shop. My phone charges very slow, using the supplied original charger and all. I have also tried to charge using original Samsung docking charger, but it was still very slow. I tried to use charger cable for Samsung digicam and it worked fine: the phone got recharged quickly. I am now using QI wireless charger pad and the receiver installed on phone's battery as instructed, but the same problem (slow charging) persists. I am now confused whether it's the new QI wireless charger pad that does not work well, or is it the phone itself (or its battery) that causes the charging to take forever! Samsung people, are you listening?
    10-09-2013 05:36 AM
  2. GSDer's Avatar
    ...Samsung Wireless Audio Dock...
    ...Samsung S3 Wireless Desktop Dock...
    I'm not familiar with these two accessories, but if they both connect to the phone via the micro-USB port then I think you're going to have similar problems. It's likely that there's something wrong with the micro-USB port on the phone and the only way to get around the problem is to replace the port or bypass it altogether.

    I'd suggest a wireless charging solution (a Qi charging pad and replacement back) that totally eliminates the micro-USB port from the equation.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    10-09-2013 09:00 AM
  3. GSDer's Avatar
    I tried to use charger cable for Samsung digicam and it worked fine: the phone got recharged quickly... Samsung people, are you listening?
    If the cable for the digicam worked fine why have you gone on to other solutions? You obviously isolated the problem.

    BTW, no - Samsung is not listening.

    Edit: I haven't seen anything that describes the charging rate for the Qi wireless charging solutions. You should look on the one that you got to see if it's 500 maH or higher.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    10-09-2013 09:09 AM
  4. Alby Mathew's Avatar
    I've had the same trouble, but recently found a solution. The original charger provided with the phone is a 1 Amp charger. I purchased the original Samsung charger three times to no avail. A few months ago, I purchased an original Samsung car charger, but that was only a 0.75 Amp charger. As promised by the shop keeper, it worked perfectly with my phone. The charge time took two hours to go from around 10% to 100%. But that did not solve my problem of charging the phone with a wall-socket charger. A few weeks ago, I discovered that the Sony charger (micro usb) works beautifully with my phone. It is a 0.85 Amp charger and charges at almost 1% per minute. It takes around 100 minutes to go from 10% to 100%. I guess there is something wrong with the Samsung 1 Amp chargers.
    10-09-2013 09:46 AM
  5. C K Thakkar's Avatar
    I think charging problem has nothing to do with the device or the charger. Remove mobile cover/casing other than flip cover and charge and see that the problem is gone. Also see that when plugged in the pin is connected correctly or best is use computer spike buster to connect the charger.
    10-09-2013 01:53 PM
  6. Amaan Aalim's Avatar
    heh , I hv purchased s3 two months ago n it has started the same problem like charging in hours . sometimes it needs whole day 24h to charge .. this has became headaque, how to fix thi guyzz ,, plzz help
    10-10-2013 06:25 AM
  7. GSDer's Avatar
    Read all 180 previous posts and try the various suggestions already provided.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    10-10-2013 10:22 AM
  8. Fakhr E Alam's Avatar
    The thing with my phone is that when I connect the charger it works fine for a while and after that suddenly decreases it's rate. I tried almost everything even the support center guys are saying that nothing is wrong with the hardware and I feel the same because people around me using an S3 have been experiencing the same issues. I think if there was any hardware issue then the problem would be there all the time instead of not being there sometimes and then being there all the time. At the moment I am totally clueless about what to do, the thing I do is that I have installed this app known as "galaxy charging current" and when the charger connects with a high value I leave it there and then check it regularly every 4-5 minutes which is a tedious and frustrating job. Please address this issue samsung!
    10-10-2013 12:47 PM
  9. lissa sweet's Avatar
    Im facing the same problem as u with my galaxy s3 and i didnt have this phone for a year yet but its giving me trouble already.. my battery takes really long to charge when i waited for 2 to 3 hours and see if its unless halft way charge but no it only 3% or 2%.. and when i charge it overnigth when i woke up in the morning it would say its fully charge 100% then i unplug and turned it on it went to 100% to 10% or sometimes 34% ... im verry disapointed with dis phone :/..
    10-13-2013 02:10 PM
  10. chirag05's Avatar
    As I have observed from so far not in my country but on the forum too. It is that the USB cords what we get with S3 are sort of problem. I got a replacement for the faulty USB for slow charging and it got problematic again. The long cord I use of my sisters Galaxy Win/Gran Quatro runs fine and even the Samsung Galaxy Ace wall charger that I borrowed from my friend runs fine. There's a problem with the USB that is made specifically for S3 n others like that. I know some of you won't agree but this is my observation..

    Sent from my GSIII
    10-13-2013 04:24 PM
  11. Annalisa Ci's Avatar
    Here is what happens with my Samsung Galaxy S3 mini. I bought the phone on Amazon, it came with a standard, cheaply made USB phone charger with US plug (cable integrated with the wall charger). The micro USB connector became loose in a couple days and the phone stopped charging. So, I got a USB to micro USB cable and discovered the following: 1. charging it through the computer USB works; 2. charging it at the wall using a standard (Targus brand) wall USB charger (advertised to work with iPad, iPhone, and ALL Android phones) does not work (no charging); 3. charging it at the wall using the Apple 12 watt iPad charger (small white block) works with no problems; 4. charging it at the wall using the USB charging brick for the Samsung Galaxy Note 10.1 also works with no problem.

    Any take on this? one speculation is that the standard USB wall charger (5 Volt, 2.1 Amps) does not correctly signal its current capacity and thus the phone refuses to let it charge it. Any other idea? e.g glitch with the phone? (I should add that I went through a factory reset first thinking it was a software problem, but it made no difference.)

    Annalisa
    10-13-2013 09:02 PM
  12. kamokrub's Avatar
    Try an app called "Battery Doctor" and use the "charge mode". It's free and at least it solved problems on mine.
    10-14-2013 02:32 AM
  13. kwisthoff's Avatar
    I just bought an S3 a month ago and now when i charge it i have to have the phone a certain way or it won't stay charging. I have tried several different chargers with the same problem. Does anyone have any suggestions on why this would happen.
    10-14-2013 07:32 PM
  14. GSDer's Avatar
    kwisthoff,
    Did you buy the phone new or used? If new, you should take it back to your carrier.

    It sounds like the micro-USB port got stressed. You could either get it replaced (iffy) or go with a wireless charging solution.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    10-14-2013 08:42 PM
  15. Samesha12_12's Avatar
    Hi, I am having the same issue with the Samsung S3. Its just One Month Old and it isnt charging at all now. It started off as charging good, then it started taking very long to charge and now it isn t charging at all. When it reaches 24% it remains there for a few hours and then the next morning it is at 5%, then as soon as i pick it up it decreases to 4, then 3 and 1%. This is getting to be very frustrating as my Husband has the S3 white and everything is working perfectly fine. However, I am having this charging issue. Somebody please advise me of what I should do? or what charger I can use.
    10-15-2013 07:13 AM
  16. GSDer's Avatar
    or what charger I can use.
    Use your husband's charger. If that doesn't work then use his battery just to eliminate that. If it still doesn't work then it's time for a visit to the local carrier store for a replacement.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    10-15-2013 10:09 AM
  17. dakeb's Avatar
    Could be overheating due to charging current too high. It will stop charging if it gets too hot. Try charging from computer usb port.

    Sent from my SM-N9005 using Tapatalk 2
    10-15-2013 10:16 AM
  18. dbibby88's Avatar
    Hi, an update from when I last posted a couple of weeks ago. Since then my phone stopped charging yet again (for the 3rd time). I rang up the company I bought it from and arranged another repair! I sent it a week last Saturday and had the phone returned to me today.

    A letter in the parcel said
    "Your phone has been examined by one of our engineers and after extensive fault diagnosis we have been unable to replicated the fault you reported.

    We have however taken the opportunity to install the latest approved software which has been found to clear most common faults."

    This is the exact letter I received with my phone the previous time I sent it off for repair (the same problem, i.e. not charging). I turned the phone on and plugged in the charger and the fault was still there! I checked to see if the software had changed from when I sent it and it hadn't (4.1.2) and the firmware still ended in the same EMG4 (or whatever it is), so I think they'd literally performed a factory reset on the phone.

    I rang back the company as soon as
    10-15-2013 04:17 PM
  19. Tim Riley1's Avatar
    The last thing you want to do is contact Samsung. Horrific "service"...
    10-15-2013 08:07 PM
  20. Cor10mier's Avatar
    we can't help unless we know what the symptoms are and what you did before they occurred.
    10-15-2013 08:19 PM
  21. Martynzilla's Avatar
    hello . its not a USB cable problem. ive got 6 different chargers, 3 or which are genuine samsung, i have an external charger, and a genuine in car carger, the whole lot of them dont work, they all used to work fine, now none do. it was plugged in for 7 hours to the mains whilst switched off, and it wouldnt go over 80% charged, and would drain quite fast once swiched on. this past saturday i bought a genuine battery. it worked fine for 2 days, then it stopped charging again, and if you use it while its plugged in the battery would drain, not charge. its only 8 months old, ive taken it back to my provider for repair now
    10-18-2013 02:13 PM
  22. Martynzilla's Avatar
    Could be overheating due to charging current too high. It will stop charging if it gets too hot. Try charging from computer usb port.

    Sent from my SM-N9005 using Tapatalk 2
    my one has never liked charging from my computer USB port from day 1
    10-18-2013 02:16 PM
  23. Martynzilla's Avatar
    my samsung not charging my s3 after 40 ish %, but it charges my partners s3 mini no problem, so how can it be the charger ? if so, both phonew wouldnt be charging would they ?
    10-18-2013 02:41 PM
  24. GSDer's Avatar
    ive taken it back to my provider for repair now
    It's in their (capable?) hands now - please let us know what the outcome is.

    I'm guessing that they'll perform a Factory Reset; reload the firmware; and call it good.

    It's certainly possible that something is wrong with the micro-USB port on the phone, or that the charging circuit is jacked up (since it should only take 2 hours at most to fully charge the battery with the phone completely off if you're using a standard 1A charger).

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    10-18-2013 06:01 PM
  25. ErikaDG128's Avatar
    I am currently having the exact same issue. Just backed up all my files and decided to do a factory reset to see if it solved the problem but as expected it did not! I'm trying to find a solution but I've had no luck and I'm thinking of just getting a new phone entirely. Have you found an answer that has helped? I think I have literally tried everything! If you did find a solution please let me know, I'd greatly appreciate it.
    10-24-2013 05:16 PM
382 ... 678910 ...

Similar Threads

  1. Galaxy S3 charging issue
    By Axels15 in forum Samsung Galaxy S3
    Replies: 10
    Last Post: 09-18-2014, 01:01 PM
  2. Samsung Galaxy S3 - Bluetooth issue & Question
    By MaxPrimal in forum Samsung Galaxy S3
    Replies: 3
    Last Post: 05-04-2013, 06:49 PM
  3. Samsung Galaxy s3 battery issues
    By philip111 in forum Samsung Galaxy S3
    Replies: 1
    Last Post: 12-01-2012, 02:07 PM
  4. Samsung Galaxy S3/iMessage issue
    By dxf in forum Samsung Galaxy S3
    Replies: 5
    Last Post: 11-14-2012, 11:20 PM
  5. Samsung Galaxy S3 battery issue.
    By beachprance in forum Samsung Galaxy S3
    Replies: 9
    Last Post: 10-12-2012, 08:56 AM
LINK TO POST COPIED TO CLIPBOARD