1. herschen's Avatar
    I have an at&t galaxy s3. I have already installed amazon appstore (in order
    to do so I had to allow installation from unknown sources)

    Amazon appstore now prompts me to install an update
    won't let me press the install button see this screenshot
    https://docs.google.com/file/d/0B5Dj...p=docslist_api
    any ideas?
    06-09-2013 07:13 PM
  2. GSDer's Avatar
    In the future it would be preferable if you posted your screenshots directly, rather than directing us to Google Docs (or any other service, for that matter) - you never know what someone is redirecting you to, so better safe than sorry.
    Regarding your problem, I'd suggest: from any Home screen, press the Menu button, select Settings, scroll down and select Application manager, find the "Appstore" item and select it, then "Clear cache" and then see if the update proceeds as expected. If it doesn't, then do the same steps but "Clear data" (or just do both the first time and get it over with).Amazon appstore won't update-uploadfromtaptalk1370835058583.jpgIf that doesn't work then just uninstall it and reinstall from the Amazon site, where you'll get the latest.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2
    06-09-2013 10:31 PM
  3. B. Diddy's Avatar
    Can't access your screenshot on Google Drive.

    In any case, this phenomenon can happen if you're using a screen dimming app like Screen Filter by Haxor. Are you using something like that? If so, turn the brightness back up to normal, or turn off the dimming app temporarily, then try again.
    06-09-2013 10:31 PM
  4. Soundtrack to Chaos's Avatar
    I'm not opening that link, but if your issue is that you can't press the install button, chances are something is blocking the button, specifically an app that has an overlay over your screen

    Sent from my Sprint Samsung Galaxy s3 with a 7000mah extended battery... Because I'm not a chick with dainty hands or an HTC one user
    06-09-2013 10:43 PM
  5. herschen's Avatar
    Running Twilight. Problem solved. Thanks.
    06-10-2013 12:10 AM
  6. Soundtrack to Chaos's Avatar
    Running Twilight. Problem solved. Thanks.
    Good, glad everything worked out

    Also, with the amazon app store, occasionally when u try and hit the update button, but nothing happens, I assume this is just a bug because it's happened to me a lot in the past

    Sent from my Google Nexus 7 running aokp 4.1.2 #AOKP-Till-I-Die
    06-10-2013 12:25 AM
  7. Joy Anderson's Avatar
    Oh my goodness! Thank you so much. This had been driving me batty!! I was also running Twilight. Fixed it.
    08-04-2013 06:02 PM

Similar Threads

  1. Help: Amazon Appstore won't load
    By kevinwska in forum Amazon Kindle Fire
    Replies: 7
    Last Post: 12-17-2013, 02:38 PM
  2. Amazon Appstore App Update issue
    By scooter7 in forum HTC EVO 3D
    Replies: 0
    Last Post: 08-03-2012, 04:36 PM
  3. Amazon Appstore won't Install
    By bobvanjr in forum HTC EVO 4G
    Replies: 2
    Last Post: 10-18-2011, 08:44 PM
  4. Amazon Appstore updated itself today
    By FrankXS in forum Verizon HTC Thunderbolt
    Replies: 8
    Last Post: 07-29-2011, 11:08 AM
  5. Replies: 5
    Last Post: 04-24-2011, 08:44 PM
LINK TO POST COPIED TO CLIPBOARD