1. Digger Dager's Avatar
    Greetings,
    I recently bought a Galaxy S3 GT I9305 with the idea to use it on Straight Talk cell service. After trimming the SIM card that Straight Talk sent to fit, and setting the APN to their settings, the phone will not connect to the 3G cell service. According to the owners manual, the icon at the top of the screen should show the 3G symbol when the phone connects to that network. The icon my phone displays is the letter E, with the yellow and green arrows indicating send and receive. I know that there is 3G service in the area, as my daughter's phone is a Samsung Proclaim, bought from Wal-Mart as a Straight Talk phone. I have been in contact with Straight Talk tech support several times, but the APN settings that they supply are not working.
    Does anyone know how to fix this? Are there settings other than the APN that need to be changed? Any help would be appreciated.
    Digger Dager
    06-18-2013 06:21 PM
  2. GTWalling's Avatar
    The GT I9305 is a GSM phone and Straight Talk is CDMA, it may not work as the frequencies are different.
    Specs - More Cell Phone Providers SCH-S960L | Samsung Cell Phones
    Digger Dager likes this.
    06-19-2013 08:47 PM
  3. Digger Dager's Avatar
    GTWalling,
    Thank you for that little tidbit. After emails and phone calls to Straight Talk tech support, and On The Go Solutions where I bought the phone, no one mentioned that the phone itself is the problem. The phone is supposed to be factory unlocked, and came with the APN settings for T-Mobil.
    Much appreciated.
    Respectfully,
    Digger Dager
    06-19-2013 09:58 PM

Similar Threads

  1. Trouble connecting to Google services?
    By revickulous2001 in forum Verizon Galaxy Nexus
    Replies: 0
    Last Post: 12-22-2011, 09:53 PM
  2. Optimus not staying connected to 3G
    By outdors21 in forum LG Optimus S
    Replies: 10
    Last Post: 03-31-2011, 12:22 PM
  3. [Q] Troubles connecting to computer
    By Mrjayjubear in forum Verizon Fascinate
    Replies: 4
    Last Post: 01-25-2011, 05:55 PM
  4. What uses less battery: connected to 3g or 4g?
    By dvdqnoc in forum Sprint Epic 4G
    Replies: 1
    Last Post: 09-02-2010, 12:01 PM
  5. First-time User having trouble connecting to PC
    By lyciansarpedon in forum AT&T Captivate
    Replies: 9
    Last Post: 08-31-2010, 02:30 PM
LINK TO POST COPIED TO CLIPBOARD