1. Jon Curry's Avatar
    I'm becoming somewhat agitated with my Samsung Galaxy S3, as of tonight, every time my phone either times out, or I hit the power button to shut off the display, when I try to turn the display back on, it's unresponsive. The phone is still definitely on, I receive texts, the LED flashes, and the back and settings button still illuminate. I've had to rely on keeping my display on for 10 minutes just to insure I am able to use my phone. The only fix is to take out the battery and put it back in, in turn restarting the phone. I have restored factory defaults, whiped the cache, and there are and were no new apps installed on my phone that could have made this occur. Phone is in excellent condition, hasn't been dropped, there is only one very, very miniscule scratch on the bottom right of the display, this happened back in around December when I first got the phone, hasn't been an issue since. The screen works fine, there are no marks, scratches, cracks, and it is completely responsive, same with the Power buttons, home buttons, volume rockers, etc. It only happens when i turn off the display. Does anyone happen to know what the deal is? I'm on the newest OS for sure, and I'm under AT&T, I haven't had the phone over a year, so if I end up having to have it replaced will it be a ridiculous amount on my part?

    I'm on OS version 4.1.1
    06-21-2013 09:29 PM
  2. Golfdriver97's Avatar
    I'm becoming somewhat agitated with my Samsung Galaxy S3, as of tonight, every time my phone either times out, or I hit the power button to shut off the display, when I try to turn the display back on, it's unresponsive. The phone is still definitely on, I receive texts, the LED flashes, and the back and settings button still illuminate. I've had to rely on keeping my display on for 10 minutes just to insure I am able to use my phone. The only fix is to take out the battery and put it back in, in turn restarting the phone. I have restored factory defaults, whiped the cache, and there are and were no new apps installed on my phone that could have made this occur. Phone is in excellent condition, hasn't been dropped, there is only one very, very miniscule scratch on the bottom right of the display, this happened back in around December when I first got the phone, hasn't been an issue since. The screen works fine, there are no marks, scratches, cracks, and it is completely responsive, same with the Power buttons, home buttons, volume rockers, etc. It only happens when i turn off the display. Does anyone happen to know what the deal is? I'm on the newest OS for sure, and I'm under AT&T, I haven't had the phone over a year, so if I end up having to have it replaced will it be a ridiculous amount on my part?

    I'm on OS version 4.1.1

    Welcome to the forums!
    When you wiped the cache, what method did you use?
    06-21-2013 10:59 PM
  3. Jon Curry's Avatar
    I held down Volume Up + Power + Home, and then selected the option for wiping the cache there. It only took a few seconds, the phone rebooted, and it was to no avail. Right now I am using an app that keeps my display on constantly, which I don't want to keep having to do. Thanks for the welcome!
    06-21-2013 11:03 PM
  4. Golfdriver97's Avatar
    I held down Volume Up + Power + Home, and then selected the option for wiping the cache there. It only took a few seconds, the phone rebooted, and it was to no avail. Right now I am using an app that keeps my display on constantly, which I don't want to keep having to do. Thanks for the welcome!
    Sorry it isn't under better circumstances....You have done everything that I would have suggested to try. I am led to believe that the problem is physically in the power button. However, you should be able to wake the device with Home.
    06-21-2013 11:08 PM
  5. Jon Curry's Avatar
    Home isn't seeming to work either. The display just refuses to turn back on altogether now it seems. I see the samsung logo and that is it.
    06-21-2013 11:13 PM
  6. Golfdriver97's Avatar
    Home isn't seeming to work either. The display just refuses to turn back on.
    I don't know what else to suggest other than contacting either Samsung, AT&T or both and reporting the problem.
    06-21-2013 11:17 PM
  7. Jon Curry's Avatar
    I left it plugged in the charger for a while, it's been 75-88 percent all evening, I picked it up and tried hitting the power button and the display turned on again, now I'm too afraid to turn it off, or anything. I don't understand, it works sometimes and then other times it just doesn't at all. So it isn't anything software?
    06-22-2013 12:06 AM
  8. Golfdriver97's Avatar
    I left it plugged in the charger for a while, it's been 75-88 percent all evening, I picked it up and tried hitting the power button and the display turned on again, now I'm too afraid to turn it off, or anything. I don't understand, it works sometimes and then other times it just doesn't at all. So it isn't anything software?
    I am not inclined to think so. Always possible. Did you get any new updates?

    Sent from a M.O.A.R. Galaxy S3
    06-22-2013 08:31 AM
  9. GSDer's Avatar
    You don't happen to have Chrome installed, do you? I remember reading a bunch of posts about black screen issues, and they ended up root causing the problem to Chrome - once it was uninstalled and the phone was restarted the problem went away.

    You may want to check the two separate settings for screen lock behavior, just to be sure everything is set correctly. One controls how long the screen can be on before it'll turn the screen off (Settings -> Display -> Screen timeout) and the other controls how long the screen can be off before it'll lock the phone (Settings -> Lock screen -> Lock automatically).

    Do you have Settings -> Lock screen -> Lock instantly with power key enabled?

    Finally, you didn't just happen to add a screen protector or new case, did you?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 4
    06-22-2013 09:31 AM
  10. Jon Curry's Avatar
    Checked all of those, and yes, I did here recently. And it went on fine, but I took it off when this started happening because I was afraid it had something to do with it.

    I don't have Settings > Lock Screen > Set power
    06-22-2013 09:59 AM
  11. meyerweb#CB's Avatar
    If nothing else works, I would suggest trying a factory reset. That's the first thing AT*T will do, or tell you to do, if you contact them.
    06-22-2013 04:08 PM

Similar Threads

  1. intermittent GPS issues with Galaxy S3 verizon
    By kjhman in forum General Help and How To
    Replies: 10
    Last Post: 08-07-2015, 02:10 PM
  2. Battery Issue with galaxy s3
    By Worochc in forum Samsung Galaxy S3 in Canada (Bell/Telus/Rogers)
    Replies: 9
    Last Post: 03-25-2013, 02:05 PM
  3. 2007 BMW 530 - pairing contacts with Galaxy S3
    By eszylko in forum Samsung Galaxy S3
    Replies: 5
    Last Post: 12-20-2012, 11:39 PM
  4. several issues/questions with galaxy s3
    By kkappes in forum AT&T Galaxy S III
    Replies: 2
    Last Post: 12-16-2012, 07:31 AM
  5. Media Hub Issue with Galaxy 7.0 Plus wifi
    By klt813 in forum Samsung Galaxy Tab 7.0 Plus
    Replies: 15
    Last Post: 03-16-2012, 06:56 PM
LINK TO POST COPIED TO CLIPBOARD