1. TBolt2011's Avatar
    First of all, i did already post this in the T-Mobile S3 specific forums, but have not gotten an answer over 3-4 days. I've also asked on XDA and have not been able to find a solution.

    So anyways, I have had CM10 on my phone for probably 8 months now (almost since the day I got the phone) and have had no issues with the ROM whatsoever.

    I got a notification about an updated version of CM10 today and went ahead and downloaded and installed it, but when I finished the update, I had no personal data left on the phone, could not set up accounts to recover the data, could not (and still can't) recover backups through ROM Manager, and cannot recover backups through CWM. I get an error message "error mounting /system" and leads to a bricked phone upon reboot until I do a fresh install of CM10.0.

    I read after I started having the issues that I wasn't supposed to directly upgrade from the CM Updater with an S3, but it was already too late. Supposedly the issue is something along the lines of an emulated version of my phone's internal storage? If that makes sense. So whenever it's pulling a piece of information it's looking in the spot it should be in, but on a non-physically-existent SD card, essentially. That's what I gathered anyways.

    I have a 32gb external SD Card that is also in use with my S3. I have tried moving my ROM Backups to there and recovering from the External SD Card, but the same error message occurred, although ROM Manager was at least able to find the backups after they were moved (I also had to change the setting and request that it prefer to look through an external SD Card).

    So I have a usable ROM as far as the software itself, but I no longer can use any accounts or information that is stored with them or any of the same widgets (not a game-breaker) as I was able to previously. Is there a way to fix this? I've never just been completely stuck before >.<
    06-26-2013 11:29 AM
  2. meyerweb#CB's Avatar
    I don't use CM (way too buggy, especially on Samsung phones), but I believe 10.0 was Android 4.1.2, and 10.1 is Android 4.2.2. If that's correct, 4.2.2 changes the file structure on the phone in order to support multiple users on one device (which might make sense on a tablet, but frankly, is stupid on a phone). Anyway, that's why your apps couldn't find things where they expected them after upgrading. I think /system is now located in a sub-folder, rather than root.

    Not having used 4.2.2 yet, I'm sort of guessing here. A factory reset doesn't affect the file structure. If you reset with a 4.2.2 ROM installed, you still have the 4.2.2 file structure, and trying to flash or restore a 4.1.2 ROM on that file structure is probably not going to work correctly. Have you tried doing a factory reset after flashing 10.0? That *might* get you back to where you need to be. If not, there are a couple of things that might work.

    One option would be to reflash 10.1 as a clean install. Make sure you clear cache, dalvik and data (factory reset) before flashing. After flashing 10.1, I'd do a factory reset again, just for the heck of it. Then, instead of trying to recover a 10.0 backup, which I don't think will ever work, just reboot the phone and configure it from scratch, as if it were a new phone. If you use the same google account, it will get back all your account settings and let you re-install your apps and rebuild your accounts, but not get back any data that wasn't synced with Google or some other external source.

    Option two would be to use Odin to reflash the original factory ROM .tar file, which WILL (I am almost positive) recreate the 4.1.2 file structure. Then re-root, and you should be able to restore the CWM backup from your external SD card.
    TBolt2011 likes this.
    06-26-2013 03:24 PM
  3. TBolt2011's Avatar
    That actually makes a lot of sense if you're right about the file structure changing. The only reason I was very concered about backups is because that's supposed to be the fallback in case something goes wrong, and if backups go wrong then what are you left with? Lol. I don't mind having to reconfigure everything, but I absolutely need to be able to set up accounts and whatnot again (as if that isn't an obvious fact).

    I will give what you said a shot right now though, and if I have to then I will try and get back to being as stock as possible through Odin and trying that. I will let ya know how it goes!
    06-26-2013 10:18 PM
  4. TBolt2011's Avatar
    Problem solved!

    Doing a clean install of CM10.1 (doing dull cache, data, and dalvik wipes before and after the flash) corrected my issues. Thank you very much!
    06-27-2013 12:46 AM
  5. meyerweb#CB's Avatar
    Glad I could help.
    06-27-2013 03:06 PM

Similar Threads

  1. CM10.0 to 10.1 update issues
    By TBolt2011 in forum T-Mobile Galaxy S III Rooting, ROM's, and Hack's
    Replies: 0
    Last Post: 06-23-2013, 12:31 AM
  2. Galaxy tab 10.1 LTE, using a WIFI only, how to get update?
    By streetstrip01 in forum Samsung Galaxy Tab 10-inch
    Replies: 5
    Last Post: 12-31-2011, 08:56 AM
  3. Replies: 3
    Last Post: 05-30-2011, 04:56 PM
  4. [Guide] Atrix Rooting, FAQ's, & How To's (Updated 2/19/10)
    By Cory Streater in forum Atrix Rooting, ROMs, and Hacks
    Replies: 3
    Last Post: 03-19-2011, 11:04 PM
  5. Flash Player Updated To 10.1.95.1
    By klittle81 in forum Android Apps
    Replies: 19
    Last Post: 09-22-2010, 01:03 PM
LINK TO POST COPIED TO CLIPBOARD