1. nelswort's Avatar
    This just started within the last few days: My S3 is flipping between Wi-Fi connection (strong signal) and/or the 4G/3G connection. My phone is 7 months old and used A LOT. Is my battery going bad? It's driving me nuts, not too mention using up most of my monthly data package when it doesn't stay on Wi-Fi (like here at home and when at work).
    07-04-2013 11:49 AM
  2. Tommy Clarkson's Avatar
    Could be a problem with you ISP? I wouldnt think thus would have anything to do with your battery.
    07-04-2013 12:53 PM
  3. rhl2's Avatar
    Probably it is a internet setting problem.correct your mobile internet setting and move on.
    07-04-2013 04:57 PM
  4. GSDer's Avatar
    How quickly is it flipping? Minutes; hours;?
    Does it only do this on your home WiFi connection?
    Have you tried removing the WiFi connection from the phone and then setting it up again?
    Are all of the other devices on your home network behaving normally?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 4
    07-04-2013 05:23 PM
  5. mssca's Avatar
    If you have access to the router, try forcing the S3 out of the network and then goo back and reenter. I had an issue like this with my D-Link wifi router. That's how I fixed it.

    The only time the battery will drain abnormally with respect to networks if you have a weak signal.

    Posted using Samsung GS III
    07-04-2013 09:56 PM
  6. nelswort's Avatar
    GSDer - it's flipping almost instantaneously. When I "connect" to my Wi-Fi, it stays for a few and then as soon as I use my message, email, facebook, etc., it flips over to 4G. My husband's notebook uses our home Wi-Fi connection and he's not having a problem with that OR his S3 either. My phone did an update on Monday (? I think it was) of this week and since then, I've noticed some screwy things going on; i.e., it downloaded a couple of apps I've never heard of, Flip Board, etc., and those I can't uninstall. I'm wondering now if this is related to that. I'm planning on going to my local Verizon store tomorrow when they open and have a tech look at it/explain to me what is happening. Thanks for the suggestions, I appreciate it.
    07-04-2013 11:29 PM
  7. GSDer's Avatar
    Oh, just received the latest OTA from Verizon? In that case I'd suggest making a backup of anything important (call logs; SMS; syncing contacts & calendar with Google; etc.) and performing a Factory Reset (the folks at the Verizon store are probably going to ask you to do one anyway).
    You could try:
    Helium: http://market.android.com/details?id...ikdutta.backup
    or
    MyBackup Pro: http://market.android.com/details?id...id.MyBackupPro (there's a trial version)
    for your backup needs.
    Also be sure to do a power off and battery pull.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 4
    07-05-2013 04:27 AM

Similar Threads

  1. Please help... My Galaxy S4 won't let me enable Wi-Fi
    By scatteredmac in forum Samsung Galaxy S4 Active
    Replies: 307
    Last Post: 06-04-2018, 08:43 PM
  2. Having problems with group MMS
    By oelitreby in forum HTC One Rooting, ROMs & Hacks
    Replies: 9
    Last Post: 07-13-2013, 09:52 PM
  3. cannot connect to wifi
    By Xhanah Hersan in forum General Help and How To
    Replies: 1
    Last Post: 07-04-2013, 10:34 PM
  4. SPen Screenshot Problem?
    By fade2black101 in forum Samsung Galaxy Note 2
    Replies: 2
    Last Post: 07-04-2013, 10:10 AM
  5. memory problem
    By aldildia in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 0
    Last Post: 07-04-2013, 04:47 AM
LINK TO POST COPIED TO CLIPBOARD