11-08-2016 09:48 PM
241 12345 ...
tools
  1. Biggs94's Avatar
    Good afternoon,

    I have a similar problem. Yesterday, as I tried to see something on my phone, the screen just wouldn't turn on. The phone will actually turn on but nothing is displayed. I have received phone calls while in the car, the phone succesfully connects with bluetooth however, still no screen.

    I have tried removing the battery for a few minutes, putting it back in and charging the phone while turned off but still no luck. I also tried booting using the other methods mentionned earlier (Volume Up+Home+Power) but no luck.

    I can see the blinking light from receiving a text message and I can see the "Back" and other button next to the Home button light up when I try to interact with the phone. I can also feel the phone vibrate when I turn it on.

    Is there anything I can do? Your help would be much appreciated.

    Thank you.
    10-19-2013 02:21 PM
  2. GSDer's Avatar
    Biggs94,
    You didn't happen to drop the phone or anything? If so, it could be that the connection between the mainboard and screen came loose.

    Otherwise you may just need a replacement screen assembly http://m.repairsuniverse.com/samsung...ent-white.html

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    10-19-2013 07:31 PM
  3. FatKat Pat's Avatar
    Last weekend my gs3 died and Samsung won't cover it. I've had the phone for about a year. Don't have carrier insurance. I unplugged the phone from the charger and the screen lit up like normal. I pressed the power button to turn the screen off. The turn off/restart menu popped and the phone froze. So I pulled the battery for a few mins and then when I put the battery back in the phone vibrates and the first splash screen lights up for maybe two seconds and the phone turns off. Tried this a few times and then took it to T-Mobile. T-Mobile said they couldn't help me out and to contact Samsung. I contacted Samsung where they said they would cover it no problem and they will email me a label for UPS to take it to Plano, TX. I shipped it out Monday and Friday they sent it back without repairing it. The tab that feeds power from the battery to the phone lifted and they don't cover internal or external repairs on their products. I was informed it is past economical repair for them. I have never dropped the phone or done anything to compromise it at all. Bought it and put it in a Otter box day one. The phone looks brand new but has the internal problem. Is there a repair place that can repair what Samsung won't? Should I just throw it on ebay and wait on the Nexus 5? I will never buy another Samsung product after hearing four of their service reps tell me they don't cover internal or external repairs and couldn't give me a answer of what they cover. If I can repair it to keep as a back up or sell for more than parts I'm willing to go that route.
    10-20-2013 01:51 PM
  4. karl murphy's Avatar
    after speaking to somebody i put my phone in my pocket and looked at it 30 mins later and the screen was black. i've tried charging it? i'ver taken battery out and put back? i dont see any charging icon? i see nothin at all!!! is my phone dead??

    i cant even get a flicker off my s3? it went black on me this morning and hasnt come back on since? was working fine (i had just finished a call) next time iue indicator light. t to do anything and hasnt worked after that??
    10-21-2013 12:11 PM
  5. Quentin Scholl's Avatar
    Hey guys. Seems like this is a pretty common problem. I've experienced much of the same issues you all have had. I have a stock Verizon S3, no custom ROMS, no physical damage.

    Background:
    Phone recently began to act sluggish. Would randomly shutoff,even on charger or loading an app. When restarting phone, could not get past 4G LTE spalsh screen. Got it to work for a day after reading up on a few tricks, but now does not even turn on.

    I'v Tried:
    Battery Tricks - I've tested the battery and it is good. Took it out and works fine in my wife's S3. Previously to complete failure, taking the battery out and putting it back in did work, but it would get stuck at the colorful Verizon 4G LTE splash screen. I managed to get past it using Recovery mode, but still had same problems. I've left the battery out for a whole day, put it back in on the charger and still nothing. Even when plugged into the charger, the LED doesn't light up.

    Recovery Mode - Prior to complete failure of the battery trick, I did managed to get into recovery mode. I cleared cache, still got stuck at 4G LTE splash screen. Did a factory reset and did manage to get past the splash screen and into the phone. However, during the auto recovery process, it shut off while dl'ing some apps and will not even power on how. When connected to a charger, the LED doesn't even light up. Also tried to plug into my PC and it is not being recognized by it.

    Smash Method - This is apparently a real thing. Click for reference. Judging by the comments, it helped a lot of people. A possible culprit is the power button. I tried several times giving it a hard smack, but did not work for me. Maybe I'm not giving it a good enough smack, but too afraid to damage phone anymore than it is (think cracked screen!).

    Going to Try
    3rd Party Online Repair - This is my last ditch effort. I found this guy who offers through eBay to fix the power button or the boot loader. Apparently, a messed up boot loader will also completely brick your phone. I don't know which issue is causing my phone to be a paper weight but I'm going to send it in an give it a try. $25-$30 seems to be a reasonable amount of money to spend prior to me purchasing a brand new phone. Even though I have a credit to upgrade through Verizon, I do not want to lose my grandfathered unlimited data plan. I'll be sure to follow up in this thread with the results. Wish me luck!
    10-22-2013 08:25 PM
  6. GSDer's Avatar
    Wish me luck!
    Good Luck! :beer:

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    10-23-2013 10:11 AM
  7. kcad01's Avatar
    Last week, my GS3 shut itself off. When I tried to turn it back on, I would feel the start vibration, get the Samsung splash screen, then the Galaxy SIII splash screen, then the phone would turn itself off. It would not charge with ANY charger from ANY USB port or ANY wall outlet. I traded batteries with a coworker who also has an SIII and the phone still would not turn on. It would not boot into recovery mode or download mode. It would not connect to Kies. Finally, I took it to the Sprint store, without any hope of a fix. I had cracked my digitizer twice previously (paid Samsung to fix/replace) and have never paid for insurance, so I expected to be told that there was nothing they could do. However, the tech tried everything I tried and was unsuccessful. He opened it up and found no damage, no sign of water, no sign of a drop. He said the problem must be in "the board" and gave me a brand new SIII - no charge. If all else fails, try the store. I may have been extremely lucky, maybe you will be too.
    10-23-2013 11:59 AM
  8. ashleybrookevv's Avatar
    I pulled my Galaxy S3 out of my pocket and it was turned off. I tried to turn it on, and it started with the "Samsung" screen like it was going to turn on, but then it turned back off. It has been doing this for the past 8 hours. I've taken out the battery for several hours, charged it, and everything. I even tried the Recovery mode thing, but it goes to the "Samsung" screen and then turns off. I don't know what to do. HELP.
    10-28-2013 09:10 PM
  9. GSDer's Avatar
    If you can't get into Recovery mode then your only option is to try booting into Download mode. If that works then you can try reloading the operating system by using the Kies software on your PC.

    If you're not comfortable with the above then your best bet is to take it to the local carrier store and see if they can recover it for you or replace it.

    If you want to try Download mode - with the phone completely off, press and hold the Volume Down and Home and Power buttons simultaneously, and release them all when you see the Samsung splash screen. If it's successful you'll be left at a 'downloading' screen, where the phone simply waits for a download to begin. Just remove the battery to turn it off.

    If Download mode was successful and you want to try reloading the firmware yourself, here's an overview of what to do:
    - if you don't already have the Kies software installed on your PC, download it (just search Google) and install it. The first time it runs it'll update itself to the latest version so make sure you run it once before proceeding.
    - put your phone in Download mode: with the phone completely off, press and hold the Volume Down and Home and Power buttons simultaneously, and release them all when you see the Samsung splash screen
    - connect the phone to your PC with the USB cable that came with the phone
    -- if you've never had the phone connected to your Windows-based computer before, you'll see messages about installing drivers, etc - just wait until this is done (may take 5 or 10 minutes) [I don't know what happens if you have a Mac - it probably just works]
    - in the Kies software, select the second item in the Tools menu and just follow the prompts to enter the model number (in CAPS) and IMEI/Serial Number (both found under the battery - it's ok to remove the battery at this point)
    - the Kies software should start downloading the correct firmware for your phone from the Internet; once that's done (depending on your Internet connection speed) it'll begin downloading that to the phone (this probably takes 10 minutes or so)

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    10-29-2013 12:04 AM
  10. Shahid Hashmi1's Avatar
    Hi All,

    I've read through these messages and I have a similar issue but never exactly the same. I'll try and add as much information as I can.

    I was watching a downloaded movie, finished it and locked my phone. About 10 minutes later the white LED light on, I went to check it to see what the notification was, I clicked on the lock/power button to unlock the phone but the screen stayed blank, however the white LED light stayed on. I then pressed the home button, but the same thing happen, the screen stayed blank.

    I then removed the battery and re inserted it and then attempted to turn it back on, however the phone wouldnt turn on. I then plugged in the charger, however the phone wouldnt turn on, no splash screen, no red LED light. It has stayed like this every since.

    I have tried to removing the battery.. leaving it for half hour and then re attaching it and charging it for a few hours, however this hasnt fixed anything. Still no red LED charging light let alone any splash screen.

    I have already tried to launch the phone in both recovery and download mode, both times nothing has happened.

    I have already tried to turn the phone on with the phone attached to the wall charger with NO battery in the phone, yet no luck.

    It sounds like my phone is screwed, but does anyone have any other ideas?
    11-02-2013 11:40 AM
  11. GSDer's Avatar
    Shahid,
    Unfortunately I'd have to agree with your assessment - it sounds like your phone is borked.

    If you had a JIG that would be your last ditch opportunity to boot the phone in Download mode.

    If you have the International model, and it's older, it's probably Sudden Death Syndrome - Samsung should repair that for free (but of course you'll have lost everything on the phone, except for what you have on an SD card or synced with the cloud).

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    11-02-2013 07:11 PM
  12. Shahid Hashmi1's Avatar
    Thanks for the quick reply GSDer.

    Two questions...
    1. What is JIG?
    2. Would it be my network provider (T-Mobile) or Samsung that I should take my phone to if it is Sudden Death Syndrome? I do have an early model but what is an international model? How do I know that mine is an international model?
    11-03-2013 06:09 AM
  13. GSDer's Avatar
    A JIG is a little plug that connects to the micro-USB port which provides specific resistance values which cause the phone to boot into Download mode. You can get them on Amazon and elsewhere - just do a search.

    The i9300 (there may be other variations) is the International model; it had a different CPU and radios from the US version.

    Just take it to T-Mobile. If you don't get any satisfaction then contact Samsung.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    11-03-2013 06:02 PM
  14. Evelin Flores's Avatar
    i went to my setting and restarted my gs3...when it started to turn back on,it stopped on the company name..what do you do in order for it to tun on all the way
    11-03-2013 07:56 PM
  15. meyerweb#CB's Avatar
    i went to my setting and restarted my gs3...when it started to turn back on,it stopped on the company name..what do you do in order for it to tun on all the way



    The first thing would be to read the suggestions already given in the previous 69 posts in this thread, and see if any of them help you.
    11-03-2013 08:04 PM
  16. mraff36's Avatar
    I was on facebook when my s3 randomly powered off. When i hold down the power button to turn it back on my phone just vibrates a couple times. When i plug it into the charger it vibrates every so often untill i unplug it. I have tried holding down the power, home, and volume up button but that did not do anything. (Nothing appears on the screen when i try to turn it on or plug it in to charge either.) Any help would be appreciated.

    however i just plugged my phone into the charger without the battery and the orange LED came on. Other than the light being on it is unresponsive (nothing comes on the screen at all)
    11-03-2013 11:18 PM
  17. CharlesEd's Avatar
    My Samsung galaxy s3 will turn on... Sort of.
    The LED light will turn on and it vibrates to let me know that it is on, but the screen stays completely black. Help?
    11-04-2013 01:40 PM
  18. Fanta45's Avatar
    how do i perform a factory reset
    11-05-2013 05:07 PM
  19. GSDer's Avatar
    how do i perform a factory reset
    Settings -> Back up and reset -> Factory data reset

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    11-06-2013 05:19 PM
  20. dcam26's Avatar
    hi can someone help me?
    i was on the phone and it suddenly shut off on me.
    i tried to turn it back on but all it did was go to the samsung screen (and all the other screens it goes to before you're actually at your lock screen) and it would just repeat itself.
    So i took the battery out for 20min and put it back in.
    when i put the battery back in, it turns on by itself without me even clicking the power on button.
    it kept doing the same thing.
    so i pressed volume up with the power button and home button.
    i cleared cache and rebooted
    it kept doing the same thing.
    i put it on the charger, the charger icon doesn't come up unless i click the power on button at the side.
    i'm running out of options
    HELP PLEASEEEEEEEEEEEEEEEEE
    11-06-2013 05:29 PM
  21. GSDer's Avatar
    dcam26,
    See post #65

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    11-06-2013 07:09 PM
  22. sarahram23's Avatar
    my Samsung s3 wont turn on it just started this morning around 9, it turned on around lunch then turned off again 30 minutes later. it occasionally turns on for like 1 minute then shuts off. now it wont turn on at all. I have tried the recovery thing and taking out the battery and charging thing, but nothings working! someone help me
    Ayoub Libuye likes this.
    11-07-2013 04:18 PM
  23. Monique Michelle's Avatar
    Let me begin by saying I dropped my phone a couple of times but I jus got it in aug and its been working fine even after I dropped it (the last time was about a week ago) and I switch chargers with my cousin by mistake and thats when the problems begin. The charger had a short in it so i had to play with it to get it to charger and when i plug a new charger that i jus brought in it no longer chargers at all. And I've tired on several different new chargers. I don't know what else to do Ive tired everything and it still doesn't want to charge.
    11-13-2013 12:15 PM
  24. AmyLeigh369's Avatar
    how long is the download thing supposed to take? I held the volume down button, power button and home button and it came up with the screen so I pressed volume up for it to download and now I don't know if its downloading or the screen is frozen?? help ?? it's been like this for probably five minutes now??
    11-17-2013 04:18 PM
  25. GSDer's Avatar
    AmyLeigh369,
    Just having the phone in Download mode doesn't do anything - as referenced in post #65, you have to have the phone connected to a computer and be downloading firmware via Kies (or Odin) in order for anything to happen.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    11-17-2013 11:10 PM
241 12345 ...

Similar Threads

  1. Charging Problem - Samsung Galaxy Ace Plus
    By lyndaa54 in forum General Help and How To
    Replies: 2
    Last Post: 03-23-2016, 07:10 PM
  2. T_T I honestly can say i dislike my DNA
    By kageneko in forum Verizon Droid DNA
    Replies: 13
    Last Post: 07-23-2013, 06:21 AM
  3. vigin mobile galaxy s3 battery life
    By Russell Eldridge in forum Samsung Galaxy S3
    Replies: 7
    Last Post: 07-22-2013, 11:16 AM
  4. Waiting for new version for galaxy note
    By alaoddin in forum General News & Discussion
    Replies: 0
    Last Post: 07-21-2013, 02:57 AM
  5. Can u please relaese ver. 4.3 for galaxy note 1
    By alaoddin in forum Samsung Galaxy Note
    Replies: 0
    Last Post: 07-21-2013, 02:54 AM
LINK TO POST COPIED TO CLIPBOARD