1. rabinah's Avatar
    My galaxy s3 got low on power and turned itself off and when i got home to charge it, it wouldnt charge or start at all.
    I then went into repair mode and it started charging, i then cleared cache and did a factory reset and i rebooted, then it went into a bootloop and ive tried to do this many times but it does not work....
    Ive tried googling it but it just says "clear cache and factory reset the device" and i cant turn it in to my provider either because i broke my screen so they refuse to even look at it.
    what should i try to do so my phone works?

    Best regards Robin
    (sweden)
    07-30-2013 10:34 AM
  2. GSDer's Avatar
    You can put it into Download mode and use the Kies software to reload the correct ROM for your model/carrier.
    Kies will prompt you for the model number and IMEI - that information can be found under the battery.

    Sent from my SCH-I535 using Tapatalk 4 Beta
    07-30-2013 08:30 PM

Similar Threads

  1. *SOLVED* Problem: "No big deal, but your Wi-Fi is off"
    By digital0verdose in forum Google Chromecast
    Replies: 12
    Last Post: 10-02-2014, 06:04 PM
  2. Having problems rooting Samsung s4 verizon
    By Derek11598 in forum Samsung Galaxy S4 Rooting, ROMs & Hacks
    Replies: 3
    Last Post: 08-06-2013, 11:34 AM
  3. Replies: 11
    Last Post: 08-01-2013, 11:32 AM
  4. Just rooted, flashed ARHD 12.1 and now firmware question?
    By Nutzer in forum HTC One Rooting, ROMs & Hacks
    Replies: 2
    Last Post: 07-30-2013, 03:29 PM
  5. Have an S3 and thinking of getting a S4
    By Drunder40 in forum Verizon Samsung Galaxy S4
    Replies: 1
    Last Post: 07-30-2013, 10:02 AM
LINK TO POST COPIED TO CLIPBOARD