1. Matthew Perez's Avatar
    Hey guys you might have seen my post earlier. I posted it in the wrong forum. .-. Haha.
    But anyways. Put simply, my nosy cousin ripped my phone off of the charger because she was trying to see who was texting. And I think it ruined my charging port. It charges verly slowly and disconnects easily if you move the chord around. Do you guys think I should get my port replaced or could it have also damaged my chord?
    08-10-2013 11:31 PM
  2. GSDer's Avatar
    Get your nosy cousin to spring for the ~$600 that it'll cost to purchase a brand new phone and see how she treats your stuff in the future...

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2
    08-11-2013 12:29 AM
  3. Matthew Perez's Avatar
    Additionally, if I use my phone while it's charging, the battery percentage sometimes decreases.
    08-11-2013 02:42 AM
  4. Hewe Wongx3_DERP's Avatar
    You can send it to your Company like T-Mobile, Vurison, AT&T ect, See what they say but first, Get a new charger, If they send it to Samsung to Diagnose the problem.

    Sent from my Galaxy S3
    Matthew Perez likes this.
    08-11-2013 03:18 AM
  5. GSDer's Avatar
    As the previous poster noted, the first thing to try is a different charger/cable. If those don't make any difference then the micro-USB port on the phone is probably damaged and you should get a replacement (if you have insurance) or get it repaired through Samsung.
    The only other option would be to use a wireless charging solution.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2
    Matthew Perez likes this.
    08-11-2013 12:13 PM
  6. Matthew Perez's Avatar
    Alright. I tried using a different chord and it still disconnects. I'm probably going to just get the port replaced or repaired.
    Thank you guys. o:
    08-11-2013 03:41 PM
  7. GSDer's Avatar
    Good luck with that.
    If you do find a reputable place that does a good job be sure to give them a shout out here for others that may be in a similar situation.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2
    08-11-2013 04:57 PM

Similar Threads

  1. Xperia L video playback problems
    By Sudeep Roy in forum Sony Xperia Series
    Replies: 3
    Last Post: 01-18-2014, 04:37 PM
  2. Galaxy S4 Battery Drain
    By Caleb Mina in forum Samsung Galaxy S4
    Replies: 2
    Last Post: 10-16-2013, 03:24 PM
  3. Galaxy S3 water damage
    By jeevz87 in forum Samsung Galaxy S3
    Replies: 14
    Last Post: 08-30-2013, 08:32 AM
  4. At&t galaxy s4 root?
    By tian wu in forum AT&T Samsung Galaxy S4
    Replies: 5
    Last Post: 08-15-2013, 06:34 PM
  5. Samsung Galaxy 2 10.1 won't charge when on
    By Angel Sandlin in forum Samsung Galaxy Tab 2 10.1
    Replies: 0
    Last Post: 08-10-2013, 09:34 PM
LINK TO POST COPIED TO CLIPBOARD