1. AngryGhost44's Avatar
    I tried to root my new Sprint Galaxy S3 (SPH-710) version with the Samsung Galaxy S3 Toolkit 7.0, but something went wrong. Right now, I am only able to boot it into Odin mode and although I am able to use Odin to communicate with the device, everything I have tried so far to unroot it (or potentially root it properly) hasn't worked.

    Right now, I am trying to do this: How to unroot Galaxy S3 to Stock Official Firmware

    I'm still downloading the original firmware and when it's finished, I'll use Odin to push it onto my phone and see what happens. After that, I'm not too sure what I can do as the phone won't boot into system (I suspect the OS has been damaged or removed) and it doesn't want to boot into Recovery Mode, either.

    Sometimes, when I hold the power button on and try to boot into system mode, the phone vibrates and a battery icon shows up, but it's plugged via USB into my laptop so I'm sure it has power.

    Any suggestions on what to do? My end goal is to root my phone, but as an intermediate step, I'm more than happy to get it just working again.

    Thanks in advance.

    UPDATE 1: I was able to boot into Recovery Mode and wipe the disk, however, a whole bunch of things failed to mount (/cache, /mount and others) because they didn't exist. Eventually the phone rebooted and got stuck on the Samsung Galaxy S3 screen. I have turned it off and removed the battery... will give it a few minutes before my next attempt. Looks like a lot of stuff is missing and I will need to get it back on before the system is able to boot up, or even recover itself.

    UPDATE 2: I have left the phone plugged into a wall outlet for a while, but whenever I try to turn it on it vibrates, shows a battery icon, and shuts off or else it just doesn't turn on. I'm going to leave it be for another half hour, but I am really surprised that the battery doesn't seem to be charging.

    Update 3: I'm able to get into Download/Odin mode but not the system mode ever, so I can't drag-and-drop files onto the phone as is necessary to do the root.

    UPDATE 4: I used Odin to put recovery.tar.md5 onto the phone and when it booted up into recovery mode I had the same issues as before... nothing would mount (sdcard, cache, system, et cetera).

    UPDATE 5: I am using Odin to put original firmware back onto the machine. It's a really long file that starts with KIES and is in .tar.md5 format. I will be happy to be able to reliably get into recovery mode and be able to restore the machine. If this doesn't work, tomorrow I'll try to do a recovery from an external SD card.

    UPDATE 6: GLORY! I was able to boot the phone up into system. It's not rooted, so now that I know how to fix it I am going to try to root it. Wish me luck!

    UPDATE 7: I give up. I was able to put CWM recovery mode onto my phone via Odin, but the root of the issue is that although I have copied the teamepic root from recovery zip to many places on the phone, I can't find it in the recovery menu. I'm not sure what the issue is here at all.

    UPDATE 8: I attempted the unified G3 rootkit, but even though I used a different custom recovery mode, it still failed because I wasn't able to find the zip file to install the OS from. I've reinstalled the default firmware and will not attempt anything else until I have a significantly different idea. The same issue keeps coming up: I just can't find the zip I've put on the phone once I'm in recovery mode.

    UPDATE 9: CF auto root doesn't root it although I selected the right model and superuser did get onto my phone. Something is keeping the phone from being rooted once it's in recovery mode. What I think is the best option is to retry the GS3 root kit method once I have an external micro SD so that I can navigate to the zip that's supposed to go on the phone before everything else, because that's the one problem I can't get around. No matter what, the phone is not recovering from the zip file that it is supposed to and I can't find the zip file itself to force it to do so.

    UPDATE 10: I used TeamWin's recovery tool and for some reason, that let me find and use the Team Win rooted recovery zip file. I confirmed that my phone is rooted and have been able to get rid of some of the ****ty bloatware that it came with it.

    Thanks, guys. I'm sure you were with me, in spirit.
    08-24-2013 11:58 PM
  2. Golfdriver97's Avatar
    I tried to root my new Sprint Galaxy S3 (SPH-710) version with the Samsung Galaxy S3 Toolkit 7.0, but something went wrong. Right now, I am only able to boot it into Odin mode and although I am able to use Odin to communicate with the device, everything I have tried so far to unroot it (or potentially root it properly) hasn't worked.

    Right now, I am trying to do this: How to unroot Galaxy S3 to Stock Official Firmware

    I'm still downloading the original firmware and when it's finished, I'll use Odin to push it onto my phone and see what happens. After that, I'm not too sure what I can do as the phone won't boot into system (I suspect the OS has been damaged or removed) and it doesn't want to boot into Recovery Mode, either.

    Sometimes, when I hold the power button on and try to boot into system mode, the phone vibrates and a battery icon shows up, but it's plugged via USB into my laptop so I'm sure it has power.

    Any suggestions on what to do? My end goal is to root my phone, but as an intermediate step, I'm more than happy to get it just working again.

    Thanks in advance.

    UPDATE 1: I was able to boot into Recovery Mode and wipe the disk, however, a whole bunch of things failed to mount (/cache, /mount and others) because they didn't exist. Eventually the phone rebooted and got stuck on the Samsung Galaxy S3 screen. I have turned it off and removed the battery... will give it a few minutes before my next attempt. Looks like a lot of stuff is missing and I will need to get it back on before the system is able to boot up, or even recover itself.

    UPDATE 2: I have left the phone plugged into a wall outlet for a while, but whenever I try to turn it on it vibrates, shows a battery icon, and shuts off or else it just doesn't turn on. I'm going to leave it be for another half hour, but I am really surprised that the battery doesn't seem to be charging.

    Update 3: I'm able to get into Download/Odin mode but not the system mode ever, so I can't drag-and-drop files onto the phone as is necessary to do the root.

    UPDATE 4: I used Odin to put recovery.tar.md5 onto the phone and when it booted up into recovery mode I had the same issues as before... nothing would mount (sdcard, cache, system, et cetera).

    UPDATE 5: I am using Odin to put original firmware back onto the machine. It's a really long file that starts with KIES and is in .tar.md5 format. I will be happy to be able to reliably get into recovery mode and be able to restore the machine. If this doesn't work, tomorrow I'll try to do a recovery from an external SD card.

    UPDATE 6: GLORY! I was able to boot the phone up into system. It's not rooted, so now that I know how to fix it I am going to try to root it. Wish me luck!

    UPDATE 7: I give up. I was able to put CWM recovery mode onto my phone via Odin, but the root of the issue is that although I have copied the teamepic root from recovery zip to many places on the phone, I can't find it in the recovery menu. I'm not sure what the issue is here at all.

    UPDATE 8: I attempted the unified G3 rootkit, but even though I used a different custom recovery mode, it still failed because I wasn't able to find the zip file to install the OS from. I've reinstalled the default firmware and will not attempt anything else until I have a significantly different idea. The same issue keeps coming up: I just can't find the zip I've put on the phone once I'm in recovery mode.

    UPDATE 9: CF auto root doesn't root it although I selected the right model and superuser did get onto my phone. Something is keeping the phone from being rooted once it's in recovery mode. What I think is the best option is to retry the GS3 root kit method once I have an external micro SD so that I can navigate to the zip that's supposed to go on the phone before everything else, because that's the one problem I can't get around. No matter what, the phone is not recovering from the zip file that it is supposed to and I can't find the zip file itself to force it to do so.

    UPDATE 10: I used TeamWin's recovery tool and for some reason, that let me find and use the Team Win rooted recovery zip file. I confirmed that my phone is rooted and have been able to get rid of some of the ****ty bloatware that it came with it.

    Thanks, guys. I'm sure you were with me, in spirit.
    Sorry, I just saw your post now.
    Welcome to the forums!

    Sent from a SlimROM S3.
    08-25-2013 03:30 AM
  3. meyerweb#CB's Avatar
    Glad you got it rooted successfully. A couple of thoughts:

    1. TWRP is superior to CWM. I always recommend using TWRP if it exists for the specific device.

    2. Before deleting a bunch of apps, I would suggest using Titanium backup to "freeze" them. The phone won't see them, they can't run, and can't use up any cpu or battery. If you really need the extra memory, you can delete them after you've had them frozen for a while, to make sure deleting it won't cause any problems.
    08-25-2013 06:44 PM
  4. K00l Br33z3's Avatar
    I don't understand how you were able to access the OS zip file. I downloaded Cyanogenmod on my external in hopes to flash from there or move it to the internal sd card.
    02-07-2014 06:50 AM

Similar Threads

  1. How to recover deleted files
    By valpd in forum AT&T Galaxy S III
    Replies: 7
    Last Post: 11-20-2015, 01:51 AM
  2. Can you force 3g?
    By phositadc in forum Motorola Droid Ultra
    Replies: 2
    Last Post: 02-06-2014, 06:09 AM
  3. Galaxy S4 battery problems.
    By SamsungS4User in forum General News & Discussion
    Replies: 3
    Last Post: 08-27-2013, 01:41 AM
  4. Samsung Galaxy Note 8.0 Wallpaper and Facebook syncing problem
    By cawaiiyuki in forum Samsung Galaxy Note 2
    Replies: 0
    Last Post: 08-24-2013, 09:51 PM
LINK TO POST COPIED TO CLIPBOARD