1. natanazizov's Avatar
    When I try to plug in my S3 to my computer nothing happens. It charges but I get no pull down options for USB and the computer doesn't recognize it. I know its not the cable or the computer because I tried my mom Galaxy S1 and it connects fine and the computer recognizes it. I also tried connecting to it in download mode and still nothing. It worked before. The phone has recently been in contact with a fair amount of water but everything else works perfectly fine. Also while I was away i had to use a cheap $5 charger to charge my phone. The charger charged my phone fine but during charging the screen wouldn't work. Maybe the charger messed up my phone?

    Once again the phone charges fine. Both through computer usb and socket usb but it doesn't connect for file transfer.
    09-06-2013 06:06 PM
  2. meyerweb#CB's Avatar
    Did the S3 connect to the computer correctly before it got wet? Before you used the cheap charger?

    Did both the water contact and cheap charger happen during the same time period, and did you connect the charger while the phone was wet?

    It's always hard to diagnose from a distance, but I would be surprised if the charger, by itself, damaged the phone. The charging pins in the connector are separate from the data pins, which is what are used to connect to the PC. If you connected the charger while there was water in the connector, it's possible you damaged the phone that way. When phones get wet, the standard advice is to immediately pull the battery (and SIM and SD cards, if so equipped), and let the phone dry completely before using it. Sealing it in a container with uncooked rice will help dry it out.

    If the phone is completely dried out, I don't have any advice that might solve the problem.
    09-06-2013 07:24 PM
  3. natanazizov's Avatar
    The water damage indicators are still white. By getting water on it I mean that i took it with me in the bathroom and there was just some water on the screen of the phone after my shower nothing major. The charger and water were completely separate issues. I don't charge my phone in the bathroom.

    And yes it did connect perfectly before.

    Now there is a new issue. The phone isn't charging while its off but instead vibrates every couple seconds. It charges perfectly when its on. But still doesn't connect to my computer.

    EDIT: It looks like it is charging while off its just constantly giving me that weird haptic feedback vibration and the led indicator is blank and not red.
    EDIT2: When I plug out the battery and plug the phone into the charger without the battery the red led light works again and the phone stops vibrating. However the phone doesn't turn on.When i plug the battery back in led lights goes off and it starts vibrating again.
    09-06-2013 07:36 PM
  4. natanazizov's Avatar
    Factory reset my phone. Both problems persist.
    09-06-2013 08:27 PM
  5. meyerweb#CB's Avatar
    Do you know anyone else with a S3 you could swap batteries, chargers and cables temporarily, and also try connecting the other S3 to your PC, and your S3 to another PC? That should help narrow down the issue.
    09-06-2013 09:10 PM
  6. natanazizov's Avatar
    My mom has an S1. Her connects perfectly. So cable and computer checks out. I cant swap battery's.
    09-06-2013 09:17 PM
  7. GSDer's Avatar
    Forgetting the strange charging behavior for the moment, it sounds like there may be a problem with the micro-USB port on your phone. You could try:
    - blowing it out with compressed air
    - with the phone off and the battery removed, use a needle to gently poke around in the micro-USB port to see if anything is stuck in there (pocket lint, Kit-Kat bar, etc.)
    - replace the port or have a place that does that kind of thing do it for you
    - send it to Samsung for repair

    Regarding the weird charging behavior - well, if it charges normally when it's ON, just leave it on when you charge it. I don't know enough about the phone's firmware to know why the charging behavior when it's off is different than when it's on, but there must be something to account for the disparity in behavior. Who knows, perhaps whatever is causing the connection issue is also causing the strange charging behavior.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 2
    09-07-2013 12:25 AM

Similar Threads

  1. Replies: 5
    Last Post: 01-20-2014, 08:54 AM
  2. Problems getting my Pre-Order today at Verizon!!!
    By Preach2k in forum Samsung Galaxy Note 3
    Replies: 24
    Last Post: 09-07-2013, 11:35 PM
  3. My almost black VZW HTC ONE.......
    By freddyttt in forum Verizon HTC One
    Replies: 2
    Last Post: 09-06-2013, 08:26 PM
  4. Audio interference from my Moto X??
    By Yooser in forum Moto X (2013)
    Replies: 3
    Last Post: 09-06-2013, 07:33 PM
  5. What's keeping my WiFi open?
    By Edible Walrus in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 09-06-2013, 07:16 PM
LINK TO POST COPIED TO CLIPBOARD