1. donaldo87's Avatar
    Hi Guys,

    I have been using my s3 for a yr now and wifi at home works fine until a few days back where I received the error msg: Authentication Error. Even after disabling the password, I have received the same error msg. I have looked up a few threads and tried disabling power saving wifi as suggested by some users but the error still persists. My mum does not encounter the same problem with her Nokia Lumia....any help would be much appreciated!
    10-11-2013 07:55 AM
  2. Haalcyon's Avatar
    Welcome to the forums!

    Sometimes the phones just freak out. You may want to backup and then do a factory reset if nothing else works.
    10-11-2013 08:03 AM
  3. GSDer's Avatar
    Try rebooting the router first.
    Then reboot the phone.
    BTW, I wouldn't leave the Wi-Fi connection unsecured (Open) except for test purposes.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    10-11-2013 05:27 PM
  4. donaldo87's Avatar
    Just tried my aunt's galaxy s4 and it connected well with my house wifi...think the issue lies with my phone...
    10-12-2013 04:14 AM

Similar Threads

  1. Galaxy S2 HeadPhone Jack issues
    By dharmil007 in forum Samsung Galaxy S II
    Replies: 9
    Last Post: 12-17-2014, 06:16 PM
  2. Samsung Galaxy S4 insane battery usage. overnight 50%
    By Mohit Hiralal in forum Samsung Galaxy S4
    Replies: 19
    Last Post: 11-17-2013, 06:00 AM
  3. Samsung keyboard....
    By jayp1306 in forum Samsung Galaxy Note 3
    Replies: 3
    Last Post: 10-12-2013, 01:18 AM
  4. Changes for HTC?
    By biggerloofah in forum HTC One M7
    Replies: 10
    Last Post: 10-11-2013, 04:46 PM
  5. Replies: 0
    Last Post: 10-11-2013, 03:30 AM
LINK TO POST COPIED TO CLIPBOARD