1. Callixtus81's Avatar
    Hi!

    I have the SIII (I9305) with android 4.1.2 (rooted).

    A few days ago my phone worked as normal, then suddenly it start charge very slow.. same cables as Ive always used. I googled the problem and some say its the usb cable, some say its hardware problems etc..

    Ive tried the original cable, and it charge normally with that one.. but all the other cables that worked before, does not work now. I can put it on charge 55% at night, and when I wake up 8 hours later its 47%..

    I rooted my phone yesterday to gain access to some tools to investigate this, and it seems its the USB STABILITY DETECTION that fails.
    I tried an app to check current when charging with original and random cable.

    Original gives these values.. : Maximum : 500, Now 999, Avg 500
    Random gives these values : Maximum 100, now 500, avg 100

    Both says AC in the battery stats. Both cables are the same quality measured by professional tools at work.

    Ive tried to googe about the USB STABILITY DETECTION, but cant find anything about how to turn it off, or override it..

    Is there anyone here who can help me with this problem ?

    Thanks
    10-26-2013 04:35 AM
  2. GSDer's Avatar
    I'm sure if you searched the Android code base for 'USB Stability Detection' you'd come across what you're looking for. But I'm not a developer so I can't point you to anything offhand.

    Your best bet would be to post over on XDA, or download the SDK and pull the code from one of the GIT repositories.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    10-26-2013 09:04 AM
  3. Callixtus81's Avatar
    Im not so advanced that I understand how to search the android code base, and I don't know whats XDA or GIT is, Im thinking more of an app or tutorial how to fix the charging problem.
    10-26-2013 12:18 PM
  4. GSDer's Avatar
    XDA is just a different forum where lots of Android developers hang out and discuss programming - modifications, different ROMs, rooting, etc.

    GIT (Github) is just a reference to a tool that's used to manage code.

    Sorry, I figured that if you were digging into the problem enough to have identified the code that was causing the issue you'd be into that stuff - my bad.

    I don't think you're going to find an app or tutorial that will help you along here. The current-monitoring tool that you found is probably the closest thing you'll come across, although obviously it doesn't explain why certain cables no longer charge properly.
    Either:
    a. there's a hardware problem with the micro-USB port
    b. there's a hardware problem with the charging circuit
    c. there's a firmware problem causing the strange behavior
    d. a combination of the above

    If the problem is a, a wireless charging solution might work (it completely bypasses the micro-USB port).

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    10-26-2013 12:39 PM
  5. Callixtus81's Avatar
    Ah, thanks for explaining.
    I used that app for confirming that two cables with the same numbers of pins and same transfer rate and thickness does not charge the same.. I then read on several forums that the S3 has a stability check and many people are experiencing this problem.. I read a little about the stability checker, and discovered this was updated in last android patch for s3.. making it faulty. Then I hoped there would be a wise guy out there who could tell me how or show me how to alter it, or come up with a solution for me and all the other people struggling with this problem.
    Adamsberg likes this.
    10-26-2013 12:46 PM
  6. Adamsberg's Avatar
    Interesting info about the Samsung's "USB Stabilty Detection" ... I thought it would only detect and measure a charger's modified data pins for to confim it's a Samsung charger ...

    Did you compare the electrical resistance of these generic cables' conductor wires with the Samsung cable?
    10-26-2013 01:36 PM
  7. GSDer's Avatar
    If this 'stability checker' was updated in the latest 4.1.2 build, you could certainly load a previous version of firmware and see if that cures the problem. You'd have to find the firmware for your model and carrier, and you could use Odin to load it. If you load a rooted firmware then you can easily block any update that may be pushed by the carrier (as you're probably already doing on your rooted phone).

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    10-26-2013 01:41 PM
  8. Callixtus81's Avatar
    I finally found an answear from samsung itself, hidden in a post in forum.. Samsung itself says the battery problem is because of the 4.1.2 update. Something about a double OS making a conflict, and the solution is flashing with a new official rom (but seems I cant find a unlocked for my phone). You are right that the detector confirms if its samsungs own cable but I cant understand how tho, as the cables have the same specs. Just mine is 5 meters long. Ive tried other cables too at same length, but not working anymore.. The weird thing is that it suddenly happend..
    Ive tried all the solutions in most the forums Ive been googled, resetting battery, calibrated the battery, rooted the phone, turned on and off usb feautures, other S3 battery and so on..

    I guess that if I can override the detector, I can trick the phone to think that all cables are samsung cable, and give me normal charge.. But seems nobody knows how to override this..

    Is there anyone who know where I can download the last official touchwiz ? Or anyone recommend something that really works ?

    My phone info :
    GT-I9305
    I9305XXCMH1
    Kernel :
    3.0.31-1153417
    dpi@dell221 #1
    SMP PREEMPT Wed Jul 31 19:57:18 KST
    2013

    Build nummer
    JZ054K.I9305XXBMG3

    Have no clue what all this means tho ^^
    10-26-2013 04:38 PM
  9. Adamsberg's Avatar
    I think your cable of 5 meters lenght is also a part of the problem.
    If the cable would've the same lenght as the Samsung's (1.2m ?) it might work properly.
    10-26-2013 05:47 PM
  10. Callixtus81's Avatar
    I dont see how the 5 meter cable can be a problem ? It worked perfectly just a few days before.. I have 3 of them as I have used in the bed and in the livingroom as where I sit or lay is far from a wall socket..
    It just suddenly didnt work anymore on any of them, and not the short 1 meter cables eighter. The only cable that works close to normal is the original samsung cable. So weird..
    10-26-2013 05:55 PM
  11. GSDer's Avatar
    You can check out http://live.samsung-updates.com/inde...evice=GT-I9305 to see if you can find the previous firmware for your phone.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    Callixtus81 likes this.
    10-26-2013 08:34 PM
  12. Callixtus81's Avatar
    Thank you so much, I finally found the right one

    So how does this work.. I gotta flash the kernel first and then the rom ? Any settings I should be aware of (with Odin) ?
    10-27-2013 07:08 AM
  13. GSDer's Avatar
    You don't have to flash a separate kernel - the ROM will include a kernel.

    As far as Odin goes, use the same settings (Auto reboot; F. Reset Time) that are generally recommended when flashing 3rd party ROMs. If you haven't used Odin yet you should read through some of the rooting sub-forums to be sure you're comfortable with it before you proceed.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    10-27-2013 01:14 PM

Similar Threads

  1. How Do You Like Your SSW2?
    By jtb79 in forum Sony Smartwatches
    Replies: 20
    Last Post: 08-04-2014, 10:24 AM
  2. Is there an app for detecting defective apps?
    By Drummerboy1975 in forum Sprint Galaxy S III Rooting, ROM's, and Hack's
    Replies: 5
    Last Post: 11-06-2013, 03:36 AM
  3. HTC One must be a good phone if Samsung is paying to bash them.
    By buzzyclonecattleman in forum HTC One M7
    Replies: 6
    Last Post: 10-25-2013, 10:40 PM
  4. How To Stop Roaming Data
    By ngoody315 in forum General Help and How To
    Replies: 2
    Last Post: 10-25-2013, 10:36 PM
  5. Replies: 0
    Last Post: 10-25-2013, 09:56 PM
LINK TO POST COPIED TO CLIPBOARD