1. lonerdude's Avatar
    So, my S3 started to freeze randomly so I would take the battery out and reboot it until it wouldn't boot past the initial s3 GT-I9300 screen (not the blue samsung splash screen) I tried to go into recovery mode, but it would go back to the screen. after a couple of times of me taking the battery out and rebooting, it asked me to do a factory reset...me being the ***** I am, I once again took the battery out etc...so I tried to do a firmware upgrade and initialization, but samsung kies does not detect my device ( my computer doesnt detect my device either, but it still installs the drivers and it doesnt charge) so can anybody PLEASE help me out? Or has my phone been destroyed?
    11-07-2013 12:44 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Are you able to boot into Recovery using these instructions? http://forums.androidcentral.com/sam...2-s3-tab2.html
    11-09-2013 12:59 AM
  3. B. Diddy's Avatar
    Is there anyway to go into recovery mode? In the process of recover files from Samsung?
    Did you try the link just above your post? And what do you mean by "In the process of recover files"?

    Posted via Android Central App
    11-24-2013 04:05 PM
  4. Mudassir5's Avatar
    Is there anyway to go into recovery mode? My s3 is struck in Samsung galaxy GT-i9300 i cant get into recovery mode but cant enter into download mode..:-( :-(:-( help...........
    12-19-2013 09:31 AM
  5. Bigg Chuck's Avatar
    I have same problem. Upgraded to whatever was pushed to my phone and now cannot get into recovery mode. Please help! I already went to Tmobile store (could not do anything), Samsung Experience Team @ Best Buy (useless for this type of a problem).
    03-28-2014 10:04 PM
  6. GSDer's Avatar
    Upgraded to whatever was pushed to my phone and now cannot get into recovery mode.
    Welcome to the forums!

    Your only problem is that you can't boot into Recovery mode? Or your problem is that your phone isn't booting normally and you're trying to get into Recovery mode and that's not working either?

    Will the phone boot into Download mode?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    03-29-2014 01:01 AM
  7. Nas Rule's Avatar
    my s3 cannot enter recovery mode. not reboot normally. when start with power button. it will only blinking samsung Galaxy S3 gt i9300. i ask someone and he said i need to reprogrammed it. how did i suppose to do that? i only can enter Download mode. This happen after i update my s3 to 4.3 by OTA. help please..
    04-11-2014 06:24 AM
  8. GSDer's Avatar
    how did i suppose to do that?
    Welcome to the forums!

    You could take it into your local carrier shop and they should fix it for you, since it happened as a result of the OTA.

    Or you could use a tool called Odin (just Google it - look for v3.07) and manually load the firmware, which can be found here - select your device in the drop-down list in the upper left corner, then mouse-over the region codes (this is much easier to do on a computer) and find your region/carrier and download the latest version.

    You can find instructions on how to use Odin in any of the rooting sub-forums or come back here when you're ready.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    04-11-2014 11:10 AM
  9. gdhanoa's Avatar
    Hello Folks,

    I am facing similar issue. I received an update to Android 4.3 about 2 weeks ago and since my phone is behaving weird. Most of the times, it goes into dead-lock mode displaying Samsung S3 GT - i9300 screen. On occasions, it does boot OK but not for too long.

    Unfortunately, I cannot take my phone to Samsung as it is out of warranty. I tried pressing "power+volume down and home screen" button, it displays the warning message where in I can either press Volume Up to proceed or Volume down to cancel - in both of the options, phone again goes back into dead-lock flashing the samsung s3 gt logo.

    Any help is appreciated!
    04-20-2014 03:30 AM
  10. Vinamre Sood's Avatar
    Hello Guys

    Need your help!!

    I rooted my Samsung Galaxy S3 GT-I9300 with Cyanogenmod 11 few months back..it was working perfectly fine till today, while i was using my phone camera and my phone freezed suddenly. Nothing was working..then i restarted my phone by long pressing the power button , but the phone is not starting up...first the samsung logo appears on the screen ..then it goes to boot animation of Cyanogen and gets stuck at it. nothing happens after that....I have tried to remove the battery and place it back and then starting the phone...issue still persists .. i have tried to bo the phone in recovery or download mode by using volume key, home and power button ..but nothing happens... i am not able to go to any mode and still stuck at the boot animation screen.

    Please please please help me
    01-11-2015 12:46 PM

Similar Threads

  1. How do I wipe my S3 completely clean??
    By hackerlife2013 in forum Samsung Galaxy S3 in Canada (Bell/Telus/Rogers)
    Replies: 2
    Last Post: 11-10-2013, 11:56 AM
  2. Chromecast doesn't work at all...
    By JSC7 in forum Google Chromecast
    Replies: 5
    Last Post: 11-07-2013, 03:50 PM
  3. Sprint Nexus 5, will it work on AT&T?
    By LowRentTechGuy in forum Google Nexus 5
    Replies: 4
    Last Post: 11-07-2013, 01:58 PM
  4. annoying messages lock screen "widget"
    By DaMaRa1109 in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 11-07-2013, 10:01 AM
LINK TO POST COPIED TO CLIPBOARD