1. wgw's Avatar
    My wife wanted me to look at her phone and fix the unread messaging notification that shows up on the icon. I see where there has been a lot of talk concerning the icon showing (1) when actually there are not unread messages. However I haven't seen anyone having her problem. If this is an old problem and has been addressed then I apologize and all I would ask is that you point me to that thread. Thanks for any information. She is still on 4.1.2 and on Verizon.
    11-19-2013 09:06 PM
  2. GSDer's Avatar
    So you're saying that on her phone she's getting messages but the Messaging icon doesn't reflect the count of how many messages she's received?

    If you go to Settings -> Application manager -> ALL and scroll down until you find Messaging and select it, is the 'Show notifications' checkbox checked?

    While in the ALL view, also look for BadgeProvider, select it and Clear cache, Clear data and Force stop, then restart the phone.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    burtonsinak and Jestercbrf3 like this.
    11-19-2013 11:17 PM
  3. burtonsinak's Avatar
    Thank you! I followed your instructions and have recovered my unread message # icon on top of the messaging icon.
    11-27-2014 05:02 PM
  4. traemccombs's Avatar
    Hate to necro this thread but I am having the same problem on my moto x 2nd gen Android. I have the latest version of Android L lollipop. I don't see application manager. Any ideas.
    09-12-2015 03:27 PM
  5. Medindexer's Avatar
    Hate to necro this thread but I am having the same problem on my moto x 2nd gen Android. I have the latest version of Android L lollipop. I don't see application manager. Any ideas.
    Did u find a solution. I have a moto g 3rd gen. And I have same problem
    02-20-2016 02:47 AM
  6. SoCalHunt's Avatar
    Did u find a solution. I have a moto g 3rd gen. And I have same problem
    Settings > Device > Applications > Applications Manager

    From there you can find your apps.. for BadgeProvider...

    Select More > Show System Apps > BadgeProvider

    To clear cache...

    Storage > Clear Cache
    12-06-2016 09:49 AM

Similar Threads

  1. Nexus 10 not playing any videos on Kitkat
    By stevenxu1018 in forum Legacy Android & Other OS's
    Replies: 7
    Last Post: 12-12-2013, 09:21 AM
  2. Contacts not showing up in Messaging
    By Danielle Brooks in forum Samsung Galaxy S4
    Replies: 3
    Last Post: 11-21-2013, 11:26 PM
  3. Video on tube sites not playing
    By Holysmoke in forum Google Nexus 7 Tablet (2013)
    Replies: 2
    Last Post: 11-19-2013, 04:33 PM
  4. Replies: 10
    Last Post: 11-19-2013, 03:54 PM
LINK TO POST COPIED TO CLIPBOARD