1. Foxwald's Avatar
    Hello, this is the first android device I've had, converting from IOS so I'm not too savvy on everything just yet.

    I seem to be having a lot of issues with the audio and songs in general. I have a 64GB Class-10 external SD which I am using to place music files onto, these music files are mainly mp3, although there are a few FLACs and fewer ALACs. Whenever I copy over songs (by copy and pasting folders into the "Music" directory on the SD card, all wired) they are seen by the music players (I have tried winamp, stock, mediamonkey, lithium, and the one I want to use, poweramp) but many of the songs are either being placed within the "Unknown Artist" category, of these none of them play and I get a "Unable to play file" error and even then some of the files I have which have the correct tags are unplayable with the same error message. I've had a long look around the internet at this issue and there doesn't seem to be any fixes (unless I've missed them, which I hope I have). A weird thing I've noticed is that files which did play well, if I was to carry out a "rescan" in poweramp no longer worked and would be moved to the "Unknown Artist" category even though they previously worked. Most of the files which do work were playlists which were synced up via J River Media Center but I get the same problems if I were to copy over non-playlist audio files. There doesn't seem to be a consensus between what file format works or doesn't work - I've had FLAC files working when the MP3 counterpart hasn't, etc.. and even half an album all working whereas the other half is unknown and unplayable.

    Another issue I've had is with the constant yet random pausing of my audio through all media players. Again, I've already had a look around the internet to see what people are suggesting and I don't have Google player on, and I've tried flight mode.

    I'd be greatful for any help, I'm a little peeved at the fact I'm now on a 2 year contract with a device that just doesn't seem to play well with audio.
    11-24-2013 10:31 AM
  2. GSDer's Avatar
    I'm a little peeved
    Prepare to be more than a little peeved

    Unfortunately, it sounds like you're running into a rather common issue on the Samsung Galaxy S3 (and S4 from what I've seen from some of those users that cross post here). The problem is likely to do with the SD card, and not the specific media or audio types that you're trying to play. For whatever reason (unsolved to date), files stored on SD cards tend to get corrupted, making them unplayable. Sometimes rebooting the phone 'fixes' the problem for a short time; most times it doesn't.

    Removing the corrupted files and replacing them often just results in other files getting corrupted. This issue seems to be independent of SD card size, brand or speed (although SanDisk got hammered for this problem and even released a 'fixed' batch of cards, which apparently still have the same problem). I even read one post about a Samsung 64GB card having the same problem.

    Long story short - you should try putting your music (obviously less of it) on the internal memory (hopefully you got the 32GB model) and see how it goes. As Levar Burton said on "Reading Rainbow" - but you don't have to take my word for it - just do a search in the forums and make your own judgment. Sorry to be the bearer of bad news.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    11-24-2013 11:41 AM
  3. Foxwald's Avatar
    Many thanks for the reply.

    I presumed as much, but with all the rave reviews the phone had I have never seen one commenting on this issue, which for me personally is a HUGE dealbreaker - the main reason I chose this phone was due to the ability to add an external SD card as I was wanting to use it as both a phone and to play music. It just seems highly weird that this issue has been allowed to continue into the S4 as well.
    11-24-2013 12:17 PM
  4. mrbowlman's Avatar
    I don't know if it's the same issue, but I've had horrible luck with various SD Cards. When I bought my phone, I bought a 32GB Sandisk SD Card. It worked fine for about a week, then I started having issues with music skipping, which turned into the phone saying the card was "unexpectedly removed." I couldn't seem to get it working properly, so I had Amazon replace the card. The next card did the exact same thing. I replaced this next card with another brand. (forget which) This new card worked for probably 2 weeks but then started doing the same thing. I then purchased a Samsung branded card. I've had the Samsung card for about a year now, and haven't had a single issue. I'm not sure the cause, but my phone definitely didn't like SD Cards from other brands.
    11-24-2013 02:08 PM
  5. Foxwald's Avatar
    Mmm, that is interesting - I've read in other threads of people having Samsung microSDs working.. Athough I should have mentioned the one I have is a Samsung too. Going to try a few tips I've read online and if all else fails I'll go and try to talk to Samsung/O2/anyone that'll listen.

    Also, something I've noticed is that it seems that there's a certain amount of data (around 7GB) which can be stored ok yet go over that limit and the data seems to overwrite itself.

    - Going to try formating the card to FAT32 instead of exFAT which I think it's at atm.
    11-24-2013 04:11 PM
  6. GSDer's Avatar
    Frankly, you might have better luck with a Samsung 32GB card than anything else - the 64GB cards seem really problem prone. YMMV.

    Edit: and good luck with Samsung - they won't even admit that there's a problem.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    11-24-2013 07:57 PM
  7. The1Metallian's Avatar
    I really have no idea what you guys are talking about. I have all my music stored on my SD and have no problem playing it. I would die! The differences between my procedures and those described by Foxwald are that I sync my music with Windows Media Player and that I use Rocket Player. But I've had no issues at all. I don't consider your problem normal and would try to replace the device.
    11-25-2013 12:53 AM
  8. 3x5's Avatar
    I'm glad to have found this thread, as I have been looking around for the better part of a year and not getting clear answers about this problem.

    Like others, I bought this phone so that I coud put a 64gb card in it and carry my music around. Not having this functionality is a total dealbreaker for me, too, and so now I wonder how I can exchange my device.

    I bought this thing last March of April, and had the problems described in the first post. I returned my SD card to Sandisk, who sent me a new card. It still didn't work, and I struggled with it for months, unti sending the phone to Samsung to have them fix the SD reader. They sent it back to me, I filled up my card, and immediately, most of the tags weren't read for my mp3s.

    One detail I should mention, that may be important, is that my computer is running Linux and is on an ext4 file system, while my card is FAT32. Is it possible that the different filesystems create permissions errors, and this is why this problem exists?

    Any advice would be much appreciated, but it sounds like the answer is to ditch the phone.
    02-08-2014 11:50 AM

Similar Threads

  1. Samsung Galaxy Note 3 - Anyone else wish they bought the galaxy S4 instead?
    By Dharma Jairam in forum Samsung Galaxy Note 3
    Replies: 118
    Last Post: 12-26-2013, 03:24 AM
  2. Replies: 2
    Last Post: 12-12-2013, 08:28 AM
  3. Verizon Galaxy S3 - slim bean rom help
    By TheJustPull in forum Verizon Galaxy S III Rooting, ROM's, and Hack's
    Replies: 3
    Last Post: 11-29-2013, 09:33 PM
  4. Ringtone Issues
    By bladerunner044 in forum Samsung Galaxy S4
    Replies: 13
    Last Post: 11-28-2013, 12:33 AM
  5. Need some help with SD card questions
    By marcopesce57 in forum Samsung Galaxy S4 Active
    Replies: 2
    Last Post: 11-24-2013, 06:05 PM