1. Mark Price's Avatar
    I've had a random thing happen to me. I have had a 32gb SD Card mounted in my Samsung Galaxy S3 phone for months now. Then today randomly as I was just sitting around using my phone suddenly I had a messaged saying that the SD card had come unmounted, I tried taking it out of my phone and placing it back in, but it wouldn't register at all. I then tried inserting it into my laptop and still it wouldn't register. I tried a 2gb SD card in my phone and it worked and also worked in my laptop. Has my Samsung branded 32gb CLASS 10!!! SD Card just randomly broken for no reason whatsoever? Please Help.
    11-27-2013 06:14 AM
  2. GSDer's Avatar
    More like your Samsung Galaxy S III has broken your Samsung SD card. Unfortunately it's a pretty common occurrence, but in your case when you contact Samsung to complain they can't point to a different phone vendor or a different SD card manufacturer to blame! Hah!

    All fun aside, someone posted that this was actually a core Android issue, but I didn't look at the issue-tracker to see if that was the case. All I can say was that I didn't have this problem on my Incredible or Thunderbolt. YMMV.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    11-27-2013 02:20 PM

Similar Threads

  1. Samsung Galaxy S5 - Fan Render and Spec Wish List
    By meashish in forum Samsung Galaxy S5
    Replies: 9
    Last Post: 01-15-2014, 03:02 AM
  2. Galaxy S3 Messaging stops working
    By Jerry Shen in forum Samsung Galaxy SIII I9300
    Replies: 2
    Last Post: 11-29-2013, 11:09 PM
  3. HTC One - Fb push notifications stop working.
    By Viren Chavda in forum HTC One M7
    Replies: 0
    Last Post: 11-27-2013, 03:52 AM
  4. Replies: 0
    Last Post: 11-27-2013, 12:49 AM
LINK TO POST COPIED TO CLIPBOARD