1. Edgar Rivera3's Avatar
    So I tried to update my galaxy s3 through kies . my phone is not rooted or anything. So I did everything that kies asked my like downloading an app and so on. Then while it was updating I left for sometime. Then when I came back my phone was stuck on a black screen with an android on it and it had a little download bar with it barely starting but stuck. I tried running recovery mode like it asked but it didn't work because my computer shuts down. I was trying to update to 4.3. Please I need help
    11-30-2013 04:17 PM

Similar Threads

  1. Sound quality with headphones?
    By dirtyjudo in forum Google Nexus 5
    Replies: 19
    Last Post: 12-03-2013, 07:31 AM
  2. Rooting Galaxy Nexus 4.2.1
    By Afterlife737 in forum Google / Samsung Galaxy Nexus
    Replies: 4
    Last Post: 12-01-2013, 01:51 PM
  3. Replies: 1
    Last Post: 11-30-2013, 03:30 PM
  4. Replies: 1
    Last Post: 11-30-2013, 02:36 PM
  5. Samsung Galaxy S4 - Contacts Error Android 4.3 Update
    By Michaelgibbs777 in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 11-30-2013, 01:39 PM
LINK TO POST COPIED TO CLIPBOARD