1. scynz1's Avatar
    Hi,

    I'd been having some trouble with my SGS3 for a while. Well a lot, especially with charging and this ghost data problem where the storage doesn't add up to how much should actually be there.

    I had been back and forth, mainly on this forum viewing all the different threads about it but today I finally rooted my phone and used Disk Usage to see where the problem lay, and it was with a huge log file which I managed to delete. You can do it that way, or you can do it the easier way, suggested on another forum which is:

    "You don't have to root your phones to fix this problem. Just dial *#9900# on the phone and then select from menu - delete dumpstate/logcat. I tested this solution on my SGS2 and it works. "
    Credit to damianoz here

    Good luck, and I hope this helps a lot of people.

    Cheers,
    Liam.

    P.S. Do many other people have an issue with the phone turning off (and requiring a battery pull) after you disconnect the charging cable when the battery is full? - I will have a search now as well.
    01-03-2014 05:08 PM
  2. SpookDroid's Avatar
    Nice tip, and I don't have an S3 but my a few friends do, and theirs DEFINITELY don't go berserk after they're done charging.
    scynz1 likes this.
    01-03-2014 05:44 PM
  3. meyerweb#CB's Avatar
    Hi,
    P.S. Do many other people have an issue with the phone turning off (and requiring a battery pull) after you disconnect the charging cable when the battery is full? - I will have a search now as well.
    Never happened to me, and I don't recall seeing anyone else describing this.
    scynz1 likes this.
    01-03-2014 06:53 PM
  4. Peter Brandt's Avatar
    You are Awsome !!!!!!!!!!!!!
    09-16-2014 05:51 AM
  5. nikhiels's Avatar
    Thanks that really helped me a lot!! Been trying to solve this issue, went from +-300mb available to 3.7gb... Really appreciate the tip!
    09-28-2014 08:21 AM
  6. Peadletipper's Avatar
    Hi....

    I've looked everywhere for a solution to lack of memory problems on my S3mini with out success. And then I saw your post *#9900# and thought yeah well this is just a phone number hey...

    But it REALLY DOES WORK !!!!! Wow thank you so much !!!!
    12-18-2014 10:40 PM
  7. muaid abdulkareem's Avatar
    thanks it worked!!!! amazing tip
    03-10-2015 01:37 AM
  8. Hebekaos's Avatar
    YES! THANK YOU damianoz!
    04-07-2015 03:14 PM
  9. Pat38's Avatar
    Is there a code for an LG Optimus? All this "data" is preventing this thing you call a phone from actually working like one! Thanks!
    04-07-2015 08:04 PM
  10. Gypora's Avatar
    Amazing, this really works!!!!!!!
    04-08-2015 08:26 AM
  11. mary24_lc's Avatar
    Hey tried it on my s 3 mini but it did not work. Can I uninstallSamsungAppsUNA2
    04-08-2015 06:29 PM
  12. AllottedBloom's Avatar
    heyy i have a LG Leon lte and its having that same damn problem the *#9900# doesnt work does anyone have any advice for me??
    07-11-2015 04:24 PM
  13. TimS5's Avatar
    Had to register to say thanks to the poster who mentioned *#9900#

    Worked on my S5, which didn't have enough space left for a system update. I'd tried ES file Explorer, moving apps to external SD and nothing worked; this did.

    Thanks again
    09-21-2015 08:28 AM
  14. Borchai's Avatar
    Hi,

    After some investigations on my phone due to the same problem, I worked out what was going on. At least, on my S3mini.

    1.- Go to Settings > Application manager
    2.- Tap and drag to see all the applications installed. Sort them by size.
    3.- Check the size of the biggest applications... and reckon if those sizes are consistent with the target of the application.

    In my particular case, the "Contacts Storage" application had a size of 2.5GB!!!! So:

    1.- I backed up my contacts exporting them to the SD card (.vfc file)
    2.- I tapped on the application and I cleared the data stored (tap on "Clear data" option")
    3.- I restored my contacts from the .vcf file

    I hope it helps you out.

    What I'm wondering is... how could a 6MB application reach a size of 2.5GB? What was stored in the file? I regreted I deleted it without checking it out previously...

    Cheers!
    11-17-2015 05:36 AM
  15. Nelson khumalo's Avatar
    Hi,

    I'd been having some trouble with my SGS3 for a while. Well a lot, especially with charging and this ghost data problem where the storage doesn't add up to how much should actually be there.

    I had been back and forth, mainly on this forum viewing all the different threads about it but today I finally rooted my phone and used Disk Usage to see where the problem lay, and it was with a huge log file which I managed to delete. You can do it that way, or you can do it the easier way, suggested on another forum which is:

    "You don't have to root your phones to fix this problem. Just dial *#9900# on the phone and then select from menu - delete dumpstate/logcat. I tested this solution on my SGS2 and it works. "
    Credit to damianoz here

    Good luck, and I hope this helps a lot of people.

    Cheers,
    Liam.

    P.S. Do many other people have an issue with the phone turning off (and requiring a battery pull) after you disconnect the charging cable when the battery is full? - I will have a search now as well.
    Thanks Liam, you helped a lot you know. WOW! IMPRESSED!.
    01-20-2018 02:49 AM
  16. swamrollbre's Avatar
    Well, the *#9900# did not work on my boost LG Power X in 2018....
    James Kennedy5 likes this.
    02-06-2018 08:30 PM
  17. Ark Blaze's Avatar
    Can you help me also, I need a code like that for Lenovo k4 note too
    03-19-2019 09:06 PM
  18. Ark Blaze's Avatar
    I have the Samee issue, my system data takes 7.something GB space out of 10.5
    03-19-2019 09:07 PM
  19. B. Diddy's Avatar
    Welcome to Android Central! It's likely that the OS and various preinstalled bloatware apps on your phone take up those 7 GB, so no special code will help clear things out. I'm pretty sure the dumpstate/logcat deletion trick is only for certain Samsung phones.
    03-19-2019 09:23 PM
  20. Kellj's Avatar
    "Just dial *#9900# on the phone and then select from menu - delete dumpstate/logcat. "

    Tried this on my S4, and no menu appeared. Even hit the call button, and then only a voice from Verizon telling me that number is not valid. Should that menu appear immediately on the phone screen? On my device,"System memory" is 6.26GM of 16 GB total space, and it's not Misc files, which total only .01GB of that 6.26GB!

    What I am doing wrong? Thanks!
    06-05-2019 04:29 PM

Similar Threads

  1. Moto X and T-Mobile - Miracast Data use?
    By Sunnyful in forum Moto X (2013)
    Replies: 28
    Last Post: 11-29-2015, 07:33 AM
  2. Galaxy s3 back of phone feels very hot
    By April Collins in forum US Cellular Galaxy SIII
    Replies: 3
    Last Post: 06-05-2015, 10:23 PM
  3. Tmobile Samsung galaxy s3 which model?
    By Sand Maggot in forum Samsung Galaxy S3
    Replies: 2
    Last Post: 01-06-2014, 01:09 AM
  4. Samsung galaxy s4 home button concern.
    By SNK Jason in forum Samsung Galaxy S4
    Replies: 2
    Last Post: 01-04-2014, 06:33 AM
  5. Samsung Note 1 or HTC One X which one?
    By muelo1000 in forum General News & Discussion
    Replies: 15
    Last Post: 01-03-2014, 11:07 PM
LINK TO POST COPIED TO CLIPBOARD