1. Natalia Balan's Avatar
    Hi everyone! This is a cry for help. My phone would not turn on.
    I tried:
    1. charging it - no reaction to the charger, no light showing the charger's plugged in, nothing at all (by taste battery seems charged)
    2. took the battery out for a few minutes then put it back in and plugged the phone - no reaction whatsoever
    3. checked a video in youtube about the possibly stuck power button, so tried to hit the power button against the table with battery out - no reaction
    4. pressing and holding power button for longer time
    5. pressing volume + menu button at the same time

    Do you have any suggestions at all, apart from the obvious try to buy a new battery, maybe??
    Thanks a million!!!
    01-04-2014 06:15 AM
  2. Golfdriver97's Avatar
    Welcome to the forums.
    I think a new battery is probably your best bet. Try that and see if it works. If you know someone who has an S3, as to try their battery for a few minutes. If theirs works in your phone, then you have you answer without really spending any money.
    01-04-2014 09:15 AM

Similar Threads

  1. CM Features on stock ROM
    By p3ntyne in forum Google Nexus 5
    Replies: 3
    Last Post: 01-08-2014, 12:53 PM