1. xcrap's Avatar
    Hi there.

    I've recently bought a Samsung Galaxy S3 INT. I've updated with CM11. All was working perfectly.
    Since I've return to Germany I've having problems in Wifi with my Hitron CVE-30306 Router. I can connect to Wifi, open webpages, apps everything, except images and thumbnails are taking years to load in apps like Facebook, Google Play or Instagram. But if i use the web browser everything works fine. The strange is that I have other devices connecting to this Wifi working perfectly, computers, TV, Blackberry and 2 iPhones. Also my Galaxy S3 wifi works perfectly in all other routers and with 3G. I've installed a temporary hotstop software in my laptop and it even works fine with that.

    I've tried to do everything in the router, change the router frequency, tried fixed channels, firmware update, etc etc and also in the phone, factory reset, static ip settings and I can't seem to get it working. It's so strange because it loads all the data, only picture seems to be having a problem to load. I've search everywhere but I can't find this particular problem. Did anyone else had the same ? Anyone can figure out what could be wrong ?

    01-05-2014 07:02 AM

Similar Threads

  1. Samsung Galaxy Centura Cases?
    By MaliciousDreamer in forum General Help and How To
    Replies: 3
    Last Post: 07-03-2014, 01:22 PM
  2. Nexus 7 wifi question
    By darktwins25 in forum General News & Discussion
    Replies: 7
    Last Post: 01-07-2014, 12:10 AM
  3. Replies: 5
    Last Post: 01-05-2014, 09:48 PM
  4. Can't factory reset Samsung Galaxy S
    By Mud Kip in forum General Help and How To
    Replies: 3
    Last Post: 01-05-2014, 12:50 PM
  5. question about samsung wireless charging cover
    By trdsol23 in forum Samsung Galaxy Note 3
    Replies: 3
    Last Post: 01-05-2014, 12:48 PM