1. sallen188's Avatar

    My phone switched itself off, tried to switch it back on but it does not load passed the "Samsung Falaxy SIII" page.

    I have tried, taking the battery, sim and memory card out, tried charging it again but nothing is working

    Any suggestions??
    02-18-2014 05:29 AM
  2. GSDer's Avatar
    With the phone completely off, if you connect the charger do you see a battery graphic, followed by a graphic showing the current battery level and charging activity?

    Have you tried booting into Recovery mode or Download mode?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk Pro
    02-18-2014 09:53 AM

Similar Threads

  1. Why does my Android phone think my partitioned SD card is damaged?
    By randomuser2349 in forum Android 2.3 Gingerbread
    Replies: 1
    Last Post: 02-27-2014, 02:28 PM
  2. HTC One: resetting phone to gain back memory doesn't seem to be working
    By airyip77 in forum HTC One Rooting, ROMs & Hacks
    Replies: 11
    Last Post: 02-24-2014, 10:58 PM
  3. Please help a Big Red Guy Out
    By diesteldorf in forum AT&T
    Replies: 12
    Last Post: 02-20-2014, 09:04 PM
  4. Replies: 3
    Last Post: 02-19-2014, 09:52 PM
  5. Problem with my tablet!
    By shynlyn in forum Samsung Galaxy Note 10.1
    Replies: 1
    Last Post: 02-18-2014, 03:00 AM