1. Aurelien Brandt's Avatar
    Hi, another newby to these forums! I've tried everything I can think of and am now turning to here in the hope that someone can help me!

    I recently updated my S3 with the new software update and since then I cannot access the Google Play store without having to accept the terms and conditions every single time!! Quite literally 20seconds after I've exited the play store and go back in I have to re-accept these terms and conditions. I tried clearing the cache and data to no avail and also checking my account details to confirm them as well as making sure the auto sync data is enabled but it doesn't seem to work. The reason I want this to stop (aside from it being incredibly annoying) is that I constantly have to go back to the settings to stop the apps I have from automatically updating and using up all of my available data!
    If anyone could suggest something i would greatly appreciate it!!

    03-04-2014 11:36 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! I assume you're referring to the Play Store's app cache and data that was cleared. Try clearing the system cache partition, which can sometimes help with various problems, especially after a system update. No personal data will be lost. http://forums.androidcentral.com/sam...2-s3-tab2.html
    03-04-2014 12:38 PM
  3. Aurelien Brandt's Avatar
    Hi, thank you for the welcome and suggestion! I do mean the play stores cache, yes.
    I tried to do that, but sadly my play store is still doing the same. It seems as if it just can't save my device with my account to realise when I am accessing it.
    03-04-2014 01:05 PM
  4. GSDer's Avatar
    Try going through each of the following (in Settings -> More (if using the Tab view) -> Application manager -> scroll right to the ALL tab) and clearing cache and data:
    Google Play services
    Google Play Store
    Google Services Framework

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk Pro
    03-04-2014 09:50 PM
  5. Aurelien Brandt's Avatar
    Tried your suggestion but im afraid it still prompts me for the terms of use.
    03-05-2014 11:43 AM
  6. GSDer's Avatar
    Time for a Factory Reset - sorry.
    Be sure to use something like Kies v3 to make a backup before proceeding.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk Pro
    03-06-2014 12:50 AM
  7. Aurelien Brandt's Avatar
    Ah darn it! Was hoping to avoid that... oh well. Thanks for all your help and suggestions!!
    03-06-2014 01:26 AM

Similar Threads

  1. Get rid of Google bar?
    By unstoppablekem in forum Google Nexus 4
    Replies: 11
    Last Post: 03-11-2014, 01:18 AM
  2. Where do web to pdf files store themselves?
    By Richard Dallaire in forum ASUS Transformer Pad TF701
    Replies: 2
    Last Post: 03-05-2014, 05:41 PM
  3. Google voice and gmail questions
    By ianhanson85 in forum Google Nexus 5
    Replies: 1
    Last Post: 03-04-2014, 06:41 PM
  4. Google+
    By thatdude93 in forum Samsung Galaxy S4
    Replies: 4
    Last Post: 03-04-2014, 03:22 PM
  5. Google play store issue
    By Tommo15 in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 2
    Last Post: 03-04-2014, 12:28 AM