1. Chelsy26's Avatar
    Hi guys.

    I received a message today about updating my phone. I eventually decided to update and it reached 100% and now won't turn on. I have taken the battery out and put it back in and nothing. I have done the manual recovery and did a factory reset and rebooted and still nothing. The Samsung logo comes on but then the screen goes blank. The charging icon appears sometimes but it's just grey and never moves. I have tried another S3 battery in it and it won't work but my battery worked in the other phone. Any help would be appreciated!!!
    03-20-2014 04:56 PM
  2. GSDer's Avatar
    You can try using a tool called Odin to flash the firmware again. You should be able to find the firmware for your phone here.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    03-21-2014 04:30 AM
  3. Herbalife Beth's Avatar
    Any luck? Mines just done the same!
    05-05-2014 10:54 PM

Similar Threads

  1. "Sign into Wi-Fi network" Message won't go away
    By tiedyelime in forum General Help and How To
    Replies: 4
    Last Post: 10-17-2014, 07:55 AM
  2. Z1 Compact KitKat 4.4.2 Update
    By dannywalls76 in forum Sony Xperia Z1 Compact
    Replies: 4
    Last Post: 07-21-2014, 09:11 PM
  3. Hard Bricked Samsung S3 Galaxy SPH-L710
    By salman121 in forum Sprint Galaxy S III
    Replies: 3
    Last Post: 03-25-2014, 12:01 AM
  4. 3gb tethering on $70 plan
    By GalaxyFan68 in forum General Carrier Discussion
    Replies: 3
    Last Post: 03-21-2014, 12:02 PM
  5. Unauthorized system
    By Ilanpalatn in forum Samsung Galaxy S4 Active
    Replies: 1
    Last Post: 03-20-2014, 06:12 PM