1. b799's Avatar
    I have a T-mobile S3 which I'm using with wind mobile in Canada... I've had it for over a year with no issues,until a few hours ago when it decided to not give me service anymore... I can still use data, but I have no signal and it says no service (this makes no sense, how can I have data, but not make/receive any calls?). This happened at the gym basement where I temporarily lost signal due to being underground... when I came upstairs, no signal. I tried restarting the phone a bunch of times, I checked the IMEI and it's still there, no error message, I put my sim into another wind phone and I had data and could make calls... Is it safe to say something is fried with my phone? Can I do something to fix it before I have to do a factory reset? (will that even save it?)

    03-22-2014 04:55 PM
  2. b799's Avatar
    So apparently my phone has been blacklisted... I don't know why as I have had it for over 1.5 years... anyway to whitelist it again?
    03-22-2014 11:11 PM
  3. dancing-bass's Avatar
    If you know it's a T-Mobile phone, I'd start with them. Find out why you've been able to use it for 1.5 years and now suddenly it's blacklisted. Ask them if there's anything you can do about it. As a shot-in-the-dark guess, I would say whatever account that phone was tied has been flagged as delinquent/non-payment. If that's the case the account will probably have to be caught up before anything can be done.

    Also talk to Wind - it might be a long shot, because your account is fine and the device you're using is NOT a Wind device... so they may not be able to help, but its worth a try.

    Other then that - there are illegal methods to get around it. I won't talk about how, because I don't know how, I don't want to know how, and the forum Mods and Administrators frown on the discussion of illegal practices. If you do choose to go that route you won't get any help here.
    03-22-2014 11:23 PM
  4. b799's Avatar
    Yea I have contacted both, Wind can't do anything, they said go to T-mobile, and of course T-mobile won't do anything and they pretty much gave me the some info as you did...Of course the phone was bought from a shop who got the phone's from the US... so who knows... at this point unless I go with the methods you mentioned the phone is pretty much bricked...
    03-22-2014 11:48 PM
  5. ogrenler's Avatar
    my wife has galaxy S3. let me just say i hate that phone very much/
    anyway she had a problem with calles(in and out), cause the call couldnt go through.it also said "no service area" with a sigh of a circle and a line in the middle.
    after hard work on that phone i found that there was a problem with the sim+sd card tray(it goes together) and after replacing that it worked fine with no problems!!!
    GSDer likes this.
    05-13-2014 12:37 PM

Similar Threads

  1. Android Device Manage only works on WiFi
    By richlaustx in forum AT&T Samsung Galaxy Note 3
    Replies: 6
    Last Post: 04-22-2014, 03:36 PM
  2. Galaxy S3: No service but data works
    By b799 in forum T-Mobile Galaxy S III
    Replies: 2
    Last Post: 03-26-2014, 03:02 PM
  3. Replies: 9
    Last Post: 03-23-2014, 02:51 PM
  4. Frozen at Boot Screen, No Power Button. Please help!
    By jpkmiec in forum Samsung Galaxy S II
    Replies: 1
    Last Post: 03-22-2014, 07:55 PM
  5. Replies: 0
    Last Post: 03-22-2014, 08:31 AM