1. inespere's Avatar
    My S3 died suddenly; it wouldn't charge properly, then stopped charging completely and now won't turn on again. I've tried recovery and download modes to no avail (it turns off completely after showing the Samsung welcome screen.)

    I've gotten a new phone and thought that my contacts were synced to my gmail account, but it turns out it wasn't working properly. I remember pressing my specific email account when I created new contacts, so I'm not sure why it didn't work... but I have lost a fair number of contacts. Any chance of getting them back? Is it possible that they are saved somewhere that I can access?
    04-05-2014 10:11 PM
  2. Johnly's Avatar
    I find this situation strange. It is typical for google to back up everything from whatever device is used. Have you tried looking for your contacts on your computer?
    04-05-2014 11:56 PM
  3. inespere's Avatar
    Google sync wasn't working properly. I had checked my google contacts on my desktop but they weren't there.

    Funny story with the phone, though (not too funny for me I guess):

    I had tried a million different things trying to revive the phone, and nothing was working at all - it just wouldn't load past the initial Samsung screen. I went out and bought a new phone. Still, I was determined to find out why it had died in the first place.

    Then I thought about it... The weird thing was, when I'd take out the battery and put it in again, it would automatically load the Samsung screen - but usually the phone wouldn't do that, since just putting the battery in wouldn't turn it on. Found a forum where people recommended smacking the phone against a table to get rid of a stuck power button. It worked.

    Annnnd I just signed a contract for my new phone. Life is cruel.
    04-07-2014 02:09 AM
  4. nedlogp's Avatar
    I have the same problem. Did you ever find a solution?
    09-02-2014 08:48 PM
  5. GSDer's Avatar
    I have the same problem.
    Which 'same' problem?
    - died suddenly
    - wouldn't charge well
    - wouldn't charge at all
    - Google sync didn't work
    Perhaps if YOU just explained your problem, when it started, what you've already tried, etc., someone could try to assist you.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    09-03-2014 08:59 PM

Similar Threads

  1. Bought this off Newegg but want to replace it various reasons....
    By Closingracer in forum Samsung Galaxy Note 10.1 (2014)
    Replies: 14
    Last Post: 06-15-2014, 03:30 PM
  2. Battery life down to 35% in 3 hours ?
    By Closingracer in forum Samsung Galaxy Note 10.1 (2014)
    Replies: 7
    Last Post: 04-22-2014, 04:37 PM
  3. Nexus 5: About to order
    By WildCatBBN3 in forum Google Nexus 5
    Replies: 137
    Last Post: 04-21-2014, 10:21 AM
  4. Any good apps to track tablet usage for kids?
    By Kelemvor33 in forum General Help and How To
    Replies: 1
    Last Post: 04-06-2014, 11:31 AM