1. ppnj4's Avatar
    I have a used AT&T Samsung Galaxy S3 16GB (model SGH-1747) that I bought of the previous owner. I've been using it on Straight Talk's BYOP sim card program since December 2013 when I bought it, it was probably a year or so old already. The phone has always worked great. Then a few days ago I was riding my bike and it fell out of my pocket. It hit on both the upper right hand corner and lower right hand corner of the casing (on the silver trim edge), but thankfully the screen was intact without cracking or scratching.

    When I got home I realized that the screen wouldn't turn on and I assumed the battery was dead so I switched it with the full battery from our other SG3. When the battery is put in, the phone vibrates, the screen shows the word "Samsung" and then switches to "Samsung Galaxy S III", then it goes black again. No matter how long I hold the power button nothing happens other than to repeat that process. I tried holding the Power button, Volume Up, and Home button at the same time - nothing. I tried again but using Volume DOWN - nothing. I tried holding both Volumes, Power, and Home - nothing. I've taken the battery out and smacked the side of the phone - repeatedly - on both my hand and the table - nothing....

    I know the screen and digitizer are fine or the words "Samsung" and "Samsung Galaxy SIII" wouldn't come up. I know the phone vibrates, and sometimes when I put the phone on the charger I get the battery icon with the circle in the center of it, but it doesn't show it charging - so I know it is getting power. Obviously, I do not have a warranty either and so I can't just pop into AT&T, Straight Talk, or the Samsung store to have them fix it. Any suggestions on what to try? When I took the back off all the components look fine, and I am sure that none of the buttons are stuck. Thanks for any help you can offer, another phone just isn't in my budget right now!!
    04-12-2014 02:56 PM
  2. GSDer's Avatar
    When the battery is put in, the phone vibrates, the screen shows the word "Samsung" and then switches to "Samsung Galaxy S III", then it goes black again.
    Welcome to the forums!

    Does this happen every time you take the battery out and reinsert it? If so, it sounds like the Power switch (on the mainboard) is damaged, depressed or defective (this has been a pretty common problem lately, even on phones that haven't been dropped).

    If that's the case, and no amount of fiddling will restore correct operation, you could get someone to desolder the existing switch (someone in the forums went so far as to break it off - I wouldn't recommend that) and order a replacement. In the meantime there would be ways to turn it on so that you could continue to use the phone until then.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    04-12-2014 07:19 PM
  3. ppnj4's Avatar
    Yes, it does happen every time I take the battery out and put it back in. It also happens when I push the power button. I know others have had power buttons that stick and releasing the button fixes the issue, but when I took the phone apart all the buttons seemed to have plenty of play and make a click sound when I push them in. But, it didn't occur to me the button could have a defect in connections.

    How can I turn the phone on so I can continue to use it? Any help would be appreciated! Also, is there a video on how to replace the power connection?
    04-13-2014 05:37 PM
  4. GSDer's Avatar
    How can I turn the phone on so I can continue to use it?
    What the other poster mentioned (after breaking off the Power switch) was that he held down the Volume Up + Home buttons, then connected the charger (which for some reason acted like a Power button press) and the phone started to boot into Recovery mode. Then he just restarted from there and everything was good.

    You can use the Home button to turn the screen on when the phone is asleep and there are apps (ex. Button Savior http://market.android.com/details?id=com.smart.swkey) that you can use to enter sleep mode.

    I haven't looked for a video online showing how to remove the Power switch but you may find something. If you don't know anyone that's into electronics your best bet may be to find a local place to do it or try http://mobiletechvideos.mybigcommerc...button-repair/

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    04-13-2014 06:33 PM
  5. ppnj4's Avatar
    The link you sent seemed like the best solution for the replacement. After having taken off the casing and getting down to the guts, I can see that the power switch module itself will require soldering, a magnifying glass, and a steady hand. I did remove the power button from the side of the phone but couldn't seem to get anything to happen. When you say break off the power button are you talking about the power button on the phone or the actual power module inside the phone?

    04-14-2014 08:41 AM
  6. GSDer's Avatar
    I was referring to the actual Power switch on the mainboard, and that was NOT my recommendation; merely a comment on what someone else did. If blowing the area out with compressed air or spraying contact cleaner doesn't help then the rest is best left to the professionals.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    04-14-2014 10:36 AM
  7. ppnj4's Avatar
    I sent the phone in yesterday to the company that was linked above. There is no guarantee that the issue will be fixed with the replacement of the power button, but it made sense as a viable solution. I know it's getting power and I know the screen is good, there didn't seem to be a great deal of other options. I appreciate all your help, and for others with similar problems I will update this thread when I receive the phone back...you should here from me in a week or two...if it's not fixed I guess we will move on to plan B!

    Shipping with insurance (to replace the phone in case of damage in transit $350) cost just under $13 plus $45 for the fix (that may or may not work, fingers crossed)...that puts me at about $60. Far cheaper than a new phone (Ebay $220-50/Amazon $350) but something to keep in mind. Had I bought insurance for it ($60) at the time of purchase I would still be at the same place but not worried that it's $60 lost if the power button isn't the issue...live and learn - I definitely bought the insurance for the phone my husband just ordered!
    04-15-2014 09:37 AM
  8. GSDer's Avatar
    Had I bought insurance for it
    you would have been paying a monthly charge (~$9/month?) plus the deductible (~$100?) so I'm not really sure you would have been ahead of the game. If you can afford a big charge in an emergency you could get something like a Moto X off contract for ~$350 and have a brand new phone with no additional commitment.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    04-15-2014 04:31 PM

Similar Threads

  1. Replies: 9
    Last Post: 08-04-2017, 09:11 PM
  2. slow charging on galaxy note pro 12.2
    By sdaisy824 in forum Samsung Galaxy Note Pro 12.2
    Replies: 34
    Last Post: 07-01-2017, 02:01 AM
  3. HTC One (M8): Hate and Love
    By SeanBlader in forum HTC One M8
    Replies: 29
    Last Post: 04-13-2014, 12:47 PM
  4. Bought a rooted sprint galaxy s4 and would like to stock It out.
    By ESA85 in forum Samsung Galaxy S4 Rooting, ROMs & Hacks
    Replies: 1
    Last Post: 04-13-2014, 07:18 AM
  5. How To get Internet Access On My Galaxy Gear.
    By Nika Lomtadze in forum Samsung Galaxy Gear
    Replies: 0
    Last Post: 04-12-2014, 01:41 PM