1. 18268's Avatar
    I have had my Samsung galaxy s3 for a about a year. Everything worked great until the WiFi and 4g stopped working. It says that i'm connected to WiFi or 4G but when I load up a app it won't work. For example, when I try to load up YouTube it would say "There was a problem with the network." My family's devices all work fine. I tried to restart my phone, reboot the WiFi router and none of it worked.
    04-19-2014 04:39 PM
  2. GSDer's Avatar
    Did anything else happen at the same time? Phone dropped? OS update?

    Sounds like the antennas got disconnected, or some bogus radio files got loaded.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    04-19-2014 06:16 PM
  3. Fafagu Tavai's Avatar
    The 4G on my Galaxy S3 it not working, the wifi good everything else's it working good only 4g it not working, I try turning it off n turn it back on and still don't work. Im in area with full 4g coverage nothing works. I can make calls and call out n texting no problem, only the 4g that doesn't work...
    Plz help!!!
    05-17-2014 12:48 AM
  4. EonVon's Avatar
    Ok, so I spent over 2 hours trying to fix this problem and I ran across this page in my search. Since I didn't find any solution on this page, I'll add my story to at least help out any stranger that crosses this This problem happened to me and my girlfriend, and this fixed both of our problems.

    Obviously, check to see that airplane mode is turned off. Then make sure mobile data is turned on under More networks.

    I initially had to switch over to the 3G network . This at least told me the phone was working. ( If you do this step and the phone still isn't getting data, i'm don't think this will help). Anyway, go in the settings menu by clicking More networks... Mobile Networks... Network Mode.and switching to CDMA. This on will cause your phone to reset. If your phone turns back on and has access to 3G, then I imagine this next step will work.

    So, to fix this, I updated everything in the setting under More... System Update,(PRL, Profile, Samsung Software, and Firmware) and then I reset my phone.and wholla 4G was back on.

    Hope this helps.
    11-26-2014 08:34 PM

Similar Threads

  1. hello all!! From the Pacific Northwest....a question about overseas travel and charging??
    By djmaher in forum New to the Forums? Introduce Yourself Here!
    Replies: 6
    Last Post: 04-21-2014, 03:53 PM
  2. Help With touch and lock sounds Please
    By BetterMost#AC in forum HTC One M8
    Replies: 4
    Last Post: 04-21-2014, 11:33 AM
  3. Replies: 1
    Last Post: 04-20-2014, 08:14 PM
  4. Replies: 6
    Last Post: 04-19-2014, 08:03 PM
  5. stuck on boot loop samsung galaxy s2 GT-I9100
    By npgodfather in forum T-Mobile Galaxy S II
    Replies: 0
    Last Post: 04-19-2014, 01:08 PM