1. nolanar's Avatar
    I was last charging and unplugged my S3 at 21:00 while at work at appx 86%. I arrived home around an hour later and it will not charge or even recognize a USB connection. I've used multiple outlets, cables, etc...nothing. I tried using my computers USB and an error pops up saying "A usb device is drawing too much power so it has been disabled" I find it hard to believe that something major could have gone wrong in an hour. Im hoping it's just my lack of tech knowledge. The device never felt over heated, or was dropped previous to the sudden battery problem. Any help is appreciated.
    05-25-2014 01:41 AM
  2. GSDer's Avatar
    Welcome to the forums!

    Have you tried taking the battery out for a few minutes and then reinserting it and, without turning it on, seeing if it will charge?

    Do you have a spare battery or someone that you can swap with temporarily?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    05-26-2014 09:44 PM

Similar Threads

  1. Worx Home stopped pop-up after upgrade to 4.4
    By Wesley Bell in forum Android 4.4 KitKat
    Replies: 4
    Last Post: 04-24-2015, 03:13 PM
  2. Moto G Vibration Motor stopped
    By Oliver Hyde in forum Moto G (2013)
    Replies: 5
    Last Post: 04-11-2015, 02:17 AM
  3. Galaxy S3 got wet...phone touch screen not working
    By anusha15 in forum Samsung Galaxy S3
    Replies: 3
    Last Post: 11-01-2014, 01:36 AM
  4. Replies: 7
    Last Post: 06-08-2014, 01:58 PM
  5. GALAXY S3 i9300 (INTL) Battery Charger, Voltage And System Issue
    By Salvator101 in forum Samsung Galaxy SIII I9300
    Replies: 0
    Last Post: 05-24-2014, 04:27 PM