1. electricity_kills's Avatar
    I have a Samsung Galaxy S3, which I am trying to learn how to create apps for, using an online tutorial:

    https://developer.android.com/traini...ndex.html?hl=p

    I've completed the basics and created the primitive app described, but I am having trouble using my phone to run this app. I can successfully create a virtual device and run my app, but I cannot seem to find the right driver for my phone. When I choose "Run" and try to select my phone as the device, this is what I see:

    Trying to create my own app,-device-chooser.jpg

    Has anybody done this successfully with the S3 and can point me to the right driver and what steps to install it? I'd really appreciate the help.
    05-29-2014 11:46 PM
  2. GSDer's Avatar
    Is there some reason that you don't just install the apk on your phone and run it?
    Do you have USB debugging enabled?
    Have you tried installing the Kies software? It should install all necessary drivers.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    05-30-2014 02:38 AM
  3. gozirra's Avatar
    If you're absolutely sure your existing driver isn't working, perhaps this development driver at Samsung will help.

    Samsung Andorid USB Driver for Windows | SAMSUNG Developers
    05-30-2014 10:46 AM
  4. electricity_kills's Avatar
    I tried using the driver gozirra linked to, with no better results.

    USB debugging is a checked box on the phone, but when I attach the phone with USB I don't see anything different than when I usually connect to charge. Is "Debugging mode" supposed to look different?

    I suppose I could try just downloading the .apk, but I was hoping to avoid that since eclipse is supposedly able to do this by itself. Not sure what else to try since I keep getting the same results as my first post.
    05-31-2014 10:55 AM
  5. gozirra's Avatar
    Have you tried a different port? One actually connected to the motherboard, not a front panel or through a hub? Don't just dismiss the suggestion, actually try it, wait for it to cycle through the various mounts.
    05-31-2014 12:11 PM

Similar Threads

  1. Ingress App?
    By P-raggles in forum Motorola Droid MAXX
    Replies: 6
    Last Post: 06-19-2014, 09:31 PM
  2. Make Chaton the default messaging app
    By Bridgette Woodruff in forum Samsung Galaxy S5
    Replies: 7
    Last Post: 06-11-2014, 11:27 AM
  3. Can't reply using voice to text messages
    By burningfenix in forum Samsung Gear 2 & Gear 2 Neo
    Replies: 3
    Last Post: 06-03-2014, 07:18 PM
  4. Been coming for a while to read threads but finally made an account!
    By zjones1008 in forum New to the Forums? Introduce Yourself Here!
    Replies: 9
    Last Post: 05-31-2014, 10:29 AM
  5. Replies: 1
    Last Post: 05-29-2014, 11:17 PM
LINK TO POST COPIED TO CLIPBOARD