1. zuren's Avatar
    I've been trying to search the forum but I fear I'm not using the correct search terms. Forgive me if this is/has been discussed.

    I have an unrooted Galaxy S3 on Virgin Mobile (Sprint) that received the Kit Kat 4.4.2 update yesterday. Everything worked fine post-update until I powered my phone down last night, now my mobile data is not working. WiFi works but once I'm out of range to where it should switch to 3G/4G, there is nothing (no connection, no 3G/4G icon). I did some general Google searching and found that this happening to others but the answers have little consistency. Some people said a reboot solved it, others pulled their battery, others took their phone in to have a patch installed, others recovered back to 4.3. Things I've tried:

    - Reboot (several times)
    - Power down and pull the battery
    - Toggle airplane mode on/off
    - Toggle mobile data on/off
    - Contacted Virgin Mobile customer support - awaiting a response

    I'm looking for other suggestions before I perform a factory reset, that I believe/hope will take me back to 4.3 if there is no other corrective action I can take. Thanks for any help!
    06-25-2014 02:10 PM
  2. GSDer's Avatar
    Please note that a Factory Reset will NOT revert the firmware to an earlier version. It will wipe the data from your internal memory (content on an SD card, if present, will be untouched), after which you will have to go through the standard setup process (pick a language, enter your Google account information, etc). The Google Play Store may start automatically downloading/installing your apps, and will reload whatever synced data you have (contacts, etc). But you'll still have to setup your Home screens and preferences. And of course all of your Candy Crush Saga progress will be lost.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    BMukherjee91 likes this.
    06-26-2014 10:18 PM
  3. gnr_2's Avatar
    I just set my phone permanently to 3G and home wifi to static IP and that seems to work.

    Sent from my "no longer 120° or battery guzzling" Sprint Galaxy Nexus, thanks to help from the AC forum
    06-27-2014 09:03 PM
  4. heratsoluer's Avatar
    good info, just set my phone permanently to 3G and home wifi to static IP and that seems to work. thanks
    gnr_2 likes this.
    06-28-2014 07:37 AM
  5. ELW1stcornet's Avatar
    I have the same problem. I did get the 3G back by going to settings -> mobile networks ( I think, could be similar name) and select CDMA only option. After rebooting I have 3G. I had the same problem once before with Jelly bean and I did complete restore of OS to get it back. I hope someone else knows more.

    12-21-2014 10:43 AM

Similar Threads

  1. Will the Verizon Moto G get 4.4.4?
    By CarrierPigeon in forum Moto G
    Replies: 23
    Last Post: 10-30-2014, 04:51 AM
  2. Kit Kat email loading problems
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-31-2014, 11:58 PM
  3. Android L Update
    By Diego Carmona in forum Google Nexus 4
    Replies: 18
    Last Post: 07-03-2014, 01:45 PM
  4. Replies: 2
    Last Post: 06-27-2014, 02:12 PM
  5. Force update?
    By Leslie Hatcher in forum HTC One M8
    Replies: 2
    Last Post: 06-25-2014, 11:52 AM