1. undsoweiter's Avatar
    Hello, I just had to update my galaxy s3 and it took my language settings away. My phone was in German and now after the update it is not anymore. The app I used to set it to German does no longer work because it is too far updated. The only languages I can set it too are English Spanish and three Asian languages. I can English but I prefer it in German. Must I wait for an updated language switcher app? My update I think is 4.3 so all the language switcher apps no longer work. This new update really messed up my phone. I hope some one can help me out by this. I'd appreciate it!

    Thank you,
    07-07-2014 09:58 PM
  2. GSDer's Avatar
    Welcome to the forums!

    Don't you have firmware for one of the German carriers? That should include Deutsche as one of the defaults.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    07-07-2014 10:41 PM
  3. undsoweiter's Avatar
    I am in the states therefore have an American phone through Verizon. German is not a default language.
    07-07-2014 11:06 PM
  4. GSDer's Avatar
    Ah, understood. This app Language Enabler http://market.android.com/details?id=com.wanam worked fine for me, but one of the requirements for the app is that your phone be rooted. I tried a couple of other apps that didn't have that requirement but they only showed the stock languages (the ones that you mentioned).

    If you think you may want to go that route you can check out http://towelroot.com

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    07-08-2014 01:27 PM
  5. undsoweiter's Avatar

    I have tried that app before but it didnt work. *How do i root it, so i can use it? im not sure exactly sure, what that means.
    07-09-2014 12:22 AM
  6. GSDer's Avatar
    I haven't used that root method (my phone is already rooted), but it looks like you just click on the lambda symbol, it'll download tr.apk to your phone, then just manually run the apk (from wherever it downloaded).Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    07-09-2014 12:15 PM
  7. undsoweiter's Avatar
    It says the instalation has failed for the tr root. Is there any other way i can get my phone rooted? Once it is rooted, then i can use the language enabler you used.

    Thank you much for your help.
    07-09-2014 03:11 PM
  8. GSDer's Avatar
    You can see if Saferoot http://forum.xda-developers.com/show....php?t=2565758 works.

    What version of firmware do you have on your phone?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    07-09-2014 05:15 PM
  9. undsoweiter's Avatar
    I got to step three, i plug my phone into computer, or? I have with usb. But nothing about debugging came up so i thought it was ok but step four confused me, where are such files located? I can't seem to find them. Excuse my many questions, all this is not so clear for me.

    And I'm not sure, what firmware means but i have update 4.3for galaxy s3.
    07-09-2014 10:29 PM

Similar Threads

  1. HTC One M8 Android update on Verizon
    By Picasso71 in forum HTC One M8
    Replies: 29
    Last Post: 09-21-2014, 09:01 PM
  2. Where can I get this phone in the USA??
    By Rhyalus in forum Sony Xperia Z1 Compact
    Replies: 4
    Last Post: 09-08-2014, 04:33 PM
  3. Update android tablet, & blackberry question too
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-07-2014, 09:15 PM
  4. Using a Verizon Phone on T-Mobile - Who Updates the Firmware?
    By toolworker in forum General Android Device Chat
    Replies: 0
    Last Post: 07-07-2014, 08:26 PM
  5. Going to home screen during call
    By Sylvia Grimes in forum Verizon Samsung Galaxy S4
    Replies: 0
    Last Post: 07-07-2014, 08:20 PM