1. TAO TAO's Avatar
    I get a white screen with grey horizontal lines when i boot my phone. Tried almost every idea that i read online. Even tried hitting the power button on the table a few times (not to hard) and nothing works.
    The only thing that seems to be working (partially anyway) is home+power+volumedown but then it says : "Downloading... Do not turn off target"
    I left it for about 30 minutes and then it just turns off. I would like to know if i can fix it myself or if it is worthed to go to a repair center...
    Thank you !

    In the past i read a few topics on androidcentral so i decided to join because it looks like there are a lot of users with good knowledge that might be able to answer my question / solve my problem.
    10-19-2014 04:14 PM
  2. GSDer's Avatar
    The behavior that you describe for Download mode is exactly what it should do - it'll stay in Download mode until you either download firmware to it, reboot it or until the battery dies.

    If the screen looks normal in Download mode then there's probably not a hardware problem. Hopefully if you install the correct firmware that'll take care of your weird screen issues.

    What model/carrier/firmware?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    TAO TAO likes this.
    10-20-2014 12:39 AM
  3. TAO TAO's Avatar
    galaxy s3 / o2 ireland / jellybean i think, not sure. i heard that the mother board could be gone
    Thank you for the reply !
    10-21-2014 10:30 AM
  4. TAO TAO's Avatar
    I tried everything ... nothing worked so i went to a repair center. They told me that the mother board is gone and it costs 110 euro to get it replaced
    Thank you very much for your answer GSDer !!
    10-21-2014 05:15 PM
  5. GSDer's Avatar
    Does the phone still boot into Download mode correctly (you may need to charge it first)? If so, you could try reloading the firmware.

    With the phone completely off, if you connect the charger do you see the battery graphic showing the current battery level and charging activity?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    10-23-2014 03:28 AM

Similar Threads

  1. Why is my Bluetooth device connected but still won't work?
    By cameron emerson in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 2
    Last Post: 01-20-2015, 12:59 PM
  2. Note 4 Is there really a gap in your phone?
    By Sammuel1973 in forum Samsung Galaxy Note 4
    Replies: 67
    Last Post: 01-16-2015, 09:18 AM
  3. Which Smartphone is the best suited for my specific needs?
    By DarkkPhenixx in forum Ask a Question
    Replies: 12
    Last Post: 10-31-2014, 08:29 PM
  4. Replies: 2
    Last Post: 10-20-2014, 12:47 PM
  5. Replies: 0
    Last Post: 10-19-2014, 04:11 PM
LINK TO POST COPIED TO CLIPBOARD