1. mhernandez49's Avatar
    I have a Galaxy S3 (SGH-I747) with ATT. The problem started when I downloaded the previous software update. I've tried all the solutions suggested such as, turning on airplane mode, taking out the battery, etc. and nothing has worked. I was hoping the new software update would solve the problem, but no such luck. When my mobile data is turned on, my wife says that it is turned off. Is the factory reset the only solution? I'd rather not go through that. Can someone help?
    11-19-2014 03:34 PM
  2. anon(5600632)'s Avatar
    On the same phone, I had good results with a free app called WiFi Matic (the one by Prados - there are others with similar names). You can set it to turn WiFi on and off as you do/don't need it. In the advanced settings, there's a check box to turn off mobile data when WiFi is connected. It also seems to help with battery life.
    11-19-2014 09:24 PM
  3. mhernandez49's Avatar
    Thanks for the advice. I will check the app you mentioned. It's frustrating because before the "evil" software update my phone was working fine. When there was a wi-fi connection, the phone automatically used the wifi and not the mobile data. Now, even though the Smart network switch is checked, the mobile data overrides the wi-fi. When I check my wi-fi connection it says: "Turned off." In order to use wi-fi, I have to turn off the mobile data.
    11-21-2014 07:39 AM
  4. anon(5600632)'s Avatar
    Try unchecking that Smart Network switch. While it's intended to stabilize your connection, I find it encourages excessive switching between WiFi and mobile data. Most WiFi connections, including strong ones, have brief hiccups. Unchecked, you notice nothing or a brief pause. But checked, you get the switch to, and use of mobile data.
    11-21-2014 01:18 PM
  5. AxlMyk's Avatar
    I deleted my Wifi connection info and re-logged into it. Seems to have helped for the last month or so.
    11-21-2014 05:39 PM
  6. mhernandez49's Avatar
    Thank you all for your suggestions. I have tried them all. Nothing works. I even have a new router. I have to turn off my mobile data in order for the wifi to work. Otherwise, the wifi network says: "Turned off." Is anyone else having this problem and can't get it fixed? Who do I turn to for help? I guess it's a Samsung issue? The only thing I haven't tried is the reset. I am afraid to lose important information if I reset!
    11-25-2014 08:10 AM
  7. GSDer's Avatar
    Welcome to the forums!
    When my mobile data is turned on, my wife says that it is turned off.
    When my 'mobile data' is turned on my wife usually says that she is turned off as well (usually accompanied by a headache).

    Heh heh - sorry, that was too good to pass up.

    On a serious note, it does sound like the update screwed something up, and your best bet is a Factory Reset. If you're concerned about data loss you could try using the Kies software on your computer to backup your information (contacts, SMS/MMS, pictures/videos, call logs and various settings).
    There are apps you can use to backup some things (ex. Cloud Drive http://market.android.com/details?id...uddrive.photos
    Helium http://market.android.com/details?id...ikdutta.backup
    Super Backup http://market.android.com/details?id...up.smscontacts) either to the cloud or to an SD card (if present).
    11-25-2014 10:40 AM
  8. mhernandez49's Avatar
    Your joke was funny. I can empathize with your wife.

    Thanks for the advice. I guess I will just have to find a way to back everything up and do the reset. I just got an SD card, so that will help.
    11-25-2014 11:14 AM

Similar Threads

  1. Rooting Samsung Galaxy SIII?
    By designwebs in forum Verizon Galaxy S III Rooting, ROM's, and Hack's
    Replies: 5
    Last Post: 01-26-2015, 06:13 PM
  2. app missing since lollipop update
    By Alexi Kyrkilis-Kalathas in forum Google Nexus 5
    Replies: 2
    Last Post: 11-19-2014, 05:18 PM
  3. Accidentally disabled (I think?) s health Galaxy s5
    By debfox@yahoo.com in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 11-19-2014, 03:57 PM
  4. Why does my Moto G (4G LTE) prioritize mobile over wifi when wifi is available?
    By joeschmoeblahblahACacct in forum Ask a Question
    Replies: 1
    Last Post: 11-19-2014, 02:06 PM
  5. international SIM unlock seems gone after factory reset
    By zeeke42 in forum Sprint Samsung Galaxy S4
    Replies: 0
    Last Post: 11-19-2014, 02:00 PM
LINK TO POST COPIED TO CLIPBOARD