1. lookatdatbooty's Avatar
    Lately I have been experiencing issues with my Samsung Galaxy S3. It has been running slow on occasion along with glitching and lagging out. What I mean by glitching and lagging out is that it will randomly start typing or switching back and forth from an app to the home screen. Basically, it's being a crack head of a phone. It's most recent malfunction was it randomly shutting off WHILE IT WAS ON THE CHARGER when I was watching a video. Now the phone will not boot up. It will stay at the screen where it says, "Samsung Galaxy S3" for about 30 seconds then randomly shut off again. I've tried to boot in safe mode: it didn't work. I've tried to take the battery out and hold the power button to drain any residual electricity: it didn't work. I've tried to charge the battery alone in theory that the charging port on the phone was bad and the phone was not booting due to lack of charge in the battery: it didn't work; when I plug the charger in, it will show an empty battery with the loading circle in the middle of it for about 5 seconds, then shut off. I've also tried to put the phone in recovery mode; when I do this I get passed the phone model screen, but that's about it. The next screen that pops up is the android logo, laying on its back with a caution sign above it. It then reads exactly as follows:

    E: failed to mount /data (Invalid Argument)
    E: failed to mount /system (Invalid Argument)

    # Manual Mode #
    -- Appling Multi-CSC. . .
    E: failed to mount /system (Invalid Argument)
    can't mount '/system' (Invalid Argument)
    E: failed to mount /data (Invalid Argument)
    can't mount '/data' (Invalid Argument)
    E: Error in /cache/recovery/last_recovery (I/O error)
    E: failed to mount /data (Invalid Argument)
    E: Can't mount /data/log/recovery_log.txt

    I have no clue what to do at this point and would really appreciate some help. Thanks in advance.
    12-16-2014 04:18 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Have you tried a new or different battery?
    12-16-2014 10:33 AM
  3. lookatdatbooty's Avatar
    No I haven't, unfortunately I do not have a replacement battery, and cannot afford one at the moment. Could the battery be causing this issue? Even with all the firmware errors?
    12-16-2014 12:30 PM
  4. B. Diddy's Avatar
    It's worth testing a new battery. Those errors you were getting only appeared in Recovery Mode, which doesn't necessarily have to do with the power issues. Try going to your local cellphone or electronics store and ask them if it's possible to test out a new S3 battery.

    S3 replacement batteries aren't too expensive, by the way. Check out this selection on Amazon: Amazon.com: batteries for galaxy s3
    12-16-2014 05:11 PM

Similar Threads

  1. How to connect an XLR mic to Galaxy Note 10.1?
    By voxangelorum in forum Samsung Galaxy Note 10.1
    Replies: 2
    Last Post: 12-23-2014, 10:37 AM
  2. Samsung Galaxy Note 4 vs. Google Nexus 6
    By connecticut472 in forum Samsung Galaxy Note 4
    Replies: 3
    Last Post: 12-16-2014, 03:39 AM
  3. How do I make T-mobile Softcard app work in a AT&T Galaxy S3?
    By rythym05392 in forum Ask a Question
    Replies: 0
    Last Post: 12-16-2014, 02:13 AM
  4. Can I get some help with Smart Remote on my Galaxy S5?
    By RaggTagg in forum Samsung Galaxy S5
    Replies: 0
    Last Post: 12-16-2014, 12:02 AM
  5. Anyone know why OTA is preferred method for 21.44.8?
    By Johnny Fever in forum Motorola Droid Turbo
    Replies: 1
    Last Post: 12-15-2014, 11:41 PM
LINK TO POST COPIED TO CLIPBOARD