1. anon(9262186)'s Avatar
    Hi everyone!

    First off, thanks in advance for your help. I've read through the majority of threads that relate to the S3 not turning on (on this site and others), and I've unfortunately not been able to find a viable solution.

    From my understanding, my circumstance is a bit unique in that I don't think my phone wants to stay on... When I hold down the power button, there is no slight vibration nor does it turn on (splash screen and all). It stays completely black. I've tried to start it on Safe Mode and Download Mode multiple times, but (to my knowledge) because it doesn't even turn on in the first place, I am unable to get to those modes. I've also tried the whole shebang when it comes to hitting the power button multiple times and whatnot.

    The only time that my phone vibrates and shows the splash screen is when I:
    1. Take out the battery and put it back in. This only vibrates, shows the SAMSUNG logo, and then immediately shuts off. It does not even show the Samsung Galaxy SIII splash screen.
    2. Take out the battery and plug the phone in to a charger. This vibrates and also shows the SAMSUNG logo, which also then immediately shuts off. This is more clear that it shuts off immediately due to the red LED notification light showing that it charges turning off about a second after it turns on. To turn on the red LED notification light or to show the Samsung logo again, I must unplug the phone and plug it back in.

    Because the phone itself will not turn on (or at least for more than a second or so), my computer does not recognize that it is connected when I try to connect it to Kies. Thus, I am unable to do a firmware reset.

    My S3 model is the SGH-T999V, and am currently with Wind Mobile (Canada). My warranty is up, and so I cannot take it back to Wind to get it fixed.

    Thanks for any of your suggestions in advance!
    01-02-2015 03:19 PM
  2. GSDer's Avatar
    Welcome to the forums!

    You've described classic Power Button failure behavior. Either the Power button (the plastic piece that you press on) or the actual Power switch on the mainboard is malfunctioning/stuck. If smacking the phone on the side didn't do anything to unstick the Power button then you'll probably have to open it up to get at the Power switch on the mainboard.

    If you're really desperate you could break the Power switch off (there are ways to still turn the power on without it), but it would be better to get it replaced. If you're not handy with soldering you can probably find an electronics shop in your area that could do it.
    01-03-2015 02:44 PM

Similar Threads

  1. Replies: 3
    Last Post: 06-01-2015, 12:38 PM
  2. Replies: 1
    Last Post: 01-03-2015, 10:08 AM
  3. Why won't my Droid Turbo connect to wifi?
    By private hazzard in forum Ask a Question
    Replies: 1
    Last Post: 01-03-2015, 12:36 AM
  4. Motorola g will not charge/ turn on??
    By jellywishes in forum Moto G (2013)
    Replies: 1
    Last Post: 01-02-2015, 03:53 PM
  5. Why won't my Samsung Galaxy Note 4 Facebook App refresh on wifi?
    By David Rosen in forum Samsung Galaxy Note 4
    Replies: 0
    Last Post: 01-02-2015, 01:53 PM
LINK TO POST COPIED TO CLIPBOARD